aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-01-02 03:41:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-01-02 04:05:24 +0000
commit8d288f66cb850d65f4ff987fc010caf5ef2045a1 (patch)
treec35f10d79019f37395c83fba27fc0c532a60fb26
parent805697b0b5ed49886bea4fd8b47844143ffa8eea (diff)
downloadports-8d288f66cb850d65f4ff987fc010caf5ef2045a1.tar.gz
ports-8d288f66cb850d65f4ff987fc010caf5ef2045a1.zip
graphics/blender: add missing dependencies for WAYLAND=on
$ make clean all WITH=WAYLAND [...] -- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) -- wayland-client not found, disabling WITH_GHOST_WAYLAND [...] -- wayland-protocols not found, disabling WITH_GHOST_WAYLAND [...] $ env -u DISPLAY blender GHOST: failed to initialize display for back-end(s): ['X11'] GHOST: unable to initialize, exiting!
-rw-r--r--graphics/blender/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index bb531c07e9ea..ce43fef8a58e 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -178,6 +178,8 @@ TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
TRACE_CMAKE_BOOL= WITH_POTRACE
TRACE_LIB_DEPENDS= libpotrace.so:graphics/libpotrace
WAYLAND_CMAKE_BOOL= WITH_GHOST_WAYLAND
+WAYLAND_USES= pkgconfig
+WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.15:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libdecor-0.so:x11-toolkits/libdecor \
libxkbcommon.so:x11/libxkbcommon
WEBP_CMAKE_BOOL= WITH_IMAGE_WEBP