aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2025-02-28 01:17:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2025-02-28 05:57:54 +0000
commit8d540c5a2008e0b00a92ee316494b368c962407e (patch)
treebda5cf3b3949b6439530b26ef916775c33601c1b
parent533d5d02970f8ec962185f0b22f371c8bb4d10f3 (diff)
math/costa: Brokeb where OpenMP isn't available
Reported by: fallout
-rw-r--r--math/costa/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/costa/Makefile b/math/costa/Makefile
index 7a0ba2039147..b636911a3242 100644
--- a/math/costa/Makefile
+++ b/math/costa/Makefile
@@ -26,6 +26,10 @@ CMAKE_ARGS= -DCOSTA_SCALAPACK=CUSTOM
CMAKE_OFF= COSTA_WITH_TESTS
CMAKE_TESTING_ON= COSTA_WITH_TESTS
+.if !exists(/usr/include/omp.h)
+BROKEN= requires OpenMP support that is missing on this architecture
+.endif
+
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= MPICH OPENMPI
OPTIONS_DEFAULT= MPICH