aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-04-17 13:08:47 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2024-04-19 16:07:41 +0000
commit8d540f0bc78e7104ae79469baebeb125046edb82 (patch)
tree591e535479f281027086b9d220875392cfddf2c4
parentc2203040e9a64b659c4098a7b981c312df5a3733 (diff)
downloadports-8d540f0bc78e7104ae79469baebeb125046edb82.tar.gz
ports-8d540f0bc78e7104ae79469baebeb125046edb82.zip
sysutils/conky: update to 1.20.1
Bugfix over the short-lived 1.20.0 ChangeLog: https://github.com/brndnmtthws/conky/releases/tag/v1.20.0 Features * Build AppImage separately per OS * Rotate appimage signing key * Add/use clang 15 on ubuntu builds * Define text_object.data.l as "long long" * Bump web deps, fix lint * Updated flake per NixOS/nix#5532 * Fix bad imlib2 typedefs for imlib<1.10 * Use --force with brew install, block upgrades * Tidy up docs * Update README.md * Update README.md * Handle external PropertyNotify events * Label dependency changes * Tweak XSendEvent arguments * Add modified date to web docs * Improve documentation for window types and hints * Refactor x11 event handling * Issue template: Link docs to obtain stack traces * Exclusive XInput event handling Bug fixes * Enable wayland in appimage build * Fix regression in lua_load path handling * Lua imlib2 fixes * Increase max length of ACPI temp (fixes #977) * Skip propagation of non-input events * Fix render order in draw_stuff * Fix event propagation on Openbox * Fix missing y_abs argument copy
-rw-r--r--sysutils/conky/Makefile2
-rw-r--r--sysutils/conky/distinfo6
-rw-r--r--sysutils/conky/files/patch-lua_CMakeLists.txt4
-rw-r--r--sysutils/conky/files/patch-src_display-x11.cc26
-rw-r--r--sysutils/conky/files/patch-src_x11.h6
5 files changed, 35 insertions, 9 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index ce91add6cdad..241bb9031ebb 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -1,5 +1,5 @@
PORTNAME= conky
-PORTVERSION= 1.19.8
+PORTVERSION= 1.20.1
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
diff --git a/sysutils/conky/distinfo b/sysutils/conky/distinfo
index 91f8cccb26c6..50efb30b9efe 100644
--- a/sysutils/conky/distinfo
+++ b/sysutils/conky/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1709105678
-SHA256 (brndnmtthws-conky-v1.19.8_GH0.tar.gz) = 8ac01452554559ace15e5966cb65eb37ef73b98c72967e6e0974c7ba98a1a88d
-SIZE (brndnmtthws-conky-v1.19.8_GH0.tar.gz) = 1711683
+TIMESTAMP = 1713443191
+SHA256 (brndnmtthws-conky-v1.20.1_GH0.tar.gz) = 5e0531d1bbb589ee2369876340c341073d3bc13f8a79c05f89ec6170d6374085
+SIZE (brndnmtthws-conky-v1.20.1_GH0.tar.gz) = 1839204
diff --git a/sysutils/conky/files/patch-lua_CMakeLists.txt b/sysutils/conky/files/patch-lua_CMakeLists.txt
index 9bd166966418..16473e5f4093 100644
--- a/sysutils/conky/files/patch-lua_CMakeLists.txt
+++ b/sysutils/conky/files/patch-lua_CMakeLists.txt
@@ -1,6 +1,6 @@
---- lua/CMakeLists.txt.orig 2023-02-18 14:34:53 UTC
+--- lua/CMakeLists.txt.orig 2024-04-17 02:04:14 UTC
+++ lua/CMakeLists.txt
-@@ -31,6 +31,8 @@ if(BUILD_X11)
+@@ -30,6 +30,8 @@ if(BUILD_X11)
get_filename_component(X11_SM_LIB_PATH ${X11_SM_LIB} DIRECTORY)
link_directories(${X11_SM_LIB_PATH})
diff --git a/sysutils/conky/files/patch-src_display-x11.cc b/sysutils/conky/files/patch-src_display-x11.cc
new file mode 100644
index 000000000000..6daaa35ff2d6
--- /dev/null
+++ b/sysutils/conky/files/patch-src_display-x11.cc
@@ -0,0 +1,26 @@
+--- src/display-x11.cc.orig 2024-04-17 02:04:14 UTC
++++ src/display-x11.cc
+@@ -762,7 +762,9 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
+ conky::display_output_x11 *surface, Display *display, XEvent &ev,
+ bool *consumed, void **cookie) {
+ if (ev.type != EnterNotify && ev.type != LeaveNotify) return false;
++#ifdef BUILD_XINPUT
+ if (window.xi_opcode != 0) return true; // handled by mouse_input already
++#endif
+
+ bool not_over_conky = ev.xcrossing.x_root <= window.x ||
+ ev.xcrossing.y_root <= window.y ||
+@@ -771,11 +773,13 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
+
+ if ((not_over_conky && ev.xcrossing.type == LeaveNotify) ||
+ (!not_over_conky && ev.xcrossing.type == EnterNotify)) {
++#ifdef BUILD_MOUSE_EVENTS
+ llua_mouse_hook(mouse_crossing_event(
+ ev.xcrossing.type == EnterNotify ? mouse_event_t::AREA_ENTER
+ : mouse_event_t::AREA_LEAVE,
+ ev.xcrossing.x, ev.xcrossing.y, ev.xcrossing.x_root,
+ ev.xcrossing.y_root));
++#endif
+ }
+ return true;
+ }
diff --git a/sysutils/conky/files/patch-src_x11.h b/sysutils/conky/files/patch-src_x11.h
index c0a45206d133..24e397f56352 100644
--- a/sysutils/conky/files/patch-src_x11.h
+++ b/sysutils/conky/files/patch-src_x11.h
@@ -1,4 +1,4 @@
---- src/x11.h.orig 2022-12-26 18:54:10 UTC
+--- src/x11.h.orig 2024-04-17 02:04:14 UTC
+++ src/x11.h
@@ -22,6 +22,7 @@
*
@@ -7,8 +7,8 @@
+#ifdef BUILD_X11
#pragma once
- #include <X11/Xatom.h>
-@@ -157,3 +158,5 @@ extern priv::use_xpmdb_setting use_xpmdb;
+ #include "config.h"
+@@ -246,3 +247,5 @@ extern priv::use_xpmdb_setting use_xpmdb;
#else
extern priv::use_xpmdb_setting use_xpmdb;
#endif