aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-09-07 19:54:19 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-09-07 19:54:19 +0000
commit8d8939752a41658e5c1f48e3c36e7d0489a64653 (patch)
tree8a2380f86595071537b89359b4cc15ae428a4a23
parentdd4cf80985260e31e095fbfd8886b86345dddb59 (diff)
downloadports-8d8939752a41658e5c1f48e3c36e7d0489a64653.tar.gz
ports-8d8939752a41658e5c1f48e3c36e7d0489a64653.zip
Add devel/libast, "A library of assorted spiffy things, previously known as
libmej, the Eterm helper library". This port is required by the Eterm 0.9.1 upgrade. Submitted by: Jeremy Norris <ishmael27@home.com>
Notes
Notes: svn path=/head/; revision=47508
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libast/Makefile27
-rw-r--r--devel/libast/distinfo1
-rw-r--r--devel/libast/files/patch-libast.h10
-rw-r--r--devel/libast/pkg-comment1
-rw-r--r--devel/libast/pkg-descr2
-rw-r--r--devel/libast/pkg-plist6
7 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 367a2bac855f..512580fe58e9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -202,6 +202,7 @@
SUBDIR += leoarg
SUBDIR += libPropList
SUBDIR += libU77
+ SUBDIR += libast
SUBDIR += libavl
SUBDIR += libcache
SUBDIR += libcii
diff --git a/devel/libast/Makefile b/devel/libast/Makefile
new file mode 100644
index 000000000000..0347fe52473f
--- /dev/null
+++ b/devel/libast/Makefile
@@ -0,0 +1,27 @@
+# ports collection makefile for: libast
+# Date created: 7 September 2001
+# Whom: Jeremy Norris <ishmael27@home.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libast
+PORTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= http://www.eterm.org/download/
+
+MAINTAINER= ishmael27@home.com
+
+LIB_DEPENDS= Imlib2.1:${PORTSDIR}/graphics/imlib2
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MMX) && (${ARCH} == "i386")
+CONFIGURE_ARGS= --enable-mmx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libast/distinfo b/devel/libast/distinfo
new file mode 100644
index 000000000000..abbd54c1e5e3
--- /dev/null
+++ b/devel/libast/distinfo
@@ -0,0 +1 @@
+MD5 (libast-0.3.tar.gz) = 34315d4542d9d6b7cdd136f8d2eb010e
diff --git a/devel/libast/files/patch-libast.h b/devel/libast/files/patch-libast.h
new file mode 100644
index 000000000000..6a719d58dd15
--- /dev/null
+++ b/devel/libast/files/patch-libast.h
@@ -0,0 +1,10 @@
+--- libast.h.orig Sat Jun 16 02:30:28 2001
++++ libast.h Fri Sep 7 01:01:50 2001
+@@ -40,6 +40,7 @@
+ # endif
+ #endif
+
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <time.h>
diff --git a/devel/libast/pkg-comment b/devel/libast/pkg-comment
new file mode 100644
index 000000000000..007d2c680642
--- /dev/null
+++ b/devel/libast/pkg-comment
@@ -0,0 +1 @@
+A library of assorted spiffy things
diff --git a/devel/libast/pkg-descr b/devel/libast/pkg-descr
new file mode 100644
index 000000000000..9bb4de4c8e8d
--- /dev/null
+++ b/devel/libast/pkg-descr
@@ -0,0 +1,2 @@
+A library of assorted spiffy things, previously known as libmej, the Eterm
+helper library.
diff --git a/devel/libast/pkg-plist b/devel/libast/pkg-plist
new file mode 100644
index 000000000000..70a499e93f05
--- /dev/null
+++ b/devel/libast/pkg-plist
@@ -0,0 +1,6 @@
+bin/libast-config
+bin/libast-test
+include/libast.h
+lib/libast.a
+lib/libast.so
+lib/libast.so.1