aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2024-03-18 20:32:22 +0000
committerThierry Thomas <thierry@FreeBSD.org>2024-03-18 20:32:22 +0000
commit8d9daace01d0b71130cd0e8fbfcf4dc987ff756c (patch)
tree6782ddefb4d0bcfccd4f4dc1aa36f86987daaf51
parent167c4e1d1949e20ce47a069d1b2071f41ed2c92e (diff)
downloadports-8d9daace01d0b71130cd0e8fbfcf4dc987ff756c.tar.gz
ports-8d9daace01d0b71130cd0e8fbfcf4dc987ff756c.zip
lang/gnat1?: force the usage of gettext
It appears that gettext is required even when NLS is disabled (surely because the compiler used for bootstrap has been built with NLS). No bump of PORTREVISION needed. PR: 277508 Reported by: bob (at) vesterman.com
-rw-r--r--lang/gnat12/Makefile3
-rw-r--r--lang/gnat13/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/lang/gnat12/Makefile b/lang/gnat12/Makefile
index fdc0cc5a0ea5..efdba686a96b 100644
--- a/lang/gnat12/Makefile
+++ b/lang/gnat12/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
RUN_DEPENDS= ${LOCALBASE}/bin/as:devel/binutils \
gcc${_GCC_VER}>0:lang/gcc${_GCC_VER}
-USES= bison gmake iconv libtool localbase tar:xz
+USES= bison gettext-runtime gmake iconv libtool localbase tar:xz
USE_BINUTILS= yes
USE_LDCONFIG= ${_TARGLIB}
@@ -88,7 +88,6 @@ GCC6AUX_VARS= _GCC6AUX_PATH=${LOCALBASE}/gcc6-aux/bin
.if exists(/usr/lib32/libc.so)
MULTILIB_CONFIGURE_ENABLE= multilib
.endif
-NLS_USES= gettext-runtime
NLS_CONFIGURE_ON= --enable-nls
NLS_CONFIGURE_OFF= --disable-nls
PREVASSET_DISTFILES+= ${_PREV_ASSET_FILE}.tar.xz:gnat
diff --git a/lang/gnat13/Makefile b/lang/gnat13/Makefile
index 48be478163c7..3a397b905940 100644
--- a/lang/gnat13/Makefile
+++ b/lang/gnat13/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
RUN_DEPENDS= ${LOCALBASE}/bin/as:devel/binutils
-USES= bison gmake iconv libtool localbase tar:xz
+USES= bison gettext-runtime gmake iconv libtool localbase tar:xz
USE_BINUTILS= yes
USE_LDCONFIG= ${_TARGLIB}
@@ -86,7 +86,6 @@ GNAT12_VARS= _GNAT12_PATH=${LOCALBASE}/gnat12/bin
.if exists(/usr/lib32/libc.so)
MULTILIB_CONFIGURE_ENABLE= multilib
.endif
-NLS_USES= gettext-runtime
NLS_CONFIGURE_ON= --enable-nls
NLS_CONFIGURE_OFF= --disable-nls
PREVASSET_DISTFILES+= ${_PREV_ASSET_FILE}.tar.xz:gnat