aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-07-27 19:43:19 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-07-27 19:43:19 +0000
commit8dcc756c51559e7deb8ae2396721cfad17226526 (patch)
treeb6970d516d77ebfa7a0665ede888fbdb6c702ec5
parent800bb7c50cfe116a92e6668875bec471cd4cb4dd (diff)
downloadports-8dcc756c51559e7deb8ae2396721cfad17226526.tar.gz
ports-8dcc756c51559e7deb8ae2396721cfad17226526.zip
graphics/qimgv: update 1.03.g20240620 → 1.03.g20240727
* Upstream committed our local patch with FreeBSD support. * Require compiler with C++ 17. * Drop EXIV2_DESC - bsd.options.desc.mk have it. PR: 280422 Reported by: diizzy Approved by: Kenneth Raplee <kenrap@kennethraplee.com> (maintainer, via IRC)
-rw-r--r--graphics/qimgv/Makefile8
-rw-r--r--graphics/qimgv/distinfo6
-rw-r--r--graphics/qimgv/files/patch-add-freebsd-support103
3 files changed, 6 insertions, 111 deletions
diff --git a/graphics/qimgv/Makefile b/graphics/qimgv/Makefile
index c558dee4465c..54252c8f8771 100644
--- a/graphics/qimgv/Makefile
+++ b/graphics/qimgv/Makefile
@@ -1,5 +1,5 @@
PORTNAME= qimgv
-PORTVERSION= 1.03.g20240620
+PORTVERSION= 1.03.g20240727
CATEGORIES= graphics
MAINTAINER= kenrap@kennethraplee.com
@@ -10,12 +10,11 @@ LICENSE= GPLv3
LIB_DEPENDS= libinotify.so:devel/libinotify
-USES= cmake compiler:c++11-lang desktop-file-utils \
+USES= cmake compiler:c++17-lang desktop-file-utils \
localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= easymodo
-GH_PROJECT= qimgv
-GH_TAGNAME= 7672cb4b15f8f5eef2b5535e7bbb59248931db72
+GH_TAGNAME= 82e6b7537002b86b4ab20954aab5bf0db7c25752
LDFLAGS+= -linotify
@@ -25,7 +24,6 @@ OPTIONS_SINGLE= QT
OPTIONS_SINGLE_QT= QT5 QT6
OPTIONS_SUB= yes
-EXIV2_DESC= Support reading exif tags via exiv2
KDE5_DESC= ${KDE_DESC} (require QT5)
OPENCV_DESC= Enables high quality scaling options
VIDEO_DESC= Enables video playback via mpv
diff --git a/graphics/qimgv/distinfo b/graphics/qimgv/distinfo
index 8690254e14ab..8d42bfe5e412 100644
--- a/graphics/qimgv/distinfo
+++ b/graphics/qimgv/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1719751325
-SHA256 (easymodo-qimgv-1.03.g20240620-7672cb4b15f8f5eef2b5535e7bbb59248931db72_GH0.tar.gz) = 78bb1943559a43f536a71641b913de5dab3a69ebfe781d8ef11382a89be68691
-SIZE (easymodo-qimgv-1.03.g20240620-7672cb4b15f8f5eef2b5535e7bbb59248931db72_GH0.tar.gz) = 1082895
+TIMESTAMP = 1722079763
+SHA256 (easymodo-qimgv-1.03.g20240727-82e6b7537002b86b4ab20954aab5bf0db7c25752_GH0.tar.gz) = 115058a995d70759a3e78a7a23a9701775a626251696d678f845ccc3365748cc
+SIZE (easymodo-qimgv-1.03.g20240727-82e6b7537002b86b4ab20954aab5bf0db7c25752_GH0.tar.gz) = 1083044
diff --git a/graphics/qimgv/files/patch-add-freebsd-support b/graphics/qimgv/files/patch-add-freebsd-support
deleted file mode 100644
index 2ca17d221ed9..000000000000
--- a/graphics/qimgv/files/patch-add-freebsd-support
+++ /dev/null
@@ -1,103 +0,0 @@
---- qimgv/components/directorymanager/watchers/directorywatcher.cpp.orig 2024-06-20 15:55:26 UTC
-+++ qimgv/components/directorymanager/watchers/directorywatcher.cpp
-@@ -1,6 +1,6 @@
- #include "directorywatcher_p.h"
-
--#ifdef __linux__
-+#if defined(__FreeBSD__) || defined(__linux__)
- #include "linux/linuxwatcher.h"
- #elif _WIN32
- #include "windows/windowswatcher.h"
-@@ -34,7 +34,7 @@ DirectoryWatcher *DirectoryWatcher::newInstance()
- {
- DirectoryWatcher* watcher;
-
--#ifdef __linux__
-+#if defined(__FreeBSD__) || defined(__linux__)
- watcher = new LinuxWatcher();
- #elif _WIN32
- watcher = new WindowsWatcher();
---- qimgv/core.cpp.orig 2024-06-20 15:55:26 UTC
-+++ qimgv/core.cpp
-@@ -728,7 +728,7 @@ void Core::showInDirectory() {
- QDesktopServices::openUrl(QUrl::fromLocalFile(model->directoryPath()));
- return;
- }
--#ifdef __linux__
-+#if defined(__FreeBSD__) || defined(__linux__)
- QString fm = ScriptManager::runCommand("xdg-mime query default inode/directory");
- if(fm.contains("dolphin"))
- ScriptManager::runCommandDetached("dolphin --select " + selectedPath());
---- qimgv/settings.cpp.orig 2024-06-20 15:55:26 UTC
-+++ qimgv/settings.cpp
-@@ -3,7 +3,7 @@ Settings::Settings(QObject *parent) : QObject(parent)
- Settings *settings = nullptr;
-
- Settings::Settings(QObject *parent) : QObject(parent) {
--#ifdef __linux__
-+#if defined(__FreeBSD__) || defined(__linux__)
- // config files
- QSettings::setDefaultFormat(QSettings::NativeFormat);
- settingsConf = new QSettings();
-@@ -38,7 +38,7 @@ void Settings::setupCache() {
- }
- //------------------------------------------------------------------------------
- void Settings::setupCache() {
--#ifdef __linux__
-+#if defined(__FreeBSD__) || defined(__linux__)
- QString genericCacheLocation = QStandardPaths::writableLocation(QStandardPaths::GenericCacheLocation);
- if(genericCacheLocation.isEmpty())
- genericCacheLocation = QDir::homePath() + "/.cache";
-@@ -292,6 +292,8 @@ QString Settings::mpvBinary() {
- if(!QFile::exists(mpvPath)) {
- #ifdef _WIN32
- mpvPath = QCoreApplication::applicationDirPath() + "/mpv.exe";
-+ #elif defined __FreeBSD__
-+ mpvPath = "/usr/local/bin/mpv";
- #elif defined __linux__
- mpvPath = "/usr/bin/mpv";
- #endif
---- qimgv/shortcutbuilder.cpp.orig 2024-06-20 15:55:26 UTC
-+++ qimgv/shortcutbuilder.cpp
-@@ -64,7 +64,7 @@ QString ShortcutBuilder::processKeyEvent(QKeyEvent *ev
- QString ShortcutBuilder::processKeyEvent(QKeyEvent *event) {
- if(event->type() != QEvent::KeyPress || isModifier(Qt::Key(event->key())))
- return "";
--#if defined(__linux__) || defined(_WIN32)
-+#if defined(__FreeBSD__) || defined(__linux__) || defined(_WIN32)
- return fromEventNativeScanCode(event);
- #else
- return fromEventText(event);
---- qimgv/utils/inputmap.cpp.orig 2024-06-20 15:55:26 UTC
-+++ qimgv/utils/inputmap.cpp
-@@ -162,7 +162,7 @@ void InputMap::initKeyMap() {
- keyMap.insert( 57397 , "/" );
- keyMap.insert( 57372 , "Enter" );
-
--#elif defined __linux__
-+#elif defined(__FreeBSD__) || defined(__linux__)
- // linux keymap for qimgv
-
- // row 1
---- qimgv/utils/stuff.cpp.orig 2024-06-20 15:55:26 UTC
-+++ qimgv/utils/stuff.cpp
-@@ -8,7 +8,7 @@ int probeOS() {
- int probeOS() {
- #ifdef TARGET_OS_MAC
- return 0;
--#elif defined __linux__
-+#elif defined(__FreeBSD__) || defined(__linux__)
- return 1;
- #elif defined _WIN32 || defined _WIN64
- return 2;
---- qimgv/utils/wallpapersetter.cpp.orig 2024-06-20 15:55:26 UTC
-+++ qimgv/utils/wallpapersetter.cpp
-@@ -11,7 +11,7 @@ void WallpaperSetter::setWallpaper(QString path) {
- (PVOID) path.utf16(),
- SPIF_UPDATEINIFILE | SPIF_SENDWININICHANGE);
- qDebug() << "wallpaper changed:" << (ok ? "true" : "false");
--#elif defined __linux__
-+#elif defined(__FreeBSD__) || defined(__linux__)
- QString command;
- command = "qdbus org.kde.plasmashell /PlasmaShell org.kde.PlasmaShell.evaluateScript \'var allDesktops = desktops(); print (allDesktops); for (i = 0; i < allDesktops.length; i++) { d = allDesktops[i]; d.wallpaperPlugin = \"org.kde.image\"; d.currentConfigGroup = Array(\"Wallpaper\", \"org.kde.image\", \"General\"); d.writeConfig(\"Image\", \"" + path + "\") } \'";
- QProcess process;