aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-04-15 21:31:23 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-04-15 21:37:15 +0000
commit8de3261ff5457d4827da8e5f08e016001d5dc4b2 (patch)
tree937edeced67122b3a6301a6374e4d70d86f2748d
parent5f7f6aee6ca5817ad4626b228c283f0289bec8b3 (diff)
downloadports-8de3261ff5457d4827da8e5f08e016001d5dc4b2.tar.gz
ports-8de3261ff5457d4827da8e5f08e016001d5dc4b2.zip
Fix PORTSCOUT=ignore:* uses throughout the tree
PORTSCOUT=ignore:1 is the only valid way syntax according to the Portscout documentation. In disables the distfile version checks completely. In order to ignore only certain version instead, it is necessary to use other Portscout keys like skipv. Also, remove the setting completely when it attempts to instruct Portscout to skip versions older than the current one. Approved by: portmgr blanket
-rw-r--r--databases/sqlitebrowser/Makefile2
-rw-r--r--devel/omnisharp-server/Makefile2
-rw-r--r--math/py-uncertainties/Makefile2
-rw-r--r--multimedia/subtitlecomposer/Makefile2
-rw-r--r--security/p5-Crypt-PKCS10/Makefile2
-rw-r--r--textproc/py-pykwalify/Makefile2
6 files changed, 4 insertions, 8 deletions
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
index 33cf0740e9c6..98588e0415f6 100644
--- a/databases/sqlitebrowser/Makefile
+++ b/databases/sqlitebrowser/Makefile
@@ -24,7 +24,7 @@ USE_GITHUB= yes
INSTALLS_ICONS= yes
-PORTSCOUT= ignore:continuous
+PORTSCOUT= ignore:1
post-patch:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' \
diff --git a/devel/omnisharp-server/Makefile b/devel/omnisharp-server/Makefile
index d1082ad5527b..46be8cc187ca 100644
--- a/devel/omnisharp-server/Makefile
+++ b/devel/omnisharp-server/Makefile
@@ -18,7 +18,7 @@ GH_TAGNAME= e1902915c
GH_TUPLE= icsharpcode:NRefactory:3f78bdbed:nrefactory/NRefactory \
jbevain:cecil:4770957a0:cecil/cecil
-PORTSCOUT= ignore:mono-2.10.8
+PORTSCOUT= skipv:mono-2.10.8
do-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
diff --git a/math/py-uncertainties/Makefile b/math/py-uncertainties/Makefile
index d06edeffd1c7..de09902ab520 100644
--- a/math/py-uncertainties/Makefile
+++ b/math/py-uncertainties/Makefile
@@ -18,6 +18,4 @@ USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
-PORTSCOUT= ignore:3.1.3
-
.include <bsd.port.mk>
diff --git a/multimedia/subtitlecomposer/Makefile b/multimedia/subtitlecomposer/Makefile
index bbe45db909e9..e46b331744ef 100644
--- a/multimedia/subtitlecomposer/Makefile
+++ b/multimedia/subtitlecomposer/Makefile
@@ -23,7 +23,7 @@ USE_GITHUB= yes
GH_ACCOUNT= maxrd2
GH_PROJECT= SubtitleComposer
-PORTSCOUT= ignore:continuous
+PORTSCOUT= ignore:1
OPTIONS_GROUP= VIDEO
VIDEO_DESC= Video players
diff --git a/security/p5-Crypt-PKCS10/Makefile b/security/p5-Crypt-PKCS10/Makefile
index c4f9b131b554..fb95ef76b489 100644
--- a/security/p5-Crypt-PKCS10/Makefile
+++ b/security/p5-Crypt-PKCS10/Makefile
@@ -22,8 +22,6 @@ RUN_DEPENDS= p5-Convert-ASN1>=0.27:converters/p5-Convert-ASN1 \
p5-Digest-MD4>0:security/p5-Digest-MD4
TEST_DEPENDS= p5-Module-Signature>0:security/p5-Module-Signature
-PORTSCOUT= ignore:1.800201,1.8002
-
USES= perl5
USE_PERL5= modbuildtiny
USE_GITHUB= yes
diff --git a/textproc/py-pykwalify/Makefile b/textproc/py-pykwalify/Makefile
index 407a5c593cb8..11b1b371790f 100644
--- a/textproc/py-pykwalify/Makefile
+++ b/textproc/py-pykwalify/Makefile
@@ -22,7 +22,7 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-PORTSCOUT= ignore:15.01,14.12,14.08,14.06.1,14.06
+PORTSCOUT= skipv:15.01,14.12,14.08,14.06.1,14.06
PORTEXAMPLES= utf8-data.yml utf8-schema.yml