aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2006-05-01 20:17:33 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2006-05-01 20:17:33 +0000
commit8df0bf29eedf85e41685264e1f186583a343f94b (patch)
tree6d57dd42776b7c5d23930af67d4759df767bd766
parentd75db857846050c36671cc18edd13f1895872c9f (diff)
downloadports-8df0bf29eedf85e41685264e1f186583a343f94b.tar.gz
ports-8df0bf29eedf85e41685264e1f186583a343f94b.zip
-Add WITHOUT_GNOME knob (OPTIONS). [1]
-Use libgailgnome in USE_GNOME instead RUN_DEPENDS line. -Add desktopfileutils, bump the PORTREVISION. PR: ports/96123 [1] Submitted by: Alexander Botero-Lowry <alex@foxybanana.com> [1]
Notes
Notes: svn path=/head/; revision=161128
-rw-r--r--devel/glade2/Makefile17
-rw-r--r--devel/glade2/pkg-plist2
2 files changed, 15 insertions, 4 deletions
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index 54cc6ad2080b..98efd48a2d62 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= glade
PORTVERSION= 2.12.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -18,22 +18,31 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A user interface builder for GTK+/GNOME
-RUN_DEPENDS= ${X11BASE}/lib/gtk-2.0/modules/libgail-gnome.so:${PORTSDIR}/x11-toolkits/libgail-gnome
+BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
USE_GETTEXT= yes
USE_X_PREFIX= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui
+USE_GNOME= gnomeprefix intlhack gnomehack gtk20 desktopfileutils
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-#OPTIONS= GNOMEDB "Enable libgnomedb support" off
+OPTIONS= GNOME "Enable gnome support" on #\
+# GNOMEDB "Enable libgnomedb support" off
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_GNOME)
+CONFIGURE_ARGS+= --disable-gnome
+.else
+USE_GNOME+= libgailgnome libgnomeui
+CONFIGURE_ARGS+= --enable-gnome
+.endif
+
#.if defined(WITH_GNOMEDB)
#USE_GNOME+= libgnomedb
#CONFIGURE_ARGS+= --enable-gnome-db
diff --git a/devel/glade2/pkg-plist b/devel/glade2/pkg-plist
index 86b3a933b548..c4c9ad6ee8af 100644
--- a/devel/glade2/pkg-plist
+++ b/devel/glade2/pkg-plist
@@ -83,3 +83,5 @@ share/locale/zh_TW/LC_MESSAGES/glade-2.0.mo
@dirrm share/gnome/help/glade-2
@dirrm share/gnome/glade-2/gtk
@dirrm share/gnome/glade-2
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true