aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-17 15:28:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-17 15:28:55 +0000
commit8ef3a9869d04edb1e6b253e02684c15dd9787835 (patch)
tree5d78b4e723084b56f1c8c6376f5fa0a426563ff7
parent56d20528f0d86788cced217fb61750455d211f4b (diff)
downloadports-8ef3a9869d04edb1e6b253e02684c15dd9787835.tar.gz
ports-8ef3a9869d04edb1e6b253e02684c15dd9787835.zip
- Convert to PEAR_AUTOINSTALL
- Trim header
Notes
Notes: svn path=/head/; revision=314455
-rw-r--r--www/pear-HTTP_Download/Makefile11
-rw-r--r--www/pear-HTTP_FloodControl/Makefile7
-rw-r--r--www/pear-HTTP_Server/Makefile3
-rw-r--r--www/pear-HTTP_Session2/Makefile25
-rw-r--r--www/pear-HTTP_Upload/Makefile15
-rw-r--r--www/pear-HTTP_WebDAV_Client/Makefile6
-rw-r--r--www/pear-Horde_Browser/Makefile5
-rw-r--r--www/pear-Services_Blogging/Makefile2
-rw-r--r--www/pear-Services_Delicious/Makefile6
-rw-r--r--www/pear-Services_Google/Makefile11
-rw-r--r--www/pear-Services_OpenSearch/Makefile9
-rw-r--r--www/pear-Services_SharedBook/Makefile6
-rw-r--r--www/pear-Services_W3C_CSSValidator/Makefile6
-rw-r--r--www/pear-Services_urlTea/Makefile1
-rw-r--r--www/pear-Structures_DataGrid_Renderer_Pager/Makefile2
-rw-r--r--www/pear-Text_Wiki/Makefile5
-rw-r--r--www/pear-UDDI/Makefile2
17 files changed, 25 insertions, 97 deletions
diff --git a/www/pear-HTTP_Download/Makefile b/www/pear-HTTP_Download/Makefile
index 6dee2febb966..61ecd37c56f4 100644
--- a/www/pear-HTTP_Download/Makefile
+++ b/www/pear-HTTP_Download/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-HTTP_Download
-# Date created: 17 January 2005
-# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
-#
+# Created by: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
# $FreeBSD$
-#
PORTNAME= HTTP_Download
PORTVERSION= 1.1.4
@@ -13,10 +9,9 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR class to send HTTP downloads
BUILD_DEPENDS= ${PEARDIR}/HTTP/Header.php:${PORTSDIR}/www/pear-HTTP_Header
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/HTTP/Header.php:${PORTSDIR}/www/pear-HTTP_Header
-FILES= HTTP/Download.php HTTP/Download/PgLOB.php HTTP/Download/Archive.php
-TESTS= send.php data.txt AllTests.php
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-HTTP_FloodControl/Makefile b/www/pear-HTTP_FloodControl/Makefile
index 2976c81d8034..176d515d6f80 100644
--- a/www/pear-HTTP_FloodControl/Makefile
+++ b/www/pear-HTTP_FloodControl/Makefile
@@ -9,12 +9,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR classes to detect and protect from attempts to flood a site
BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
-CATEGORY= HTTP
-FILES= FloodControl.php FloodControl/Container.php \
- FloodControl/Container/DB.php FloodControl/Container/File.php \
- FloodControl/Container/MDB.php FloodControl/Container/MDB2.php
+RUN_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
LATEST_LINK= pear-HTTP_FloodControl
DOCS= README LICENSE
diff --git a/www/pear-HTTP_Server/Makefile b/www/pear-HTTP_Server/Makefile
index 621c63d7b27a..fb3ff03075bc 100644
--- a/www/pear-HTTP_Server/Makefile
+++ b/www/pear-HTTP_Server/Makefile
@@ -10,7 +10,8 @@ COMMENT= HTTP server class
BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP \
${PEARDIR}/Net/Server.php:${PORTSDIR}/net/pear-Net_Server
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP \
+ ${PEARDIR}/Net/Server.php:${PORTSDIR}/net/pear-Net_Server
PEAR_AUTOINSTALL= yes
diff --git a/www/pear-HTTP_Session2/Makefile b/www/pear-HTTP_Session2/Makefile
index 06e4c87c486d..3177703bd411 100644
--- a/www/pear-HTTP_Session2/Makefile
+++ b/www/pear-HTTP_Session2/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-HTTP_Session
-# Date created: 13 December 2003
-# Whom: Alex Miller (<asm@asm.kiev.ua>)
-#
+# Created by: Alex Miller (<asm@asm.kiev.ua>)
# $FreeBSD$
-#
PORTNAME= HTTP_Session2
PORTVERSION= 0.7.3
@@ -15,25 +11,10 @@ COMMENT= PHP5 Session Handler
LICENSE= BSD
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
USE_DOS2UNIX= yes
-
-IGNORE_WITH_PHP= 4
-
-CATEGORY= HTTP
-FILES= HTTP/Session2.php \
- HTTP/Session2/Container.php \
- HTTP/Session2/Exception.php \
- HTTP/Session2/Container/DB.php \
- HTTP/Session2/Container/Interface.php \
- HTTP/Session2/Container/MDB2.php \
- HTTP/Session2/Container/Memcache.php
-EXAMPLES= HTTP_Session2_Example.php sessiondata.sql
-_EXAMPLESDIR= docs
-TESTS= AllTests.php functions.php \
- test-session2.phpt test-session-doctrine.phpt \
- test-session-mdb2.phpt test-session.phpt
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-HTTP_Upload/Makefile b/www/pear-HTTP_Upload/Makefile
index a5ac69937215..3f5b640c39c1 100644
--- a/www/pear-HTTP_Upload/Makefile
+++ b/www/pear-HTTP_Upload/Makefile
@@ -1,24 +1,17 @@
-# Ports collection makefile for: pear-HTTP_Upload
-# Date created: 13 December 2003
-# Whom: Alex Miller (<asm@asm.kiev.ua>)
-#
+# Created by: Alex Miller (<asm@asm.kiev.ua>)
# $FreeBSD$
-#
PORTNAME= HTTP_Upload
PORTVERSION= 0.9.1
CATEGORIES= www devel pear
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= miwi@FreeBSD.org
COMMENT= Easy and secure management of files submitted via HTML Forms
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-CATEGORY= HTTP
-FILES= Upload.php
-EXAMPLES= upload_example.php
-_EXAMPLESDIR= docs
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-HTTP_WebDAV_Client/Makefile b/www/pear-HTTP_WebDAV_Client/Makefile
index 61c15f833c2b..5ac3bacf83e9 100644
--- a/www/pear-HTTP_WebDAV_Client/Makefile
+++ b/www/pear-HTTP_WebDAV_Client/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: HTTP_WebDAV_Client
-# Date created: 14 Nov 2008
-# Whom: Wen Heping<wenheping@gmail.com>
-#
+# Created by: Wen Heping<wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= HTTP_WebDAV_Client
PORTVERSION= 1.0.2
diff --git a/www/pear-Horde_Browser/Makefile b/www/pear-Horde_Browser/Makefile
index 4798a4fd40c4..c1057bba16bc 100644
--- a/www/pear-Horde_Browser/Makefile
+++ b/www/pear-Horde_Browser/Makefile
@@ -1,7 +1,4 @@
-# Ports collection makefile for: pear-Horde_Browser
-# Date created: 6 July 2011
-# Whom: Martin Matuska <mm@FreeBSD.org>
-#
+# Created by: Martin Matuska <mm@FreeBSD.org>
# $FreeBSD$
PORTNAME= Horde_Browser
diff --git a/www/pear-Services_Blogging/Makefile b/www/pear-Services_Blogging/Makefile
index 4d6aa95eea39..fd8aefbf5704 100644
--- a/www/pear-Services_Blogging/Makefile
+++ b/www/pear-Services_Blogging/Makefile
@@ -10,7 +10,7 @@ COMMENT= PHP interface to Blog
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/XML/RPC.php:${PORTSDIR}/net/pear-XML_RPC
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/XML/RPC.php:${PORTSDIR}/net/pear-XML_RPC
PEAR_AUTOINSTALL= yes
diff --git a/www/pear-Services_Delicious/Makefile b/www/pear-Services_Delicious/Makefile
index 713456187a73..43034626f929 100644
--- a/www/pear-Services_Delicious/Makefile
+++ b/www/pear-Services_Delicious/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_Delicious
-# Date created: 2006/08/03
-# Whom: chinsan <chisnan.tw@gmail.com>
-#
+# Created by: chinsan <chisnan.tw@gmail.com>
# $FreeBSD$
-#
PORTNAME= Services_Delicious
PORTVERSION= 0.6.0
diff --git a/www/pear-Services_Google/Makefile b/www/pear-Services_Google/Makefile
index e74743f5b913..0ddc4b40c596 100644
--- a/www/pear-Services_Google/Makefile
+++ b/www/pear-Services_Google/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_Google
-# Date created: 13 April 2008
-# Whom: Wen heping <wenheping@gmail.com>)
-#
+# Created by: Wen heping <wenheping@gmail.com>)
# $FreeBSD$
-#
PORTNAME= Services_Google
PORTVERSION= 0.2.0
@@ -13,10 +9,7 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= PHP interface to access the Google SOAP Web APIs
USE_PHP= soap
-CATEGORY= Services
-
-FILES= Google.php
-EXAMPLES= example1.php
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-Services_OpenSearch/Makefile b/www/pear-Services_OpenSearch/Makefile
index ef842f537b6f..62602bf33956 100644
--- a/www/pear-Services_OpenSearch/Makefile
+++ b/www/pear-Services_OpenSearch/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_OpenSearch
-# Date created: 10 Dez 2008
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Services_OpenSearch
PORTVERSION= 0.2.0
@@ -16,8 +12,7 @@ BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializ
${PEARDIR}/XML/RSS.php:${PORTSDIR}/devel/pear-XML_RSS
RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-CATEGORY= Services
-FILES= OpenSearch.php
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/www/pear-Services_SharedBook/Makefile b/www/pear-Services_SharedBook/Makefile
index fe81ef387dbd..675da8c99bbc 100644
--- a/www/pear-Services_SharedBook/Makefile
+++ b/www/pear-Services_SharedBook/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_SharedBook
-# Date created: 22 Jan 2007
-# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
-#
+# Created by: Ditesh Shashikant Gathani <ditesh@gathani.org>
# $FreeBSD$
-#
PORTNAME= Services_SharedBook
PORTVERSION= 0.2.6
diff --git a/www/pear-Services_W3C_CSSValidator/Makefile b/www/pear-Services_W3C_CSSValidator/Makefile
index a964fae724f1..0459a097b29d 100644
--- a/www/pear-Services_W3C_CSSValidator/Makefile
+++ b/www/pear-Services_W3C_CSSValidator/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Services_W3C_CSSValidator:
-# Date created: 21 Jan 2007
-# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
-#
+# Created by: Ditesh Shashikant Gathani <ditesh@gathani.org>
# $FreeBSD$
-#
PORTNAME= Services_W3C_CSSValidator
PORTVERSION= 0.2.3
diff --git a/www/pear-Services_urlTea/Makefile b/www/pear-Services_urlTea/Makefile
index 8be782c1cc71..9788f3a30342 100644
--- a/www/pear-Services_urlTea/Makefile
+++ b/www/pear-Services_urlTea/Makefile
@@ -12,7 +12,6 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
USE_PHP= curl
-
PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
diff --git a/www/pear-Structures_DataGrid_Renderer_Pager/Makefile b/www/pear-Structures_DataGrid_Renderer_Pager/Makefile
index ab0669f725ef..b712b2afb6d7 100644
--- a/www/pear-Structures_DataGrid_Renderer_Pager/Makefile
+++ b/www/pear-Structures_DataGrid_Renderer_Pager/Makefile
@@ -5,7 +5,7 @@ PORTNAME= Structures_DataGrid_Renderer_Pager
PORTVERSION= 0.1.3
CATEGORIES= www pear
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= miwi@FreeBSD.org
COMMENT= Pager Renderer for pear-Structures_DataGrid
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
diff --git a/www/pear-Text_Wiki/Makefile b/www/pear-Text_Wiki/Makefile
index 0922e7dffaa5..f2ab405cd6a8 100644
--- a/www/pear-Text_Wiki/Makefile
+++ b/www/pear-Text_Wiki/Makefile
@@ -13,11 +13,6 @@ RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
PEAR_AUTOINSTALL= yes
-post-extract:
- @${MV} ${WRKSRC}/Text/* ${WRKSRC}
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|" ${WRKSRC}/Wiki.php
- @${FIND} ${WRKSRC} -name "*.bak" -delete
-
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/www/pear-UDDI/Makefile b/www/pear-UDDI/Makefile
index 2462c56de585..89338464ab92 100644
--- a/www/pear-UDDI/Makefile
+++ b/www/pear-UDDI/Makefile
@@ -10,7 +10,7 @@ COMMENT= PEAR UDDI for PHP
BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util
-RUN_DEPENDS:= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
+RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util
PEAR_AUTOINSTALL= yes