aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2023-05-14 21:27:16 +0000
committerMikhail Teterin <mi@FreeBSD.org>2023-05-14 21:27:16 +0000
commit8f8d3f33217d4e66fd420f8460422e726d3cf855 (patch)
tree108867bfebb9de457fa25070ee167c0161b9047c
parent279054c5d3d6c8451bfb1d3243c65132f81782c3 (diff)
downloadports-8f8d3f33217d4e66fd420f8460422e726d3cf855.tar.gz
ports-8f8d3f33217d4e66fd420f8460422e726d3cf855.zip
www/websh: report errors parsing cookie-expiration date
Original code would ignore such errors -- and would simply skip the expiration-clause of any cookie. This MIGHT explain the test-failures reported by Poudriere, even though I cannot reproduce this problem locally. Fix another minor problem, while I'm here -- and bump PORTREVISION.
-rw-r--r--www/websh/Makefile4
-rw-r--r--www/websh/files/pkgIndex.tcl.in2
2 files changed, 3 insertions, 3 deletions
diff --git a/www/websh/Makefile b/www/websh/Makefile
index f4c83d23a329..7e71259fe02d 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -1,6 +1,6 @@
PORTNAME= websh
PORTVERSION= 3.6.0b5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= www tcl
MASTER_SITES= https://archive.apache.org/dist/tcl/${PORTNAME}/source/
EXTRACT_SUFX= -src.tar.gz
@@ -43,7 +43,7 @@ post-patch:
done
${REINPLACE_CMD} -e 's,\.html,.whtml,g' ${WRKSRC:H:H}/doc/mod_websh/htdocs/*.ws3
${REINPLACE_CMD} -e 's|__declspec(dllexport)|DLLEXPORT|' \
- ${WRKSRC}/../generic/*.[ch]
+ ${WRKSRC:H}/generic/*.[ch]
post-configure:
# Remove the "STUBS" and the PACKAGE_* defines, which may conflict
diff --git a/www/websh/files/pkgIndex.tcl.in b/www/websh/files/pkgIndex.tcl.in
index 2c6a688fad6e..39aa4c08819b 100644
--- a/www/websh/files/pkgIndex.tcl.in
+++ b/www/websh/files/pkgIndex.tcl.in
@@ -1,3 +1,3 @@
if {[package vcompare [info tclversion] 8.3] < 0} return
-package ifneeded websh %%WS_VER%% [list load [file join [file dirname $dir] libwebsh%%TCL_DVER%%.so.1]]
+package ifneeded websh %%WS_VER%% [list load [file join [file dirname $dir] libwebsh%%LIBSUF%%.so.1]]