aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-09-28 20:34:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-09-28 20:41:30 +0000
commit8f957c37002202c0485320f7b64ff046aec51b6a (patch)
treed0e4eb80f55da563be117eb41f818cee4a7d880b
parenta9f4e50570586fc1a0844f420b6b4fab1df55c14 (diff)
downloadports-8f957c37002202c0485320f7b64ff046aec51b6a.tar.gz
ports-8f957c37002202c0485320f7b64ff046aec51b6a.zip
emulators/qemu-devel: Update version 5.1.0.20201019=>6.1.0.20210928
- Move upstream site to GITLAB Relnotes: https://gitlab.com/qemu-project/qemu/-/commits/master/
-rw-r--r--emulators/qemu-devel/Makefile33
-rw-r--r--emulators/qemu-devel/distinfo26
-rw-r--r--emulators/qemu-devel/files/patch-configure44
-rw-r--r--emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc11
-rw-r--r--emulators/qemu-devel/files/patch-docs_meson.build79
-rw-r--r--emulators/qemu-devel/files/patch-docs_system_qemu-cpu-models.rst6
-rw-r--r--emulators/qemu-devel/files/patch-net_tap-bsd.c10
-rw-r--r--emulators/qemu-devel/pkg-plist11
8 files changed, 49 insertions, 171 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index b29703b530b6..9220675fb093 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -1,8 +1,7 @@
# Created by: Juergen Lock <nox@jelal.kn-bremen.de>
PORTNAME= qemu
-DISTVERSION= 5.1.0.20201019
-PORTREVISION= 1
+DISTVERSION= 6.1.0.20210928
CATEGORIES= emulators
PKGNAMESUFFIX= -devel
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -16,27 +15,29 @@ ONLY_FOR_ARCHS= amd64 powerpc powerpc64 powerpc64 powerpc64le
IGNORE_FreeBSD_11= Unable to produce Position Independent Code
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
bash:shells/bash
-LIB_DEPENDS= libnettle.so:security/nettle \
+LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libepoxy.so:graphics/libepoxy \
- libpcre2-8.so:devel/pcre2
+ libnettle.so:security/nettle \
+ libpcre2-8.so:devel/pcre2 \
+ libzstd.so:archivers/zstd
USES= bison compiler:c11 cpe gmake gnome iconv:wchar_t ninja perl5 \
pkgconfig python:build tar:xz xorg
-USE_GITHUB= yes
+USE_GITLAB= yes
USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
USE_PYTHON= distutils noflavors
USE_XORG= pixman
-GH_TUPLE= qemu:qemu:22d30b3 \
- qemu:keycodemapdb:6b3d716:keycodemapdb/ui/keycodemapdb \
- qemu:dtc:85e5d83:dtc/dtc \
- mesonbuild:meson:776acd2:meson/meson \
- cota:berkeley-softfloat-3:b64af41:berkeleysoftfloat3/tests/fp/berkeley-softfloat-3 \
- cota:berkeley-testfloat-3:5a59dce:berkeleytestfloat3/tests/fp/berkeley-testfloat-3
+GL_COMMIT= de8ed1055c2ce18c95f597eb10df360dcb534f99
+GL_TUPLE= qemu-project:keycodemapdb:d21009b1c9f94b740ea66be8e48a1d8ad8124023:keycodemapdb/ui/keycodemapdb \
+ qemu-project:dtc:e33ce1d6a8c7e54e3ad12cff33690b6da0aee1dc:dtc/dtc \
+ qemu-project:meson:5fa0fd3b473f792bd7333cf6ae6e2f4c851b6108:meson/meson \
+ qemu-project:berkeley-softfloat-3:b64af41c3276f97f0e181920400ee056b9c88037:berkeleysoftfloat3/tests/fp/berkeley-softfloat-3 \
+ qemu-project:berkeley-testfloat-3:5a59dcec19327396a011a17fd924aed4fec416b3:berkeleytestfloat3/tests/fp/berkeley-testfloat-3
#BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
#.if !defined(PKGNAMESUFFIX) || (${PKGNAMESUFFIX} != "-utils" && ${PKGNAMESUFFIX} != "-guest-agent")
@@ -84,7 +85,7 @@ NCURSES_DEFAULT_USES= ncurses
NCURSES_BASE_USES= ncurses:base
NCURSES_PORT_USES= ncurses:port
OPENGL_CONFIGURE_OFF= --disable-opengl
-OPENGL_USE= GL=gl
+OPENGL_USE= GL=gbm,gl
OPENGL_USES= gl
PNG_CONFIGURE_OFF= --disable-vnc-png
PNG_LIB_DEPENDS= libpng.so:graphics/png
@@ -104,9 +105,9 @@ X11_CONFIGURE_ENABLE= sdl
X11_USE= SDL=sdl2 XORG=x11,xext GNOME=gdkpixbuf2
X11_USES= sdl
-PORTDOCS= docs index.html interop/.buildinfo interop/* \
- specs/.buildinfo specs/* system/.buildinfo system/* \
- tools/.buildinfo tools/* user/.buildinfo user/*
+PORTDOCS= .buildinfo _static/* about/* devel/* docs genindex.html \
+ index.html interop/* objects.inv search.html searchindex.js \
+ specs/* system/* tools/* user/*
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index 19632a907c84..12ca1735d501 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,13 +1,13 @@
-TIMESTAMP = 1603111978
-SHA256 (qemu/5.1.0.20201019/qemu-qemu-5.1.0.20201019-22d30b3_GH0.tar.gz) = 9cbcb93fb7e85f6ce127e1a33eaf2fa3f4d7e87c0bc114fc7b1d5f867cb27ef1
-SIZE (qemu/5.1.0.20201019/qemu-qemu-5.1.0.20201019-22d30b3_GH0.tar.gz) = 30079609
-SHA256 (qemu/5.1.0.20201019/qemu-keycodemapdb-6b3d716_GH0.tar.gz) = c9d3412510aac999865d01aaa14b1fa8dc0385db55c5cf6c4d95d160bd0eaee9
-SIZE (qemu/5.1.0.20201019/qemu-keycodemapdb-6b3d716_GH0.tar.gz) = 47905
-SHA256 (qemu/5.1.0.20201019/qemu-dtc-85e5d83_GH0.tar.gz) = 3507d8e96d1942493128591b518c522cfd56d7779ce53283b2cf33661b809479
-SIZE (qemu/5.1.0.20201019/qemu-dtc-85e5d83_GH0.tar.gz) = 200566
-SHA256 (qemu/5.1.0.20201019/mesonbuild-meson-776acd2_GH0.tar.gz) = ee215c525f388753237680fdaba51d4e8730482722061e1946176cd7fa980ac8
-SIZE (qemu/5.1.0.20201019/mesonbuild-meson-776acd2_GH0.tar.gz) = 2310127
-SHA256 (qemu/5.1.0.20201019/cota-berkeley-softfloat-3-b64af41_GH0.tar.gz) = f22bf52cc980b122c663f2e22f8098fa60d8e468e0095f1da58231235a6b324e
-SIZE (qemu/5.1.0.20201019/cota-berkeley-softfloat-3-b64af41_GH0.tar.gz) = 148768
-SHA256 (qemu/5.1.0.20201019/cota-berkeley-testfloat-3-5a59dce_GH0.tar.gz) = 3bfd602c8563bc05b540aa4d50e3231b283bf4fddc67e9edb80bf9bcb617df4a
-SIZE (qemu/5.1.0.20201019/cota-berkeley-testfloat-3-5a59dce_GH0.tar.gz) = 138950
+TIMESTAMP = 1632836307
+SHA256 (qemu/6.1.0.20210928/qemu-qemu-de8ed1055c2ce18c95f597eb10df360dcb534f99_GL0.tar.gz) = 9f898082d12be51c9ec06e3007f40a9e69871ba3285b55488fa9e1806bf32a05
+SIZE (qemu/6.1.0.20210928/qemu-qemu-de8ed1055c2ce18c95f597eb10df360dcb534f99_GL0.tar.gz) = 31495981
+SHA256 (qemu/6.1.0.20210928/qemu-project-keycodemapdb-d21009b1c9f94b740ea66be8e48a1d8ad8124023_GL0.tar.gz) = ac074e95824ae5337e19024eae21119caeea67884fb2a3b4aaa8679bcd0f9ccc
+SIZE (qemu/6.1.0.20210928/qemu-project-keycodemapdb-d21009b1c9f94b740ea66be8e48a1d8ad8124023_GL0.tar.gz) = 49211
+SHA256 (qemu/6.1.0.20210928/qemu-project-dtc-e33ce1d6a8c7e54e3ad12cff33690b6da0aee1dc_GL0.tar.gz) = fd1d927e216b51547cfb409853d00f1cbf48c9fead9f9bd0537c63459618a573
+SIZE (qemu/6.1.0.20210928/qemu-project-dtc-e33ce1d6a8c7e54e3ad12cff33690b6da0aee1dc_GL0.tar.gz) = 205791
+SHA256 (qemu/6.1.0.20210928/qemu-project-meson-5fa0fd3b473f792bd7333cf6ae6e2f4c851b6108_GL0.tar.gz) = ad215ee7ef61f413715532487a83223c3c426f9fc1d66e8d1ee5c6d47a169247
+SIZE (qemu/6.1.0.20210928/qemu-project-meson-5fa0fd3b473f792bd7333cf6ae6e2f4c851b6108_GL0.tar.gz) = 4089447
+SHA256 (qemu/6.1.0.20210928/qemu-project-berkeley-softfloat-3-b64af41c3276f97f0e181920400ee056b9c88037_GL0.tar.gz) = faae889814ea6a292f7ca03d9b36e6c7e95bab2a64777804883cc822b8d48757
+SIZE (qemu/6.1.0.20210928/qemu-project-berkeley-softfloat-3-b64af41c3276f97f0e181920400ee056b9c88037_GL0.tar.gz) = 148741
+SHA256 (qemu/6.1.0.20210928/qemu-project-berkeley-testfloat-3-5a59dcec19327396a011a17fd924aed4fec416b3_GL0.tar.gz) = c1f92abe87764de22f6cf8372d697717d18e7951ceb11b6e12c6767b7d1e3a65
+SIZE (qemu/6.1.0.20210928/qemu-project-berkeley-testfloat-3-5a59dcec19327396a011a17fd924aed4fec416b3_GL0.tar.gz) = 139221
diff --git a/emulators/qemu-devel/files/patch-configure b/emulators/qemu-devel/files/patch-configure
index e637e548f6c1..0137de386d62 100644
--- a/emulators/qemu-devel/files/patch-configure
+++ b/emulators/qemu-devel/files/patch-configure
@@ -1,39 +1,15 @@
---- configure.orig 2020-10-19 09:52:57 UTC
+--- configure.orig 2021-09-27 14:03:42 UTC
+++ configure
-@@ -1534,7 +1534,7 @@ if test "$mingw32" = "yes" ; then
- sysconfdir="$prefix"
- local_statedir=
+@@ -1635,7 +1635,7 @@ if test "$mingw32" = "yes" ; then
else
-- mandir="${mandir:-$prefix/share/man}"
-+ mandir="${mandir:-$prefix/man}"
- datadir="${datadir:-$prefix/share}"
- docdir="${docdir:-$prefix/share/doc}"
bindir="${bindir:-$prefix/bin}"
-@@ -3112,6 +3112,14 @@ if check_include "sys/signal.h" ; then
fi
-
- ##########################################
-+# getifaddrs (for tests/test-io-channel-socket )
-+
-+have_ifaddrs_h=yes
-+if ! check_include "ifaddrs.h" ; then
-+ have_ifaddrs_h=no
-+fi
-+
-+##########################################
- # VTE probe
-
- if test "$vte" != "no"; then
-@@ -4522,7 +4530,7 @@ fi
-
- # check for libusb
- if test "$libusb" != "no" ; then
-- if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
-+ if $pkg_config libusb-1.0; then
- libusb="yes"
- libusb_cflags=$($pkg_config --cflags libusb-1.0)
- libusb_libs=$($pkg_config --libs libusb-1.0)
-@@ -6226,6 +6234,9 @@ fi
+-mandir="${mandir:-$prefix/share/man}"
++mandir="${mandir:-$prefix/man}"
+ datadir="${datadir:-$prefix/share}"
+ docdir="${docdir:-$prefix/share/doc}"
+ sysconfdir="${sysconfdir:-$prefix/etc}"
+@@ -4607,6 +4607,9 @@ echo "CONFIG_TLS_PRIORITY=\"$tls_priority\"" >> $confi
# if this macro is set.
if test "$have_fsxattr" = "yes" ; then
echo "HAVE_FSXATTR=y" >> $config_host_mak
@@ -41,5 +17,5 @@
+if test "$have_ifaddrs_h" = "yes" ; then
+ echo "HAVE_IFADDRS_H=y" >> $config_host_mak
fi
- if test "$have_copy_file_range" = "yes" ; then
- echo "HAVE_COPY_FILE_RANGE=y" >> $config_host_mak
+ if test "$xen" = "enabled" ; then
+ echo "CONFIG_XEN_BACKEND=y" >> $config_host_mak
diff --git a/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc b/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
deleted file mode 100644
index 546595845c62..000000000000
--- a/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- disas/libvixl/vixl/a64/disasm-a64.cc.orig 2019-04-23 18:14:45 UTC
-+++ disas/libvixl/vixl/a64/disasm-a64.cc
-@@ -2693,7 +2693,7 @@ void Disassembler::AppendPCRelativeOffsetToOutput(cons
- if (offset < 0) {
- abs_offset = -abs_offset;
- }
-- AppendToOutput("#%c0x%" PRIx64, sign, abs_offset);
-+ AppendToOutput("#%c0x%" PRIx64, sign, offset < 0 ? -offset : offset);
- }
-
-
diff --git a/emulators/qemu-devel/files/patch-docs_meson.build b/emulators/qemu-devel/files/patch-docs_meson.build
deleted file mode 100644
index 981e0eab746f..000000000000
--- a/emulators/qemu-devel/files/patch-docs_meson.build
+++ /dev/null
@@ -1,79 +0,0 @@
---- docs/meson.build.orig 2020-10-19 13:41:20 UTC
-+++ docs/meson.build
-@@ -1,9 +1,9 @@
- if get_option('sphinx_build') == ''
- sphinx_build = find_program(['sphinx-build-3', 'sphinx-build'],
-- required: get_option('docs'))
-+ required: true)
- else
- sphinx_build = find_program(get_option('sphinx_build'),
-- required: get_option('docs'))
-+ required: true)
- endif
-
- # Check if tools are available to build documentation.
-@@ -26,12 +26,6 @@ if sphinx_build.found()
- tmpdir / 'sphinx/out'])
- build_docs = (sphinx_build_test_out.returncode() == 0)
-
-- if not build_docs
-- warning('@0@ exists but it is either too old or uses too old a Python version'.format(get_option('sphinx_build')))
-- if get_option('docs').enabled()
-- error('Install a Python 3 version of python-sphinx')
-- endif
-- endif
- endif
-
- if build_docs
-@@ -111,5 +105,51 @@ if build_docs
- endforeach
- alias_target('sphinxdocs', sphinxdocs)
- alias_target('html', sphinxdocs)
-+ alias_target('man', sphinxmans)
-+else
-+ manuals = [ 'interop', 'tools', 'system' ]
-+ man_pages = {
-+ 'interop' : {
-+ 'qemu-ga.8': (have_tools ? 'man8' : ''),
-+ 'qemu-ga-ref.7': 'man7',
-+ 'qemu-qmp-ref.7': 'man7',
-+ },
-+ 'tools': {
-+ 'qemu-img.1': (have_tools ? 'man1' : ''),
-+ 'qemu-nbd.8': (have_tools ? 'man8' : ''),
-+ 'qemu-trace-stap.1': (config_host.has_key('CONFIG_TRACE_SYSTEMTAP') ? 'man1' : ''),
-+ 'virtfs-proxy-helper.1': (have_virtfs_proxy_helper ? 'man1' : ''),
-+ 'virtiofsd.1': (have_virtiofsd ? 'man1' : ''),
-+ },
-+ 'system': {
-+ 'qemu.1': 'man1',
-+ 'qemu-block-drivers.7': 'man7',
-+ 'qemu-cpu-models.7': 'man7'
-+ },
-+ }
-+
-+ sphinxmans = []
-+ foreach manual : manuals
-+ private_dir = meson.current_build_dir() / (manual + '.p')
-+ output_dir = meson.current_build_dir() / manual
-+ input_dir = meson.current_source_dir() / manual
-+
-+ these_man_pages = []
-+ install_dirs = []
-+ foreach page, section : man_pages.get(manual, {})
-+ these_man_pages += page
-+ install_dirs += section == '' ? false : get_option('mandir') / section
-+ endforeach
-+ if these_man_pages.length() > 0
-+ sphinxmans += custom_target(manual + ' man pages',
-+ build_by_default: build_docs,
-+ output: these_man_pages,
-+ input: this_manual,
-+ install: build_docs,
-+ install_dir: install_dirs,
-+ command: [SPHINX_ARGS, '-b', 'man', '-d', private_dir,
-+ input_dir, meson.current_build_dir()])
-+ endif
-+ endforeach
- alias_target('man', sphinxmans)
- endif
diff --git a/emulators/qemu-devel/files/patch-docs_system_qemu-cpu-models.rst b/emulators/qemu-devel/files/patch-docs_system_qemu-cpu-models.rst
index ed263998422e..829daf378ce9 100644
--- a/emulators/qemu-devel/files/patch-docs_system_qemu-cpu-models.rst
+++ b/emulators/qemu-devel/files/patch-docs_system_qemu-cpu-models.rst
@@ -1,8 +1,8 @@
---- docs/system/qemu-cpu-models.rst.orig 2020-07-28 20:52:47 UTC
+--- docs/system/qemu-cpu-models.rst.orig 2021-09-27 14:03:42 UTC
+++ docs/system/qemu-cpu-models.rst
-@@ -17,4 +17,4 @@ Description
+@@ -21,4 +21,4 @@ Description
See also
- ''''''''
+ --------
-The HTML documentation of QEMU for more precise information and Linux user mode emulator invocation.
+The HTML documentation of QEMU for more precise information and Linux user mode emulator invocation, as well as the FreeBSD host notes in pkg-message in the relevant qemu port directory.
diff --git a/emulators/qemu-devel/files/patch-net_tap-bsd.c b/emulators/qemu-devel/files/patch-net_tap-bsd.c
deleted file mode 100644
index 6d94c1bde1ca..000000000000
--- a/emulators/qemu-devel/files/patch-net_tap-bsd.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- net/tap-bsd.c.orig 2019-04-23 18:14:46 UTC
-+++ net/tap-bsd.c
-@@ -31,6 +31,7 @@
-
- #if defined(__NetBSD__) || defined(__FreeBSD__)
- #include <sys/ioctl.h>
-+#include <sys/socket.h>
- #include <net/if.h>
- #include <net/if_tap.h>
- #endif
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index c9617a4014d3..7b1e0a6161bf 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -6,8 +6,6 @@ bin/qemu-img
bin/qemu-io
%%GTK3%%bin/qemu-keymap
bin/qemu-nbd
-%%NO_X86_TARGETS%%bin/qemu-sparc
-%%NO_X86_TARGETS%%bin/qemu-sparc64
bin/qemu-storage-daemon
%%NO_X86_TARGETS%%bin/qemu-system-aarch64
%%NO_X86_TARGETS%%bin/qemu-system-alpha
@@ -23,7 +21,6 @@ bin/qemu-system-i386
%%NO_X86_TARGETS%%bin/qemu-system-mips64
%%NO_X86_TARGETS%%bin/qemu-system-mips64el
%%NO_X86_TARGETS%%bin/qemu-system-mipsel
-%%NO_X86_TARGETS%%bin/qemu-system-moxie
%%NO_X86_TARGETS%%bin/qemu-system-nios2
%%NO_X86_TARGETS%%bin/qemu-system-or1k
%%NO_X86_TARGETS%%bin/qemu-system-ppc
@@ -41,14 +38,18 @@ bin/qemu-system-x86_64
%%NO_X86_TARGETS%%bin/qemu-system-xtensa
%%NO_X86_TARGETS%%bin/qemu-system-xtensaeb
bin/qemu-x86_64
+include/qemu-plugin.h
man/man1/qemu.1.gz
man/man1/qemu-img.1.gz
man/man7/qemu-block-drivers.7.gz
man/man7/qemu-cpu-models.7.gz
-man/man7/qemu-ga-ref.7.gz
-man/man7/qemu-qmp-ref.7.gz
man/man8/qemu-ga.8.gz
+man/man7/qemu-ga-ref.7.gz
man/man8/qemu-nbd.8.gz
+man/man8/qemu-pr-helper.8.gz
+man/man7/qemu-qmp-ref.7.gz
+man/man1/qemu-storage-daemon.1.gz
+man/man7/qemu-storage-daemon-qmp-ref.7.gz
@sample etc/qemu-ifup.sample
@sample etc/qemu-ifdown.sample
%%DATADIR%%/QEMU,tcx.bin