aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikola Kolev <koue@chaosophia.net>2024-02-19 11:36:25 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2024-02-22 12:31:51 +0000
commit8f98bcec2fd893ff2ecc52ba8ce6f08c827ef420 (patch)
treedd2b2a4372a552ee09a41ceb5b81b1c34b886c87
parente2995955b849e094ce7426ab5a082541fbc27556 (diff)
downloadports-8f98bcec2fd893ff2ecc52ba8ce6f08c827ef420.tar.gz
ports-8f98bcec2fd893ff2ecc52ba8ce6f08c827ef420.zip
www/obhttpd: update to 7.4.20231129
* Use LibreSSL 3.8.2 Changelog: https://github.com/koue/httpd/blob/master/ChangeLog PR: 275453
-rw-r--r--www/obhttpd/Makefile6
-rw-r--r--www/obhttpd/distinfo10
-rw-r--r--www/obhttpd/files/extra-patch-libressl_tls_tls.c20
3 files changed, 7 insertions, 29 deletions
diff --git a/www/obhttpd/Makefile b/www/obhttpd/Makefile
index 8497dfe70bf2..2c02dd5bb91a 100644
--- a/www/obhttpd/Makefile
+++ b/www/obhttpd/Makefile
@@ -1,6 +1,5 @@
PORTNAME= obhttpd
-DISTVERSION= 7.3.20230714
-PORTREVISION= 1
+DISTVERSION= 7.4.20231129
CATEGORIES= www
MASTER_SITES= OPENBSD/LibreSSL:libressl
DISTFILES= libressl-${SSL}.tar.gz:libressl
@@ -36,7 +35,7 @@ CFLAGS+= -Wall -fcommon \
USERS= www
GROUPS= www
-SSL= 3.5.4
+SSL= 3.8.2
LIBEVENT= 7.3.20230714
LIBIMSG= 7.3.20230714
@@ -56,7 +55,6 @@ post-patch:
pre-configure:
@(cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/libressl-${SSL}.tar.gz ${EXTRACT_AFTER_ARGS})
- @(${PATCH} -d ${WRKDIR}/libressl-${SSL} < ${PATCHDIR}/extra-patch-libressl_tls_tls.c)
@(cd ${WRKDIR}/libressl-${SSL} && ${SETENV} ac_cv_header_endian_h=no ./configure && ${SETENV} ${MAKE_ENV} ${MAKE})
@(cd ${WRKSRC_libimsg} && ${SETENV} ${MAKE_ENV} ${MAKE})
@(cd ${WRKSRC_libevent} && ${SETENV} ${MAKE_ENV} ${MAKE})
diff --git a/www/obhttpd/distinfo b/www/obhttpd/distinfo
index 7f0d3979f96b..4da6faf175cb 100644
--- a/www/obhttpd/distinfo
+++ b/www/obhttpd/distinfo
@@ -1,8 +1,8 @@
-TIMESTAMP = 1691792255
-SHA256 (libressl-3.5.4.tar.gz) = 0379da1344a2f71ad4a4e3be30ef9d82eecddce7f8dc2ae66631a1dfe14343ac
-SIZE (libressl-3.5.4.tar.gz) = 4039834
-SHA256 (koue-httpd-7.3.20230714_GH0.tar.gz) = 82e1147d7c1d184d6049a4ce64c110705848bb7b5461929404383a2c0cffbd8d
-SIZE (koue-httpd-7.3.20230714_GH0.tar.gz) = 175337
+TIMESTAMP = 1701364058
+SHA256 (libressl-3.8.2.tar.gz) = 6d4b8d5bbb25a1f8336639e56ec5088052d43a95256697a85c4ce91323c25954
+SIZE (libressl-3.8.2.tar.gz) = 4473978
+SHA256 (koue-httpd-7.4.20231129_GH0.tar.gz) = eb4c7bb4d07c94a187c985787a463189090caf55f3c094bb66fb20affe7162b7
+SIZE (koue-httpd-7.4.20231129_GH0.tar.gz) = 176508
SHA256 (koue-libevent-7.3.20230714_GH0.tar.gz) = 84fffbead795fd00ca758c460a2540bcb2f34bbc80b7837dbc94e18dc49ceebb
SIZE (koue-libevent-7.3.20230714_GH0.tar.gz) = 92458
SHA256 (koue-libimsg-7.3.20230714_GH0.tar.gz) = 553082eb214882141d4492cf8f5384940b222f6ce9c91688bcd3608a5b9a6fc6
diff --git a/www/obhttpd/files/extra-patch-libressl_tls_tls.c b/www/obhttpd/files/extra-patch-libressl_tls_tls.c
deleted file mode 100644
index 822da5bdfc00..000000000000
--- a/www/obhttpd/files/extra-patch-libressl_tls_tls.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- tls/tls.c.orig 2021-05-10 21:00:13.463847000 +0000
-+++ tls/tls.c 2021-05-10 21:02:18.217054000 +0000
-@@ -57,10 +57,13 @@ tls_do_init(void)
- int
- tls_init(void)
- {
-- static pthread_once_t once = PTHREAD_ONCE_INIT;
--
-- if (pthread_once(&once, tls_do_init) != 0)
-- return -1;
-+ // fail if statically-linked
-+ //
-+ //static pthread_once_t once = PTHREAD_ONCE_INIT;
-+ //
-+ //if (pthread_once(&once, tls_do_init) != 0)
-+ // return -1;
-+ tls_do_init();
-
- return tls_init_rv;
- }