aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-05-25 08:50:06 +0000
committerCy Schubert <cy@FreeBSD.org>2023-05-25 08:52:21 +0000
commit8fc5e393c4a9e1589291f6580415636786dfd105 (patch)
treea11470ab6e3eddb3d09f646d7801d41c2d27a3a2
parent1e4fb474684bec1ed3dc59471ced780e04cd74f7 (diff)
downloadports-8fc5e393c4a9e1589291f6580415636786dfd105.tar.gz
ports-8fc5e393c4a9e1589291f6580415636786dfd105.zip
x11/xcoloredit: Fix LLVM15 error
xcoloredit.c:356:14: error: incompatible pointer to integer conversion assigning to 'int' from 'void *' [-Wint-conversion] bars_locked = NULL; ^ ~~~~ While at it adopt this feral port. MFH: 2023Q2
-rw-r--r--x11/xcoloredit/Makefile2
-rw-r--r--x11/xcoloredit/files/patch-xcoloredit.c13
2 files changed, 12 insertions, 3 deletions
diff --git a/x11/xcoloredit/Makefile b/x11/xcoloredit/Makefile
index 3200ec83ccdf..dc9d123f3d04 100644
--- a/x11/xcoloredit/Makefile
+++ b/x11/xcoloredit/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= x11
MASTER_SITES= XCONTRIB/../R5contrib
DISTNAME= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cy@FreeBSD.org
COMMENT= Find colour values by graphical colour mixing
USES= imake tar:Z xorg
diff --git a/x11/xcoloredit/files/patch-xcoloredit.c b/x11/xcoloredit/files/patch-xcoloredit.c
index cbc7f594a24a..588f6d1a89dc 100644
--- a/x11/xcoloredit/files/patch-xcoloredit.c
+++ b/x11/xcoloredit/files/patch-xcoloredit.c
@@ -1,5 +1,5 @@
---- xcoloredit.c.orig Wed May 30 22:10:09 2007
-+++ xcoloredit.c Wed May 30 22:10:57 2007
+--- xcoloredit.c.orig 1992-01-25 08:00:21.000000000 -0800
++++ xcoloredit.c 2023-05-25 01:40:26.543747000 -0700
@@ -38,6 +38,7 @@
*/
@@ -35,6 +35,15 @@
char **argv;
{
Status ok;
+@@ -350,7 +353,7 @@
+ unboxedGC = XtGetGC(mixingForm, GCForeground | GCLineWidth, &values);
+
+ original_background = values.foreground;
+- bars_locked = NULL;
++ bars_locked = 0;
+
+ XtAddCallback(redScroll, XtNjumpProc, Thumbed, (XtPointer)RED);
+ XtAddCallback(greenScroll, XtNjumpProc, Thumbed, (XtPointer)GREEN);
@@ -696,7 +699,7 @@
(float)0.025);
XawScrollbarSetThumb(valScroll, (float)(1.0 - hsv_values.v),