aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-11-20 11:21:00 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-11-20 11:25:44 +0000
commit9016ee492eaccd1a1a7f0a29c77673dc9048b9c5 (patch)
treebfc5d5d2ace213d82653906ca1da9642d330aa8b
parentf7d874c638020a951daa48e2311600e6858e002f (diff)
downloadports-9016ee492eaccd1a1a7f0a29c77673dc9048b9c5.tar.gz
ports-9016ee492eaccd1a1a7f0a29c77673dc9048b9c5.zip
www/py-django-filer: Update to 3.1.0
* Introduce default option HEIF to reflect the settings as defined in setup.py. * Remove no longer required patch. Changelog: https://github.com/django-cms/django-filer/releases/tag/3.1.0 PR: 274890 Approved by: portmgr (maintainer timeout, 14+ days)
-rw-r--r--www/py-django-filer/Makefile18
-rw-r--r--www/py-django-filer/distinfo6
-rw-r--r--www/py-django-filer/files/patch-setup.py23
3 files changed, 13 insertions, 34 deletions
diff --git a/www/py-django-filer/Makefile b/www/py-django-filer/Makefile
index d0fa0b31e4ed..ba9c1acdfc19 100644
--- a/www/py-django-filer/Makefile
+++ b/www/py-django-filer/Makefile
@@ -1,6 +1,5 @@
PORTNAME= django-filer
-PORTVERSION= 2.1.2
-PORTREVISION= 1
+PORTVERSION= 3.1.0
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,16 +11,19 @@ WWW= https://github.com/stefanfoulis/django-filer
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=2.2<4.0:www/py-django32@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django-easy-thumbnails>=2.8.0:graphics/py-django-easy-thumbnails@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django-mptt>=0.6<1.0:www/py-django-mptt@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django-polymorphic>=2:www/py-django-polymorphic@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}unidecode>=0.04<1.2:converters/py-unidecode@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=3.2<5.1:www/py-django32@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-easy-thumbnails>0:graphics/py-django-easy-thumbnails@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-polymorphic>0:www/py-django-polymorphic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
+OPTIONS_DEFINE= HEIF
+OPTIONS_DEFAULT= HEIF
+
+HEIF_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow-heif>0:graphics/py-pillow-heif@${PY_FLAVOR}
+
.include <bsd.port.mk>
diff --git a/www/py-django-filer/distinfo b/www/py-django-filer/distinfo
index b97f93cf250f..a5eb81d1c86d 100644
--- a/www/py-django-filer/distinfo
+++ b/www/py-django-filer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1643097180
-SHA256 (django-filer-2.1.2.tar.gz) = 50f9da3b40e106de084dc6e18c19a7a54397fbee60b7ddd2568b1281ed2a24b4
-SIZE (django-filer-2.1.2.tar.gz) = 1003487
+TIMESTAMP = 1698834039
+SHA256 (django-filer-3.1.0.tar.gz) = a69db306f9495f30ba67046cca166dc8a7f73f69ed90bc302767e6d9ca991cca
+SIZE (django-filer-3.1.0.tar.gz) = 1109438
diff --git a/www/py-django-filer/files/patch-setup.py b/www/py-django-filer/files/patch-setup.py
deleted file mode 100644
index cd61b43b9761..000000000000
--- a/www/py-django-filer/files/patch-setup.py
+++ /dev/null
@@ -1,23 +0,0 @@
-Relax requirements for www/py-django-polymorphic and avoid the installation of
-the test suite in the top-level directory of ${PYTHON_SITELIBDIR}.
-
---- setup.py.orig 2021-11-09 13:48:04 UTC
-+++ setup.py
-@@ -7,7 +7,7 @@ from filer import __version__
- REQUIREMENTS = [
- 'django>=2.2,<4.0',
- 'django-mptt>=0.6,<1.0', # the exact version depends on Django
-- 'django-polymorphic>=2,<3.1',
-+ 'django-polymorphic>=2',
- 'easy-thumbnails>=2.8.0',
- 'Unidecode>=0.04,<1.2',
- ]
-@@ -51,7 +51,7 @@ setup(
- description='A file management application for django that makes handling '
- 'of files and images a breeze.',
- long_description=open('README.rst').read(),
-- packages=find_packages(),
-+ packages=find_packages(exclude=['tests*']),
- include_package_data=True,
- zip_safe=False,
- install_requires=REQUIREMENTS,