aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Wagin <dmitry.wagin@ya.ru>2021-05-18 16:16:20 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-05-18 16:16:20 +0000
commit9045d1b5a57c8d426a716f4655b8e1dad9dd2839 (patch)
tree9995583e8cd064d1fe2c603a9ac460054dd3df86
parent362eb92da22191ba1aa95524f86a62afc9d92496 (diff)
downloadports-9045d1b5a57c8d426a716f4655b8e1dad9dd2839.tar.gz
ports-9045d1b5a57c8d426a716f4655b8e1dad9dd2839.zip
devel/libzookeeper: Update to 3.7.0
PR: 255970
-rw-r--r--devel/libzookeeper/Makefile4
-rw-r--r--devel/libzookeeper/distinfo6
-rw-r--r--devel/libzookeeper/files/zookeeper.jute.c82
-rw-r--r--devel/libzookeeper/files/zookeeper.jute.h22
4 files changed, 109 insertions, 5 deletions
diff --git a/devel/libzookeeper/Makefile b/devel/libzookeeper/Makefile
index bceeced18820..018909b49a5c 100644
--- a/devel/libzookeeper/Makefile
+++ b/devel/libzookeeper/Makefile
@@ -1,7 +1,7 @@
# Created by: skreuzer@FreeBSD.org
PORTNAME= zookeeper
-PORTVERSION= 3.6.2
+PORTVERSION= 3.7.0
CATEGORIES= devel
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= lib
@@ -16,9 +16,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcppunit.so:devel/cppunit
USES= autoreconf libtool pkgconfig
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/zookeeper-client/zookeeper-client-c
diff --git a/devel/libzookeeper/distinfo b/devel/libzookeeper/distinfo
index 5deb1db03ba3..d7909bd177a0 100644
--- a/devel/libzookeeper/distinfo
+++ b/devel/libzookeeper/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1601308293
-SHA256 (apache-zookeeper-3.6.2.tar.gz) = 62d9e865a7b1da5e906ff39ebf40cfa1880303c04b4cf38e2c88d328bc2bcd6f
-SIZE (apache-zookeeper-3.6.2.tar.gz) = 3372391
+TIMESTAMP = 1617193329
+SHA256 (apache-zookeeper-3.7.0.tar.gz) = cb3980f61b66babe550dcb717c940160ba813512c0aca26c2b8a718fac5d465d
+SIZE (apache-zookeeper-3.7.0.tar.gz) = 3438672
diff --git a/devel/libzookeeper/files/zookeeper.jute.c b/devel/libzookeeper/files/zookeeper.jute.c
index b8d0eae6c693..a68e2b7144f9 100644
--- a/devel/libzookeeper/files/zookeeper.jute.c
+++ b/devel/libzookeeper/files/zookeeper.jute.c
@@ -126,6 +126,26 @@ int deserialize_StatPersisted(struct iarchive *in, const char *tag, struct StatP
}
void deallocate_StatPersisted(struct StatPersisted*v){
}
+int serialize_ClientInfo(struct oarchive *out, const char *tag, struct ClientInfo *v){
+ int rc;
+ rc = out->start_record(out, tag);
+ rc = rc ? rc : out->serialize_String(out, "authScheme", &v->authScheme);
+ rc = rc ? rc : out->serialize_String(out, "user", &v->user);
+ rc = rc ? rc : out->end_record(out, tag);
+ return rc;
+}
+int deserialize_ClientInfo(struct iarchive *in, const char *tag, struct ClientInfo*v){
+ int rc;
+ rc = in->start_record(in, tag);
+ rc = rc ? rc : in->deserialize_String(in, "authScheme", &v->authScheme);
+ rc = rc ? rc : in->deserialize_String(in, "user", &v->user);
+ rc = rc ? rc : in->end_record(in, tag);
+ return rc;
+}
+void deallocate_ClientInfo(struct ClientInfo*v){
+ deallocate_String(&v->authScheme);
+ deallocate_String(&v->user);
+}
int serialize_ConnectRequest(struct oarchive *out, const char *tag, struct ConnectRequest *v){
int rc;
rc = out->start_record(out, tag);
@@ -1115,6 +1135,68 @@ int deserialize_GetEphemeralsResponse(struct iarchive *in, const char *tag, stru
void deallocate_GetEphemeralsResponse(struct GetEphemeralsResponse*v){
deallocate_String_vector(&v->ephemerals);
}
+int allocate_ClientInfo_vector(struct ClientInfo_vector *v, int32_t len) {
+ if (!len) {
+ v->count = 0;
+ v->data = 0;
+ } else {
+ v->count = len;
+ v->data = calloc(sizeof(*v->data), len);
+ }
+ return 0;
+}
+int deallocate_ClientInfo_vector(struct ClientInfo_vector *v) {
+ if (v->data) {
+ int32_t i;
+ for(i=0;i<v->count; i++) {
+ deallocate_ClientInfo(&v->data[i]);
+ }
+ free(v->data);
+ v->data = 0;
+ }
+ return 0;
+}
+int serialize_ClientInfo_vector(struct oarchive *out, const char *tag, struct ClientInfo_vector *v)
+{
+ int32_t count = v->count;
+ int rc = 0;
+ int32_t i;
+ rc = out->start_vector(out, tag, &count);
+ for(i=0;i<v->count;i++) {
+ rc = rc ? rc : serialize_ClientInfo(out, "data", &v->data[i]);
+ }
+ rc = rc ? rc : out->end_vector(out, tag);
+ return rc;
+}
+int deserialize_ClientInfo_vector(struct iarchive *in, const char *tag, struct ClientInfo_vector *v)
+{
+ int rc = 0;
+ int32_t i;
+ rc = in->start_vector(in, tag, &v->count);
+ v->data = calloc(v->count, sizeof(*v->data));
+ for(i=0;i<v->count;i++) {
+ rc = rc ? rc : deserialize_ClientInfo(in, "value", &v->data[i]);
+ }
+ rc = in->end_vector(in, tag);
+ return rc;
+}
+int serialize_WhoAmIResponse(struct oarchive *out, const char *tag, struct WhoAmIResponse *v){
+ int rc;
+ rc = out->start_record(out, tag);
+ rc = rc ? rc : serialize_ClientInfo_vector(out, "clientInfo", &v->clientInfo);
+ rc = rc ? rc : out->end_record(out, tag);
+ return rc;
+}
+int deserialize_WhoAmIResponse(struct iarchive *in, const char *tag, struct WhoAmIResponse*v){
+ int rc;
+ rc = in->start_record(in, tag);
+ rc = rc ? rc : deserialize_ClientInfo_vector(in, "clientInfo", &v->clientInfo);
+ rc = rc ? rc : in->end_record(in, tag);
+ return rc;
+}
+void deallocate_WhoAmIResponse(struct WhoAmIResponse*v){
+ deallocate_ClientInfo_vector(&v->clientInfo);
+}
int serialize_LearnerInfo(struct oarchive *out, const char *tag, struct LearnerInfo *v){
int rc;
rc = out->start_record(out, tag);
diff --git a/devel/libzookeeper/files/zookeeper.jute.h b/devel/libzookeeper/files/zookeeper.jute.h
index b02063a2a34c..c4899db3fc06 100644
--- a/devel/libzookeeper/files/zookeeper.jute.h
+++ b/devel/libzookeeper/files/zookeeper.jute.h
@@ -68,6 +68,13 @@ struct StatPersisted {
int serialize_StatPersisted(struct oarchive *out, const char *tag, struct StatPersisted *v);
int deserialize_StatPersisted(struct iarchive *in, const char *tag, struct StatPersisted*v);
void deallocate_StatPersisted(struct StatPersisted*);
+struct ClientInfo {
+ char * authScheme;
+ char * user;
+};
+int serialize_ClientInfo(struct oarchive *out, const char *tag, struct ClientInfo *v);
+int deserialize_ClientInfo(struct iarchive *in, const char *tag, struct ClientInfo*v);
+void deallocate_ClientInfo(struct ClientInfo*);
struct ConnectRequest {
int32_t protocolVersion;
int64_t lastZxidSeen;
@@ -414,6 +421,21 @@ struct GetEphemeralsResponse {
int serialize_GetEphemeralsResponse(struct oarchive *out, const char *tag, struct GetEphemeralsResponse *v);
int deserialize_GetEphemeralsResponse(struct iarchive *in, const char *tag, struct GetEphemeralsResponse*v);
void deallocate_GetEphemeralsResponse(struct GetEphemeralsResponse*);
+struct ClientInfo_vector {
+ int32_t count;
+ struct ClientInfo *data;
+
+};
+int serialize_ClientInfo_vector(struct oarchive *out, const char *tag, struct ClientInfo_vector *v);
+int deserialize_ClientInfo_vector(struct iarchive *in, const char *tag, struct ClientInfo_vector *v);
+int allocate_ClientInfo_vector(struct ClientInfo_vector *v, int32_t len);
+int deallocate_ClientInfo_vector(struct ClientInfo_vector *v);
+struct WhoAmIResponse {
+ struct ClientInfo_vector clientInfo;
+};
+int serialize_WhoAmIResponse(struct oarchive *out, const char *tag, struct WhoAmIResponse *v);
+int deserialize_WhoAmIResponse(struct iarchive *in, const char *tag, struct WhoAmIResponse*v);
+void deallocate_WhoAmIResponse(struct WhoAmIResponse*);
struct LearnerInfo {
int64_t serverid;
int32_t protocolVersion;