aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-09-07 07:26:05 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-09-07 08:04:09 +0000
commit905b1bd86fd5a0a40ce912c5d96992303a05aa62 (patch)
treeff03bb0982e533bf645adfe0b17881388f06b2e4
parent83d8cc195d9f54e71ee8841970f955b331da7249 (diff)
downloadports-905b1bd86fd5a0a40ce912c5d96992303a05aa62.tar.gz
ports-905b1bd86fd5a0a40ce912c5d96992303a05aa62.zip
Uses/cargo: Try to load Makefile.crates
Some ports stash the `make cargo-crates` output there which might as well be supported by USES=cargo.
-rw-r--r--Mk/Uses/cargo.mk2
-rw-r--r--dns/doh-proxy/Makefile1
-rw-r--r--multimedia/librespot/Makefile2
-rw-r--r--net-p2p/openethereum/Makefile2
-rw-r--r--sysutils/jail_exporter/Makefile3
5 files changed, 2 insertions, 8 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index a0a88701e62e..7df138518f88 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -14,6 +14,8 @@ _INCLUDE_USES_CARGO_MK= yes
IGNORE+= USES=cargo takes no arguments
.endif
+.sinclude "${MASTERDIR}/Makefile.crates"
+
# List of static dependencies. The format is cratename-version.
# CARGO_CRATES will be downloaded from MASTER_SITE_CRATESIO.
CARGO_CRATES?=
diff --git a/dns/doh-proxy/Makefile b/dns/doh-proxy/Makefile
index 42d3b1c29289..0ce5ae9bc572 100644
--- a/dns/doh-proxy/Makefile
+++ b/dns/doh-proxy/Makefile
@@ -18,7 +18,6 @@ USES= cargo
PLIST_FILES= bin/doh-proxy
# make cargo-crates > Makefile.crates
-.include "Makefile.crates"
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/doh-proxy
diff --git a/multimedia/librespot/Makefile b/multimedia/librespot/Makefile
index b451afca17ca..8a1abee4af60 100644
--- a/multimedia/librespot/Makefile
+++ b/multimedia/librespot/Makefile
@@ -45,8 +45,6 @@ TREMOR_VARS= CARGO_FEATURES+=with-tremor
VORBIS_LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
VORBIS_VARS= CARGO_FEATURES+=with-vorbis
-.include "Makefile.crates"
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/librespot
diff --git a/net-p2p/openethereum/Makefile b/net-p2p/openethereum/Makefile
index 626bf34e4fd2..3dc186f64349 100644
--- a/net-p2p/openethereum/Makefile
+++ b/net-p2p/openethereum/Makefile
@@ -21,8 +21,6 @@ CARGO_TEST= yes
RUSTFLAGS+= -C link-arg=-fuse-ld=lld
-.include "${.CURDIR}/Makefile.crates"
-
CARGO_GIT_SUBDIR= rethutil:reth-util:crates/util
post-install:
diff --git a/sysutils/jail_exporter/Makefile b/sysutils/jail_exporter/Makefile
index d01d5154d14e..ae87eaf89643 100644
--- a/sysutils/jail_exporter/Makefile
+++ b/sysutils/jail_exporter/Makefile
@@ -17,9 +17,6 @@ USE_RC_SUBR= jail_exporter
OPTIONS_DEFINE= DOCS
-# This Makefile contains the CARGO_CRATES section.
-.include "Makefile.crates"
-
post-install:
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.8 \
${STAGEDIR}${MANPREFIX}/man/man8