aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2023-09-12 13:46:25 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-09-12 13:46:25 +0000
commit9124172c050698257c1da6a4de81c3c36d480e5c (patch)
tree0348e9a164470ff1bc81df0ffc104bb12207cfed
parenta366400c3e351c131530de3ed7330e5ef5e88cdc (diff)
downloadports-9124172c050698257c1da6a4de81c3c36d480e5c.tar.gz
ports-9124172c050698257c1da6a4de81c3c36d480e5c.zip
devel/bloomberg-bde: tidy ports Makefile
- the build system uses -march=westmere, so restrict to that kind of architecture - while here pet portlint No bump to PORTREVISION because it still builds in the same places and I dont' feel that a one-bit change to COMMENT is worth re-packaging.
-rw-r--r--devel/bloomberg-bde/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/bloomberg-bde/Makefile b/devel/bloomberg-bde/Makefile
index a8b024f93213..aa7c77ff8b3b 100644
--- a/devel/bloomberg-bde/Makefile
+++ b/devel/bloomberg-bde/Makefile
@@ -5,11 +5,14 @@ CATEGORIES= devel
PKGNAMEPREFIX= bloomberg-
MAINTAINER= adridg@FreeBSD.org
-COMMENT= foundational C++ libraries used at Bloomberg
+COMMENT= Foundational C++ libraries used at Bloomberg
WWW= https://github.com/bloomberg/bde
LICENSE= APACHE20
+ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS_REASON= Build uses -march=westmere
+
USES= cmake python:build pkgconfig
USE_GITHUB= yes
@@ -42,7 +45,7 @@ post-stage:
_test_label= bsla.t
do-test:
- cd ${TEST_WRKSRC} && ninja `ctest -N -L ${_test_label} | awk '/Test *#/{print $$3}'`
+ cd ${TEST_WRKSRC} && ninja `ctest -N -L ${_test_label} | ${AWK} '/Test *#/{print $$3}'`
cd ${TEST_WRKSRC} && ctest -L ${_test_label}
.include <bsd.port.mk>