aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-14 07:11:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-14 07:11:55 +0000
commit912a0fceb5903543c97d9abfc309831d9f12dcb2 (patch)
treec9b2e392470a6ede16a46cc9ca30f8dbcf4b4623
parent47b797b69832d37409020245d5dc3fa808abd87b (diff)
downloadports-912a0fceb5903543c97d9abfc309831d9f12dcb2.tar.gz
ports-912a0fceb5903543c97d9abfc309831d9f12dcb2.zip
biology/locarna: Fix build on 14.x and main
The code uses the STL method that was remved in C++17. Reported by: fallout
-rw-r--r--biology/locarna/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/biology/locarna/Makefile b/biology/locarna/Makefile
index 4483c3792d59..53d51d26f8c8 100644
--- a/biology/locarna/Makefile
+++ b/biology/locarna/Makefile
@@ -19,6 +19,7 @@ TEST_DEPENDS= bash:shells/bash \
USES= autoreconf gmake libtool perl5 pkgconfig shebangfix
USE_LDCONFIG= yes
+USE_CXXSTD= c++14 # workaround for https://github.com/s-will/LocARNA/issues/82 (LocARNA uses the removed STL method)
CXXFLAGS+= -I${LOCALBASE}/include/catch2 # use external catch