aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-03-18 12:51:27 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-03-18 12:51:30 +0000
commit91a3c4def796cf45e6c2c404a2f8808e14ae7355 (patch)
treee25625d194a79943ec6e7a3410a094bac80759ae
parentc8d58be2cf8bec92ad3586ec1c38ba547bd09e16 (diff)
downloadports-91a3c4def796cf45e6c2c404a2f8808e14ae7355.tar.gz
ports-91a3c4def796cf45e6c2c404a2f8808e14ae7355.zip
textproc/libextractor: Remove FFmpeg support
Breaks build with FFmpeg 6.0 and support is removed upstream Reference: https://git.gnunet.org/libextractor.git/commit/?id=2332716ae48d6b899e4d2bb07f468e8c076d2608 PR: 261302
-rw-r--r--textproc/libextractor/Makefile11
-rw-r--r--textproc/libextractor/pkg-plist4
2 files changed, 5 insertions, 10 deletions
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index dfe2b173dc9f..abde85e69b0a 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libextractor
PORTVERSION= 1.11
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= GNU
@@ -25,7 +25,8 @@ USE_LDCONFIG= yes
CONFLICTS_INSTALL= csound outguess # bin/extract
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gtk-version=2 \
+CONFIGURE_ARGS= --disable-ffmpeg \
+ --with-gtk-version=2 \
--with-ltdl=${LOCALBASE}
INSTALL_TARGET= install-strip
@@ -35,10 +36,10 @@ LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
INFO= libextractor
-OPTIONS_DEFINE= EXIV2 FFMPEG FLAC GIF GSF GSTREAMER MPEG2 MP4 \
+OPTIONS_DEFINE= EXIV2 FLAC GIF GSF GSTREAMER MPEG2 MP4 \
NLS RPM SMF TIDY VORBIS
-OPTIONS_DEFAULT= EXIV2 FFMPEG FLAC GIF GSF GSTREAMER MPEG2 MP4 \
+OPTIONS_DEFAULT= EXIV2 FLAC GIF GSF GSTREAMER MPEG2 MP4 \
RPM SMF TIDY VORBIS
OPTIONS_SUB= yes
@@ -50,8 +51,6 @@ SMF_DESC= Standard MIDI file support via LibSMF
EXIV2_LIB_DEPENDS= libexiv2.so:graphics/exiv2
EXIV2_CONFIGURE_ENV= EXIV2_H="<exiv2/image.hpp>"
EXIV2_CONFIGURE_ENV_OFF= EXIV2_H=""
-FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-FFMPEG_CONFIGURE_ENABLE= ffmpeg
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
FLAC_CONFIGURE_ENV_OFF=ac_cv_lib_FLAC_FLAC__stream_decoder_init_stream=no
GIF_LIB_DEPENDS= libgif.so:graphics/giflib
diff --git a/textproc/libextractor/pkg-plist b/textproc/libextractor/pkg-plist
index 6a404d29abc4..65a0d10845ab 100644
--- a/textproc/libextractor/pkg-plist
+++ b/textproc/libextractor/pkg-plist
@@ -46,8 +46,6 @@ lib/libextractor/libextractor_pdf.a
lib/libextractor/libextractor_pdf.so
lib/libextractor/libextractor_png.a
lib/libextractor/libextractor_png.so
-%%FFMPEG%%lib/libextractor/libextractor_previewopus.a
-%%FFMPEG%%lib/libextractor/libextractor_previewopus.so
lib/libextractor/libextractor_ps.a
lib/libextractor/libextractor_ps.so
lib/libextractor/libextractor_riff.a
@@ -58,8 +56,6 @@ lib/libextractor/libextractor_s3m.a
lib/libextractor/libextractor_s3m.so
lib/libextractor/libextractor_sid.a
lib/libextractor/libextractor_sid.so
-%%FFMPEG%%lib/libextractor/libextractor_thumbnailffmpeg.a
-%%FFMPEG%%lib/libextractor/libextractor_thumbnailffmpeg.so
lib/libextractor/libextractor_thumbnailgtk.a
lib/libextractor/libextractor_thumbnailgtk.so
lib/libextractor/libextractor_tiff.a