aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-16 16:29:20 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-16 17:46:50 +0000
commit91bc9e8990add7abfe33a7330c770536b03a58e7 (patch)
treed8a1868abdbd6943a875431552318611f0309bc8
parent4825f732b46977e0ff4babedbd37ae312e12ae32 (diff)
downloadports-91bc9e8990add7abfe33a7330c770536b03a58e7.tar.gz
ports-91bc9e8990add7abfe33a7330c770536b03a58e7.zip
devel/libs11n: Fix build with llvm16
- Pet portclippy - Adopt port Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/libs11n/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/devel/libs11n/Makefile b/devel/libs11n/Makefile
index 6001298e0ce8..b16cb8f56611 100644
--- a/devel/libs11n/Makefile
+++ b/devel/libs11n/Makefile
@@ -12,6 +12,7 @@ WWW= http://s11n.net/
LICENSE= PD
USES= uidfix zip
+USE_CXXSTD= c++11
USE_LDCONFIG= yes
PORTSCOUT= limitw:1,even
@@ -29,6 +30,14 @@ PLIST_SUB+= PROFILE=""
post-extract:
@${CP} ${PATCHDIR}/Makefile.bsd ${WRKSRC}/Makefile
+post-patch:
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+ @${REINPLACE_CMD} -e 's|auto_ptr|unique_ptr|' \
+ ${WRKSRC}/../include/s11n.net/s11n/algo.tpp \
+ ${WRKSRC}/../include/s11n.net/s11n/io/data_node_format.hpp \
+ ${WRKSRC}/../include/s11n.net/s11n/io/data_node_io.hpp
+.endif
+
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/s11n.net
${MKDIR} ${STAGEDIR}${PREFIX}/include/s11n.net/s11n