aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Moerz <freebsd@ny-central.org>2023-11-20 16:00:25 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-11-22 22:44:00 +0000
commit921ff7ab739ad286a29bfb3ac3731a1228f0a4b1 (patch)
tree376e238db74ec1f4d3fcc4a34565d17196fb37ca
parentd67975600c84a139dea0cc29490273c79eccb564 (diff)
downloadports-921ff7ab739ad286a29bfb3ac3731a1228f0a4b1.tar.gz
ports-921ff7ab739ad286a29bfb3ac3731a1228f0a4b1.zip
deskutils/ganttproject: Update version 3.1.3100=>3.2.3240
Changelog: https://www.ganttproject.biz/download/gp30 PR: 274754 Approved by: Submitter is maintainer
-rw-r--r--deskutils/ganttproject/Makefile5
-rw-r--r--deskutils/ganttproject/distinfo6
-rw-r--r--deskutils/ganttproject/files/patch-ganttproject70
-rw-r--r--deskutils/ganttproject/pkg-plist119
4 files changed, 136 insertions, 64 deletions
diff --git a/deskutils/ganttproject/Makefile b/deskutils/ganttproject/Makefile
index 9b51f4295ce4..bdebc2fb06a4 100644
--- a/deskutils/ganttproject/Makefile
+++ b/deskutils/ganttproject/Makefile
@@ -1,9 +1,8 @@
PORTNAME= ganttproject
-DISTVERSION= 3.1.3100
-PORTREVISION= 1
+DISTVERSION= 3.2.3240
CATEGORIES= deskutils java
MASTER_SITES= https://github.com/bardsoftware/ganttproject/releases/download/ganttproject-${DISTVERSION}/ \
- https://dl.ganttproject.biz/ganttproject-3.1.3100/
+ https://dl.ganttproject.biz/ganttproject-3.2.3240/
MAINTAINER= freebsd@ny-central.org
COMMENT= Gantt chart based project scheduling and management tool
diff --git a/deskutils/ganttproject/distinfo b/deskutils/ganttproject/distinfo
index 8565dcf24f7a..90782fc7ad47 100644
--- a/deskutils/ganttproject/distinfo
+++ b/deskutils/ganttproject/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621768579
-SHA256 (ganttproject-3.1.3100.zip) = 4e7ea4b8ea50f41afef868b5c080e2ab7cfa28deda890f0a831dfd1717460a6d
-SIZE (ganttproject-3.1.3100.zip) = 39982185
+TIMESTAMP = 1698336656
+SHA256 (ganttproject-3.2.3240.zip) = 38dbddaf4c55ff7731e3a061dde9a8b38236789409ee3b5ab8228d96688748bd
+SIZE (ganttproject-3.2.3240.zip) = 40679709
diff --git a/deskutils/ganttproject/files/patch-ganttproject b/deskutils/ganttproject/files/patch-ganttproject
new file mode 100644
index 000000000000..c0340cd03fa8
--- /dev/null
+++ b/deskutils/ganttproject/files/patch-ganttproject
@@ -0,0 +1,70 @@
+--- ganttproject.orig 2023-10-26 16:28:31 UTC
++++ ganttproject
+@@ -64,7 +64,7 @@ fi
+
+ USE_BUNDLED_RUNTIME=1
+ DEBUG_ARGS=""
+-APP_ARGS=()
++APP_ARGS=""
+
+ while true; do
+ case "$1" in
+@@ -99,7 +99,7 @@ while true; do
+ break;
+ ;;
+ *)
+- APP_ARGS+=("$1")
++ APP_ARGS="$APP_ARG $1"
+ shift 1
+ ;;
+ esac
+@@ -139,15 +139,29 @@ check_java() {
+ return 1
+ fi
+
+- VERSION="$( $JAVA_COMMAND -version 2>&1 | grep version | head -n 1)"
++ VERSION="$( $JAVA_COMMAND -version 2>&1 | grep version | head -n 1 | grep -Eo '\".*\"' | cut -c 2-4 )"
+ log "...found $VERSION"
+- [[ "$VERSION" =~ 11\.? ]] && return 0;
+- [[ "$VERSION" =~ 12\.? ]] && return 0;
+- [[ "$VERSION" =~ 13\.? ]] && return 0;
+- [[ "$VERSION" =~ 14\.? ]] && return 0;
+- [[ "$VERSION" =~ 15\.? ]] && return 0;
+- [[ "$VERSION" =~ 16\.? ]] && return 0;
+- [[ "$VERSION" =~ 17\.? ]] && return 0;
++ if [ "$VERSION" == "11." ]; then
++ return 0;
++ fi
++ if [ "$VERSION" == "12." ]; then
++ return 0;
++ fi
++ if [ "$VERSION" == "13." ]; then
++ return 0;
++ fi
++ if [ "$VERSION" == "14." ]; then
++ return 0;
++ fi
++ if [ "$VERSION" == "15." ]; then
++ return 0;
++ fi
++ if [ "$VERSION" == "16." ]; then
++ return 0;
++ fi
++ if [ "$VERSION" == "17." ]; then
++ return 0;
++ fi
+ log "...this seems to be an old Java Runtime";
+ JAVA_COMMAND=""
+ return 1
+@@ -214,7 +228,9 @@ JAVA_EXPORTS="--add-exports javafx.controls/com.sun.ja
+ --add-exports javafx.graphics/com.sun.javafx.util=ALL-UNNAMED\
+ --add-opens java.desktop/sun.swing=ALL-UNNAMED\
+ --add-opens java.desktop/sun.awt.X11=ALL-UNNAMED"
+-"$JAVA_COMMAND" -Xmx1024m $JAVA_EXPORTS -Duser.dir="$(pwd)" $DEBUG_ARGS $BOOT_CLASS \
++"$JAVA_COMMAND" \
++ --module-path=/usr/local/openjfx14/lib --add-modules=javafx.swing,javafx.web,javafx.graphics,javafx.controls \
++ -Xmx1024m $JAVA_EXPORTS -Duser.dir="$(pwd)" $DEBUG_ARGS $BOOT_CLASS \
+ --app net.sourceforge.ganttproject.GanttProject \
+ --version-dirs "$GP_HOME"/plugins:~/.ganttproject.d/updates \
+- -log true -log_file "$LOG_FILE" "${APP_ARGS[@]}"
++ -log true -log_file "$LOG_FILE" "$APP_ARGS"
diff --git a/deskutils/ganttproject/pkg-plist b/deskutils/ganttproject/pkg-plist
index 870ad40a26db..e79828589e67 100644
--- a/deskutils/ganttproject/pkg-plist
+++ b/deskutils/ganttproject/pkg-plist
@@ -1,9 +1,11 @@
-@(,,0755) bin/ganttproject
+bin/ganttproject
share/applications/ganttproject.desktop
%%DATADIR%%/HouseBuildingSample.gan
+%%DATADIR%%/LICENSE
%%DATADIR%%/eclipsito.jar
-@(,,0755) %%DATADIR%%/ganttproject
-@comment %%DATADIR%%/LICENSE
+@(,,2755) %%DATADIR%%/ganttproject
+%%DATADIR%%/ganttproject.bak
+%%DATADIR%%/ganttproject.l4j.ini
%%DATADIR%%/lib/javagalician.jar
%%DATADIR%%/logback.xml
%%DATADIR%%/logging.properties
@@ -15,44 +17,44 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-codec-1.15.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-collections4-4.4.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-csv.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-io-2.8.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-io-2.11.0.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-lang3-3.12.0.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-logging-1.2.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-math3-3.6.1.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/commons-net-ftpclient-3.0.1.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/concurrentlinkedhashmap-lru-1.4.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/controlsfx-11.1.0.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-ext-attributes-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-ext-gfm-strikethrough-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-ext-tables-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-ast-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-builder-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-collection-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-data-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-dependency-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-format-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-html-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-misc-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-options-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-sequence-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-visitor-0.62.2.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/fontawesomefx-commons-11.0.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/fontawesomefx-fontawesome-4.7.0-11.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/fontawesomefx-materialicons-2.2.0-11.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/controlsfx-11.1.1.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-ext-attributes-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-ext-gfm-strikethrough-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-ext-tables-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-ast-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-builder-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-collection-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-data-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-dependency-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-format-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-html-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-misc-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-options-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-sequence-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/flexmark-util-visitor-0.64.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/fontawesomefx-commons-9.1.2.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/fontawesomefx-fontawesome-4.7.0-9.1.2.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/fontawesomefx-materialicons-2.2.0-9.1.2.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/ganttproject-jxbusycomponent-1.2.2.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/httpclient-4.5.13.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/httpcore-4.4.13.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/httpmime-4.5.13.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jackson-annotations-2.12.3.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jackson-core-2.12.3.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jackson-databind-2.12.3.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jcl-over-slf4j-1.7.30.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jdom-2.0.2.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jackson-annotations-2.13.2.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jackson-core-2.13.2.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jackson-databind-2.13.2.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jdom-1.1.3.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jgoodies-common-1.8.1.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jgoodies-looks-2.7.0.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/jxlayer-3.0.4.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/log4j-api-2.17.2.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/mdfx-0.2.0-SNAPSHOT.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/milton-api-2.7.4.4.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/milton-client-2.7.4.4-bs.jar
@@ -60,10 +62,10 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/okhttp-3.14.9.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/okio-1.17.2.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/org.bouncycastle.openpgp-1.67-with-deps.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/poi-5.0.0.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/poi-5.2.2.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/retry4j-0.15.0.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/slf4j-api-1.7.30.jar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/slf4j-jdk14-1.7.30.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/slf4j-api-1.7.36.jar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/slf4j-jdk14-1.7.36.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/lib/swingx-1.6.4.jar
%%DATADIR%%/plugins/base/biz.ganttproject.app.libs/plugin.xml
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/plugin.xml
@@ -82,6 +84,7 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_cz.calendar
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_de.calendar
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_de_austria.calendar
+%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_en_JP.calendar
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_en_australia.calendar
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_en_australia_nsw.calendar
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_en_australia_queensland.calendar
@@ -125,7 +128,6 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_uk_northern_ireland.calendar
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_uk_scotland.calendar
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/resources/calendars/i18n_us.calendar
-%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/crowdin2prb.sh
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_ar_SA.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_bg_BG.properties
@@ -164,7 +166,7 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_ru_RU.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_sk_SK.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_sl_SI.properties
-%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_sr_SP.properties
+%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_sr.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_sv_SE.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_tg_TJ.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_tr_TR.properties
@@ -172,27 +174,31 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_vi_VN.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_zh_CN.properties
%%DATADIR%%/plugins/base/biz.ganttproject.app.localization/translations/i18n_zh_TW.properties
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/animal-sniffer-annotations-1.14.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/annotations-13.0.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/biz.ganttproject.core-21.05.18.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/checker-qual-2.0.0.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/error_prone_annotations-2.1.3.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/guava-25.1-jre.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/j2objc-annotations-1.1.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/biz.ganttproject.core-22.03.31.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/checker-qual-3.12.0.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/error_prone_annotations-2.11.0.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/failureaccess-1.0.1.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/guava-31.1-jre.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/j2objc-annotations-1.3.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/jsr305-3.0.2.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-1.5.0.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-common-1.5.0.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-jdk7-1.5.0.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-jdk8-1.5.0.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-reflect-1.6.10.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-1.6.10.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-common-1.6.10.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-jdk7-1.6.10.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlin-stdlib-jdk8-1.6.10.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlinx-coroutines-core-jvm-1.6.0.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/kotlinx-coroutines-javafx-1.6.0.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.core/lib/listenablefuture-9999.0-empty-to-avoid-conflict-with-guava.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.core/plugin.xml
%%DATADIR%%/plugins/base/biz.ganttproject.core/resources/img/notes.png
%%DATADIR%%/plugins/base/biz.ganttproject.impex.ical/lib/backport-util-concurrent-3.1.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.impex.ical/lib/biz.ganttproject.impex.ical-21.05.18.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.impex.ical/lib/biz.ganttproject.impex.ical-22.03.31.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.ical/lib/commons-lang-2.6.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.impex.ical/lib/ical4j-1.0.7.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.impex.ical/lib/ical4j-1.0.8.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.ical/plugin.xml
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/FastInfoset-1.2.16.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/biz.ganttproject.impex.msproject2-21.05.18.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/biz.ganttproject.impex.msproject2-22.03.31.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/istack-commons-runtime-3.0.8.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/jakarta.activation-api-1.2.1.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/jakarta.xml.bind-api-2.3.2.jar.lib
@@ -200,21 +206,20 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/jaxb-api-2.3.1.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/jaxb-impl-2.1.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/jaxb-runtime-2.3.2.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/jsoup-1.13.1.jar.lib
-%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/mpxj-9.3.0.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/jsoup-1.14.2.jar.lib
+%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/mpxj-10.2.0.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/rtfparserkit-1.16.0.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/stax-ex-1.8.1.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/lib/txw2-2.3.2.jar.lib
%%DATADIR%%/plugins/base/biz.ganttproject.impex.msproject2/plugin.xml
-%%DATADIR%%/plugins/base/ganttproject/lib/eclipsito.jar.lib
-%%DATADIR%%/plugins/base/ganttproject/lib/ganttproject-21.05.18.jar.lib
-%%DATADIR%%/plugins/base/ganttproject/lib/kotlinx-coroutines-core-jvm-1.4.3.jar.lib
-%%DATADIR%%/plugins/base/ganttproject/lib/kotlinx-coroutines-javafx-1.4.3.jar.lib
+%%DATADIR%%/plugins/base/ganttproject/lib/ganttproject-22.03.31.jar.lib
%%DATADIR%%/plugins/base/ganttproject/plugin.xml
%%DATADIR%%/plugins/base/ganttproject/resources/charsets.properties
%%DATADIR%%/plugins/base/ganttproject/resources/chart.properties
%%DATADIR%%/plugins/base/ganttproject/resources/fontawesome-webfont.ttf
%%DATADIR%%/plugins/base/ganttproject/resources/fontawesome.properties
+%%DATADIR%%/plugins/base/ganttproject/resources/fonts/DroidSansFallbackFull.ttc
+%%DATADIR%%/plugins/base/ganttproject/resources/fonts/LiberationSans-Regular.ttf
%%DATADIR%%/plugins/base/ganttproject/resources/icons.properties
%%DATADIR%%/plugins/base/ganttproject/resources/icons/16x16/appointment-new.png
%%DATADIR%%/plugins/base/ganttproject/resources/icons/16x16/arrow-up.png
@@ -452,15 +457,13 @@ share/applications/ganttproject.desktop
%%DATADIR%%/plugins/base/ganttproject/resources/xslt/gantt-tasks.xsl
%%DATADIR%%/plugins/base/ganttproject/resources/xslt/gantt-utils.xsl
%%DATADIR%%/plugins/base/ganttproject/resources/xslt/gantt.xsl
-%%DATADIR%%/plugins/base/org.ganttproject.chart.pert/lib/org.ganttproject.chart.pert-21.05.18.jar.lib
+%%DATADIR%%/plugins/base/org.ganttproject.chart.pert/lib/org.ganttproject.chart.pert-22.03.31.jar.lib
%%DATADIR%%/plugins/base/org.ganttproject.chart.pert/plugin.xml
%%DATADIR%%/plugins/base/org.ganttproject.chart.pert/resources/icons/pert_16.gif
%%DATADIR%%/plugins/base/org.ganttproject.chart.pert/resources/icons/pert_24.gif
-%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/lib/itextpdf-5.5.13.2.jar.lib
-%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/lib/org.ganttproject.impex.htmlpdf-21.05.18.jar.lib
+%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/lib/itextpdf-5.5.13.3.jar.lib
+%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/lib/org.ganttproject.impex.htmlpdf-22.03.31.jar.lib
%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/plugin.xml
-%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/resources/fonts/DroidSansFallbackFull.ttc
-%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/resources/fonts/LiberationSans-Regular.ttf
%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/resources/html-export-themes/default/gantt-chart.xsl
%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/resources/html-export-themes/default/gantt-resources.xsl
%%DATADIR%%/plugins/base/org.ganttproject.impex.htmlpdf/resources/html-export-themes/default/gantt-tasks.xsl