aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-02-01 06:06:31 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2022-02-01 06:06:31 +0000
commit9221ac266bd205dca7c666ad7f88c717113c3a37 (patch)
tree8670e3dc3f559c48b48c38293ea036ae5dcafe49
parent2be648cefd5b3215460d7846a075f72df8715b6e (diff)
downloadports-9221ac266bd205dca7c666ad7f88c717113c3a37.tar.gz
ports-9221ac266bd205dca7c666ad7f88c717113c3a37.zip
devel/cmake: Update to 3.22.2
-rw-r--r--devel/cmake-doc/Makefile2
-rw-r--r--devel/cmake-gui/Makefile2
-rw-r--r--devel/cmake/Makefile2
-rw-r--r--devel/cmake/distinfo6
-rw-r--r--devel/cmake/files/patch-Modules_FindBoost.cmake8
5 files changed, 10 insertions, 10 deletions
diff --git a/devel/cmake-doc/Makefile b/devel/cmake-doc/Makefile
index 18c7f64881b3..1f78ad5fb15a 100644
--- a/devel/cmake-doc/Makefile
+++ b/devel/cmake-doc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cmake
-DISTVERSION= 3.22.1
+DISTVERSION= 3.22.2
CATEGORIES= devel
MASTER_SITES= https://www.cmake.org/files/v${PORTVERSION:R}/
PKGNAMESUFFIX= -doc
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 72f1b6866ef5..6771197152b6 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cmake
-DISTVERSION= 3.22.1
+DISTVERSION= 3.22.2
CATEGORIES= devel
MASTER_SITES= https://www.cmake.org/files/v${PORTVERSION:R}/
PKGNAMESUFFIX= -gui
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index b340a88a5ed6..69095886dc8d 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cmake
# Remember to update devel/cmake-doc and devel/cmake-gui as well.
-DISTVERSION= 3.22.1
+DISTVERSION= 3.22.2
CATEGORIES= devel
MASTER_SITES= https://github.com/Kitware/CMake/releases/download/v${DISTVERSION}/ \
https://www.cmake.org/files/v${PORTVERSION}/
diff --git a/devel/cmake/distinfo b/devel/cmake/distinfo
index 6da2fdba1ed2..56ce88034903 100644
--- a/devel/cmake/distinfo
+++ b/devel/cmake/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1639168771
-SHA256 (cmake-3.22.1.tar.gz) = 0e998229549d7b3f368703d20e248e7ee1f853910d42704aa87918c213ea82c0
-SIZE (cmake-3.22.1.tar.gz) = 9778031
+TIMESTAMP = 1643176841
+SHA256 (cmake-3.22.2.tar.gz) = 3c1c478b9650b107d452c5bd545c72e2fad4e37c09b89a1984b9a2f46df6aced
+SIZE (cmake-3.22.2.tar.gz) = 9779456
diff --git a/devel/cmake/files/patch-Modules_FindBoost.cmake b/devel/cmake/files/patch-Modules_FindBoost.cmake
index b02e85249284..664b8749d839 100644
--- a/devel/cmake/files/patch-Modules_FindBoost.cmake
+++ b/devel/cmake/files/patch-Modules_FindBoost.cmake
@@ -1,4 +1,4 @@
---- Modules/FindBoost.cmake.orig 2021-07-14 14:10:23 UTC
+--- Modules/FindBoost.cmake.orig 2022-01-25 13:45:06 UTC
+++ Modules/FindBoost.cmake
@@ -135,6 +135,9 @@ This module reads hints about search locations from va
``BOOST_LIBRARYDIR``
@@ -20,7 +20,7 @@
#-------------------------------------------------------------------------------
# Before we go searching, check whether a boost cmake package is available, unless
# the user specifically asked NOT to search for one.
-@@ -2132,10 +2138,10 @@ foreach(COMPONENT ${Boost_FIND_COMPONENTS})
+@@ -2162,10 +2168,10 @@ foreach(COMPONENT ${Boost_FIND_COMPONENTS})
# Handle Python version suffixes
unset(COMPONENT_PYTHON_VERSION_MAJOR)
unset(COMPONENT_PYTHON_VERSION_MINOR)
@@ -28,8 +28,8 @@
+ if(${COMPONENT}${BOOST_PYTHON_SUFFIX} MATCHES "^(python|mpi_python|numpy)([0-9])\$")
set(COMPONENT_UNVERSIONED "${CMAKE_MATCH_1}")
set(COMPONENT_PYTHON_VERSION_MAJOR "${CMAKE_MATCH_2}")
-- elseif(${COMPONENT} MATCHES "^(python|mpi_python|numpy)([0-9])\\.?([0-9])\$")
-+ elseif(${COMPONENT}${BOOST_PYTHON_SUFFIX} MATCHES "^(python|mpi_python|numpy)([0-9])\\.?([0-9])\$")
+- elseif(${COMPONENT} MATCHES "^(python|mpi_python|numpy)([0-9])\\.?([0-9]+)\$")
++ elseif(${COMPONENT}${BOOST_PYTHON_SUFFIX} MATCHES "^(python|mpi_python|numpy)([0-9]+)\$")
set(COMPONENT_UNVERSIONED "${CMAKE_MATCH_1}")
set(COMPONENT_PYTHON_VERSION_MAJOR "${CMAKE_MATCH_2}")
set(COMPONENT_PYTHON_VERSION_MINOR "${CMAKE_MATCH_3}")