aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2022-05-23 10:43:37 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2022-05-23 10:46:14 +0000
commit9230d75a823cc4191f4ad358422762b175e91ccd (patch)
tree44a609d35add23ff293f899827080a01d67f6aa9
parent1e19f00e5e469b848aed2853cda3ba2368ceb784 (diff)
downloadports-9230d75a823cc4191f4ad358422762b175e91ccd.tar.gz
ports-9230d75a823cc4191f4ad358422762b175e91ccd.zip
postgresql??-server: fix regression in the rc script
The rc script was converted to use a SUB_LIST variable, but I failed to introduce the variable correctly in the Makefile. [1] The plist for postgresql15-server was incorrect. Fixed this as well. PR: 264097 [1]
-rw-r--r--databases/postgresql10-server/Makefile2
-rw-r--r--databases/postgresql11-server/Makefile2
-rw-r--r--databases/postgresql12-server/Makefile2
-rw-r--r--databases/postgresql13-server/Makefile2
-rw-r--r--databases/postgresql14-server/Makefile2
-rw-r--r--databases/postgresql15-server/Makefile5
-rw-r--r--databases/postgresql15-server/files/postgresql.in4
-rw-r--r--databases/postgresql15-server/pkg-plist-server84
8 files changed, 90 insertions, 13 deletions
diff --git a/databases/postgresql10-server/Makefile b/databases/postgresql10-server/Makefile
index 7a92076bd676..7d8a298ff514 100644
--- a/databases/postgresql10-server/Makefile
+++ b/databases/postgresql10-server/Makefile
@@ -3,7 +3,7 @@
DISTVERSION?= 10.21
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 0
+PORTREVISION?= 1
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql11-server/Makefile b/databases/postgresql11-server/Makefile
index 570b7c2b0fa6..cf0e0aba1686 100644
--- a/databases/postgresql11-server/Makefile
+++ b/databases/postgresql11-server/Makefile
@@ -3,7 +3,7 @@
DISTVERSION?= 11.16
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 0
+PORTREVISION?= 1
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql12-server/Makefile b/databases/postgresql12-server/Makefile
index 28b400576bfc..6682f3883028 100644
--- a/databases/postgresql12-server/Makefile
+++ b/databases/postgresql12-server/Makefile
@@ -3,7 +3,7 @@
DISTVERSION?= 12.11
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 0
+PORTREVISION?= 1
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql13-server/Makefile b/databases/postgresql13-server/Makefile
index 7eba72fbee28..d818559b2cfd 100644
--- a/databases/postgresql13-server/Makefile
+++ b/databases/postgresql13-server/Makefile
@@ -3,7 +3,7 @@
DISTVERSION?= 13.7
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 0
+PORTREVISION?= 1
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql14-server/Makefile b/databases/postgresql14-server/Makefile
index 9e8c55ebe165..edf39b2192a3 100644
--- a/databases/postgresql14-server/Makefile
+++ b/databases/postgresql14-server/Makefile
@@ -3,7 +3,7 @@
DISTVERSION?= 14.3
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 0
+PORTREVISION?= 1
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql15-server/Makefile b/databases/postgresql15-server/Makefile
index 176d1b229192..e37133fdaaa6 100644
--- a/databases/postgresql15-server/Makefile
+++ b/databases/postgresql15-server/Makefile
@@ -4,7 +4,7 @@ PORTNAME?= postgresql
DISTVERSION?= 15beta1
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= databases
MASTER_SITES= PGSQL/source/v${DISTVERSION}
PKGNAMESUFFIX?= ${PORTVERSION:R}${COMPONENT}
@@ -176,7 +176,8 @@ PLIST_SUB+= PG_VERSION=${PORTVERSION:R} \
PG_USER_regex=[[:<:]]${PG_USER}[[:>:]] \
PG_GROUP=${PG_GROUP} \
PG_GROUP_regex=[[:<:]]${PG_GROUP}[[:>:]]
-SUB_LIST+= PG_GROUP=${PG_GROUP} \
+SUB_LIST+= PG_VERSION=${PORTVERSION:R} \
+ PG_GROUP=${PG_GROUP} \
PG_USER=${PG_USER} \
PG_UID=${PG_UID}
diff --git a/databases/postgresql15-server/files/postgresql.in b/databases/postgresql15-server/files/postgresql.in
index 06673e8e4e63..444ab22e89da 100644
--- a/databases/postgresql15-server/files/postgresql.in
+++ b/databases/postgresql15-server/files/postgresql.in
@@ -8,7 +8,7 @@
#
# postgresql_enable="YES"
# # optional
-# postgresql_data="/var/db/%%PG_USER%%/data14"
+# postgresql_data="/var/db/%%PG_USER%%/data%%PG_VERSION%%"
# postgresql_flags="-w -s -m fast"
# postgresql_initdb_flags="--encoding=utf-8 --lc-collate=C"
# postgresql_login_class="default"
@@ -32,7 +32,7 @@ load_rc_config postgresql
postgresql_enable=${postgresql_enable:-"NO"}
postgresql_flags=${postgresql_flags:-"-w -s -m fast"}
postgresql_user=${postgresql_user:-"%%PG_USER%%"}
-eval postgresql_data=${postgresql_data:-"~${postgresql_user}/data14"}
+eval postgresql_data=${postgresql_data:-"~${postgresql_user}/data%%PG_VERSION%%"}
postgresql_login_class=${postgresql_login_class:-"default"}
postgresql_initdb_flags=${postgresql_initdb_flags:-"--encoding=utf-8 --lc-collate=C"}
diff --git a/databases/postgresql15-server/pkg-plist-server b/databases/postgresql15-server/pkg-plist-server
index 0e69f688951b..efe8711dce6e 100644
--- a/databases/postgresql15-server/pkg-plist-server
+++ b/databases/postgresql15-server/pkg-plist-server
@@ -46,6 +46,9 @@ lib/postgresql/utf8_and_sjis.so
lib/postgresql/utf8_and_sjis2004.so
lib/postgresql/utf8_and_uhc.so
lib/postgresql/utf8_and_win.so
+%%LLVM%%%%GSSAPI%%lib/postgresql/bitcode/postgres/libpq/be-gssapi-common.bc
+%%LLVM%%%%GSSAPI%%lib/postgresql/bitcode/postgres/libpq/be-secure-gssapi.bc
+%%LLVM%%%%SSL%%lib/postgresql/bitcode/postgres/libpq/be-secure-openssl.bc
%%LLVM%%lib/postgresql/bitcode/postgres.index.bc
%%LLVM%%lib/postgresql/bitcode/postgres/access/brin/brin.bc
%%LLVM%%lib/postgresql/bitcode/postgres/access/brin/brin_bloom.bc
@@ -190,7 +193,10 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xlogarchive.bc
%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xlogfuncs.bc
%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xloginsert.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xlogprefetcher.bc
%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xlogreader.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xlogrecovery.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xlogstats.bc
%%LLVM%%lib/postgresql/bitcode/postgres/access/transam/xlogutils.bc
%%LLVM%%lib/postgresql/bitcode/postgres/bootstrap/bootparse.bc
%%LLVM%%lib/postgresql/bitcode/postgres/bootstrap/bootstrap.bc
@@ -205,7 +211,9 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/objectaddress.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/partition.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_aggregate.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_attrdef.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_cast.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_class.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_collation.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_constraint.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_conversion.bc
@@ -216,6 +224,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_largeobject.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_namespace.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_operator.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_parameter_acl.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_proc.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_publication.bc
%%LLVM%%lib/postgresql/bitcode/postgres/catalog/pg_range.bc
@@ -270,6 +279,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/commands/typecmds.bc
%%LLVM%%lib/postgresql/bitcode/postgres/commands/user.bc
%%LLVM%%lib/postgresql/bitcode/postgres/commands/vacuum.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/commands/vacuumparallel.bc
%%LLVM%%lib/postgresql/bitcode/postgres/commands/variable.bc
%%LLVM%%lib/postgresql/bitcode/postgres/commands/view.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/execAmi.bc
@@ -312,6 +322,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeLimit.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeLockRows.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeMaterial.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeMemoize.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeMergeAppend.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeMergejoin.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeModifyTable.bc
@@ -320,7 +331,6 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeProjectSet.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeRecursiveunion.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeResult.bc
-%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeMemoize.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeSamplescan.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeSeqscan.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeSetOp.bc
@@ -349,14 +359,12 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/lib/knapsack.bc
%%LLVM%%lib/postgresql/bitcode/postgres/lib/pairingheap.bc
%%LLVM%%lib/postgresql/bitcode/postgres/lib/rbtree.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/libpq/auth-sasl.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/auth-scram.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/auth.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/be-fsstubs.bc
-%%LLVM%%%%GSSAPI%%lib/postgresql/bitcode/postgres/libpq/be-gssapi-common.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/be-secure-common.bc
-%%LLVM%%%%GSSAPI%%lib/postgresql/bitcode/postgres/libpq/be-secure-gssapi.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/be-secure.bc
-%%LLVM%%%%SSL%%lib/postgresql/bitcode/postgres/libpq/be-secure-openssl.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/crypt.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/hba.bc
%%LLVM%%lib/postgresql/bitcode/postgres/libpq/ifaddr.bc
@@ -441,6 +449,8 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_enr.bc
%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_expr.bc
%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_func.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_jsontable.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_merge.bc
%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_node.bc
%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_oper.bc
%%LLVM%%lib/postgresql/bitcode/postgres/parser/parse_param.bc
@@ -458,6 +468,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/port/pg_sema.bc
%%LLVM%%lib/postgresql/bitcode/postgres/port/pg_shmem.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/autovacuum.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/auxprocess.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/bgworker.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/bgwriter.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/checkpointer.bc
@@ -465,6 +476,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/interrupt.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/pgarch.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/postmaster.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/shell_archive.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/startup.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/syslogger.bc
%%LLVM%%lib/postgresql/bitcode/postgres/postmaster/walwriter.bc
@@ -476,6 +488,15 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/regex/regprefix.bc
%%LLVM%%lib/postgresql/bitcode/postgres/replication/backup_manifest.bc
%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_copy.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_gzip.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_lz4.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_progress.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_server.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_sink.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_target.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_throttle.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/replication/basebackup_zstd.bc
%%LLVM%%lib/postgresql/bitcode/postgres/replication/logical/decode.bc
%%LLVM%%lib/postgresql/bitcode/postgres/replication/logical/launcher.bc
%%LLVM%%lib/postgresql/bitcode/postgres/replication/logical/logical.bc
@@ -515,6 +536,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/storage/file/buffile.bc
%%LLVM%%lib/postgresql/bitcode/postgres/storage/file/copydir.bc
%%LLVM%%lib/postgresql/bitcode/postgres/storage/file/fd.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/storage/file/fileset.bc
%%LLVM%%lib/postgresql/bitcode/postgres/storage/file/reinit.bc
%%LLVM%%lib/postgresql/bitcode/postgres/storage/file/sharedfileset.bc
%%LLVM%%lib/postgresql/bitcode/postgres/storage/freespace/freespace.bc
@@ -577,6 +599,19 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/tsearch/wparser_def.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/backend_progress.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/backend_status.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_archiver.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_bgwriter.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_checkpointer.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_database.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_function.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_relation.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_replslot.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_shmem.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_slru.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_subscription.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_wal.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/pgstat_xact.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/activity/wait_event.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/acl.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/amutils.bc
@@ -608,6 +643,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/geo_ops.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/geo_selfuncs.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/geo_spgist.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/hbafuncs.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/inet_cidr_ntop.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/inet_net_pton.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/adt/int.bc
@@ -698,7 +734,9 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/utils/cache/ts_cache.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/cache/typcache.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/error/assert.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/error/csvlog.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/error/elog.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/utils/error/jsonlog.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/fmgr/dfmgr.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/fmgr/fmgr.bc
%%LLVM%%lib/postgresql/bitcode/postgres/utils/fmgr/funcapi.bc
@@ -767,6 +805,7 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/cs/LC_MESSAGES/pg_resetwal-%%PG_VERSION%%.mo
%%NLS%%share/locale/cs/LC_MESSAGES/pg_rewind-%%PG_VERSION%%.mo
%%NLS%%share/locale/cs/LC_MESSAGES/pg_test_fsync-%%PG_VERSION%%.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/pg_test_timing-%%PG_VERSION%%.mo
%%NLS%%share/locale/cs/LC_MESSAGES/pg_upgrade-%%PG_VERSION%%.mo
%%NLS%%share/locale/cs/LC_MESSAGES/pg_waldump-%%PG_VERSION%%.mo
%%NLS%%share/locale/cs/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
@@ -823,8 +862,16 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/fr/LC_MESSAGES/pg_waldump-%%PG_VERSION%%.mo
%%NLS%%share/locale/fr/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%NLS%%share/locale/fr/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
+%%NLS%%share/locale/he/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
+%%NLS%%share/locale/he/LC_MESSAGES/pg_basebackup-%%PG_VERSION%%.mo
+%%NLS%%share/locale/he/LC_MESSAGES/pg_ctl-%%PG_VERSION%%.mo
+%%NLS%%share/locale/id/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
+%%NLS%%share/locale/it/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pg_basebackup-%%PG_VERSION%%.mo
%%NLS%%share/locale/it/LC_MESSAGES/pg_controldata-%%PG_VERSION%%.mo
%%NLS%%share/locale/it/LC_MESSAGES/pg_ctl-%%PG_VERSION%%.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pg_resetwal-%%PG_VERSION%%.mo
+%%NLS%%share/locale/it/LC_MESSAGES/pg_rewind-%%PG_VERSION%%.mo
%%NLS%%share/locale/it/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%NLS%%share/locale/it/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
%%NLS%%share/locale/ja/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
@@ -848,14 +895,33 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/ko/LC_MESSAGES/pg_controldata-%%PG_VERSION%%.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pg_ctl-%%PG_VERSION%%.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pg_resetwal-%%PG_VERSION%%.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/pg_rewind-%%PG_VERSION%%.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pg_test_fsync-%%PG_VERSION%%.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/pg_test_timing-%%PG_VERSION%%.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pg_upgrade-%%PG_VERSION%%.mo
%%NLS%%share/locale/ko/LC_MESSAGES/pg_waldump-%%PG_VERSION%%.mo
%%NLS%%share/locale/ko/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%NLS%%share/locale/ko/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pg_archivecleanup-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pg_basebackup-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pg_controldata-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pg_ctl-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pg_resetwal-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pg_rewind-%%PG_VERSION%%.mo
%%NLS%%share/locale/pl/LC_MESSAGES/pg_test_fsync-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/pg_test_timing-%%PG_VERSION%%.mo
%%NLS%%share/locale/pl/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_basebackup-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_controldata-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_ctl-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_resetwal-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/pg_rewind-%%PG_VERSION%%.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%NLS%%share/locale/ru/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
%%NLS%%share/locale/ru/LC_MESSAGES/pg_archivecleanup-%%PG_VERSION%%.mo
%%NLS%%share/locale/ru/LC_MESSAGES/pg_basebackup-%%PG_VERSION%%.mo
@@ -891,10 +957,13 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/tr/LC_MESSAGES/pg_controldata-%%PG_VERSION%%.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pg_ctl-%%PG_VERSION%%.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pg_resetwal-%%PG_VERSION%%.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/pg_rewind-%%PG_VERSION%%.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pg_test_fsync-%%PG_VERSION%%.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/pg_test_timing-%%PG_VERSION%%.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pg_upgrade-%%PG_VERSION%%.mo
%%NLS%%share/locale/tr/LC_MESSAGES/pg_waldump-%%PG_VERSION%%.mo
%%NLS%%share/locale/tr/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
%%NLS%%share/locale/uk/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
%%NLS%%share/locale/uk/LC_MESSAGES/pg_archivecleanup-%%PG_VERSION%%.mo
%%NLS%%share/locale/uk/LC_MESSAGES/pg_basebackup-%%PG_VERSION%%.mo
@@ -909,7 +978,13 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/uk/LC_MESSAGES/pg_waldump-%%PG_VERSION%%.mo
%%NLS%%share/locale/uk/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%NLS%%share/locale/uk/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pg_archivecleanup-%%PG_VERSION%%.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pg_basebackup-%%PG_VERSION%%.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pg_controldata-%%PG_VERSION%%.mo
%%NLS%%share/locale/vi/LC_MESSAGES/pg_test_fsync-%%PG_VERSION%%.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pg_test_timing-%%PG_VERSION%%.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/pg_waldump-%%PG_VERSION%%.mo
%%NLS%%share/locale/vi/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/initdb-%%PG_VERSION%%.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/pg_archivecleanup-%%PG_VERSION%%.mo
@@ -925,6 +1000,7 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/zh_CN/LC_MESSAGES/pg_waldump-%%PG_VERSION%%.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/postgres-%%PG_VERSION%%.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/plpgsql-%%PG_VERSION%%.mo
%%TZDATA%%%%DATADIR%%/timezone/Africa/Abidjan
%%TZDATA%%%%DATADIR%%/timezone/Africa/Accra
%%TZDATA%%%%DATADIR%%/timezone/Africa/Addis_Ababa