aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-10 23:00:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-10 23:00:42 +0000
commit9297c97c51e8e1d7b88c2b5b7e349d90e39ac1fd (patch)
treed051a98a451ba14db83c3af72d4a1d4c8fc3c382
parentee199424cf06a713e860c71110cc3371f8be5aeb (diff)
downloadports-9297c97c51e8e1d7b88c2b5b7e349d90e39ac1fd.tar.gz
ports-9297c97c51e8e1d7b88c2b5b7e349d90e39ac1fd.zip
Converts a CGI query into structured data using a dotted name convention
similar to TT2. expand_cgi works with CGI.pm, Apache::Request or anything with an appropriate "param" method. Or you can use expand_hash directly. If you prefer to use a different flattening convention then CGI::Expand can be subclassed. WWW: http://search.cpan.org/dist/CGI-Expand PR: ports/107780 Submitted by: Fernan Aguero <fernan at iib.unsam.edu.ar>
Notes
Notes: svn path=/head/; revision=182032
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Expand/Makefile32
-rw-r--r--www/p5-CGI-Expand/distinfo3
-rw-r--r--www/p5-CGI-Expand/pkg-descr10
-rw-r--r--www/p5-CGI-Expand/pkg-plist6
5 files changed, 52 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index be0319332eaf..b0b4b9ed4294 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -519,6 +519,7 @@
SUBDIR += p5-CGI-Cache
SUBDIR += p5-CGI-Cookie-Splitter
SUBDIR += p5-CGI-Ex
+ SUBDIR += p5-CGI-Expand
SUBDIR += p5-CGI-FastTemplate
SUBDIR += p5-CGI-FormBuilder
SUBDIR += p5-CGI-Framework
diff --git a/www/p5-CGI-Expand/Makefile b/www/p5-CGI-Expand/Makefile
new file mode 100644
index 000000000000..a262f0ccc566
--- /dev/null
+++ b/www/p5-CGI-Expand/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: www/p5-CGI-Expand
+# Date created: 28 Dec 2006
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Expand
+PORTVERSION= 2.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Convert flat hash to nested data using TT2's dot convention
+
+BUILD_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Expand.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500801
+
+IGNORE= requires Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-CGI-Expand/distinfo b/www/p5-CGI-Expand/distinfo
new file mode 100644
index 000000000000..f1fc3f7c14b6
--- /dev/null
+++ b/www/p5-CGI-Expand/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Expand-2.02.tar.gz) = 9eb20cf962df24056687b2152bdc5b70
+SHA256 (CGI-Expand-2.02.tar.gz) = 799d81cae2a8813a2d53cb1155ba0ce267149d3b70f55e44cbdb6a22add84ede
+SIZE (CGI-Expand-2.02.tar.gz) = 8634
diff --git a/www/p5-CGI-Expand/pkg-descr b/www/p5-CGI-Expand/pkg-descr
new file mode 100644
index 000000000000..12f8471ab4c5
--- /dev/null
+++ b/www/p5-CGI-Expand/pkg-descr
@@ -0,0 +1,10 @@
+Converts a CGI query into structured data using a dotted name convention
+similar to TT2.
+
+expand_cgi works with CGI.pm, Apache::Request or anything with an appropriate
+"param" method. Or you can use expand_hash directly.
+
+If you prefer to use a different flattening convention then CGI::Expand can
+be subclassed.
+
+WWW: http://search.cpan.org/dist/CGI-Expand
diff --git a/www/p5-CGI-Expand/pkg-plist b/www/p5-CGI-Expand/pkg-plist
new file mode 100644
index 000000000000..4cc0c4daa9fb
--- /dev/null
+++ b/www/p5-CGI-Expand/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Expand/.packlist
+%%SITE_PERL%%/CGI/Expand.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Expand
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/CGI
+@dirrmtry %%SITE_PERL%%/CGI