aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-06-08 00:58:26 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-06-08 00:58:26 +0000
commit92a9331f7818730d3cbc502cc39a7890cd7ff3bc (patch)
tree6a4d78795ab904bcc51b3942e6ac478fb7aa3766
parente0776945fd6a164ae242bfe211276748999f5e6a (diff)
downloadports-92a9331f7818730d3cbc502cc39a7890cd7ff3bc.tar.gz
ports-92a9331f7818730d3cbc502cc39a7890cd7ff3bc.zip
graphics/openpgl: sort out Makefile, pet portclippy, allow build on i386
PR: 279498 Approved by: Shane <FreeBSD@ShaneWare.Biz> (maintaner)
-rw-r--r--graphics/openpgl/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/openpgl/Makefile b/graphics/openpgl/Makefile
index cedc56146600..037dc251b236 100644
--- a/graphics/openpgl/Makefile
+++ b/graphics/openpgl/Makefile
@@ -1,7 +1,7 @@
PORTNAME= openpgl
DISTVERSIONPREFIX= v
DISTVERSION= 0.5.0
-PORTREVISION= 3
+PORTREVISION= 4
#DISTVERSIONSUFFIX= -beta
CATEGORIES= graphics devel
@@ -13,18 +13,17 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
# supported processors -
-# arm with NEON/NEON2X and x86_64 with SSE4/AVX2/AVX512
-ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7
+# arm with NEON/NEON2X and x86_64/x86 with SSE/AVX/AVX2/AVX512
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
ONLY_FOR_ARCHS_REASON= requires supported SIMD ISA
LIB_DEPENDS= libembree3.so:graphics/embree \
libtbb.so:devel/onetbb
USES= cmake compiler:c++11-lib
-USE_LDCONFIG= yes
-
USE_GITHUB= yes
GH_ACCOUNT= OpenPathGuidingLibrary
+USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"