aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2022-02-12 16:24:59 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-02-12 16:35:56 +0000
commit92ba87a661c409b4167d37efc38a1588c81efa41 (patch)
tree3cdeb77dd2eb9bcb72d4720a01de325c44a0090c
parent974b9f8336547aab4776f8792501bc033f4b7066 (diff)
downloadports-92ba87a661c409b4167d37efc38a1588c81efa41.tar.gz
ports-92ba87a661c409b4167d37efc38a1588c81efa41.zip
math/py-cdecimal: deprecate and mark BROKEN with Python 3.9
Note: upstream does not support it after Python-3.2, and a fast C implementation of the decimal module (_decimal) is bundled with Python. PR: 261870
-rw-r--r--math/py-cdecimal/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/math/py-cdecimal/Makefile b/math/py-cdecimal/Makefile
index 7ce6f0093577..d2481f7e89bd 100644
--- a/math/py-cdecimal/Makefile
+++ b/math/py-cdecimal/Makefile
@@ -13,10 +13,19 @@ COMMENT= Fast drop-in replacement for the Decimal module
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+DEPRECATED= upstream does not support it after Python-3.2
+
USES= python:3.6-3.8
USE_PYTHON= distutils autoplist
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} == 3.9
+# Note: a fast C implementation of the decimal module (_decimal) is bundled with Python
+BROKEN= no member named 'tp_print' in 'struct _typeobject'
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/cdecimal*.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>