aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2022-08-06 10:49:50 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2022-08-06 10:49:50 +0000
commit92c171f2bc1eefb871102bf70e6b860b4806596f (patch)
treeb69697543d012941ee58fac1f263342ab785e4ce
parentf4be8324d5cdf48f5ff1d01ec623aa8aa733f1e5 (diff)
downloadports-92c171f2bc1eefb871102bf70e6b860b4806596f.tar.gz
ports-92c171f2bc1eefb871102bf70e6b860b4806596f.zip
[NEW] net/py-cepa: Python controller library for Tor
Cepa (short for allium cepa) is a fork of stem that adds support for v3 onion client authentication. With it you can use Tor's control protocol to script against the Tor process, or build things such as Nyx. WWW: https://github.com/onionshare/cepa Sponsored by: TorBSD Diversity Project, TDP Sponsored by: The Tor Project
-rw-r--r--net/Makefile1
-rw-r--r--net/py-cepa/Makefile34
-rw-r--r--net/py-cepa/distinfo3
-rw-r--r--net/py-cepa/pkg-descr7
4 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 8ad763b67768..a081af47e3f6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1026,6 +1026,7 @@
SUBDIR += py-amqp
SUBDIR += py-amqplib
SUBDIR += py-avahi
+ SUBDIR += py-cepa
SUBDIR += py-cjdns
SUBDIR += py-cloudflare-scrape
SUBDIR += py-cloudflare-scrape-js2py
diff --git a/net/py-cepa/Makefile b/net/py-cepa/Makefile
new file mode 100644
index 000000000000..7eed325fc7d5
--- /dev/null
+++ b/net/py-cepa/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= cepa
+PORTVERSION= 1.8.3
+CATEGORIES= net security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Python controller library for Tor, with v3 onion client auth support
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR}\
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>0:security/py-pycryptodome@${PY_FLAVOR}
+
+TEST_DEPENDS= tor:security/tor \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyflakes>0:devel/py-pyflakes@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycodestyle>0:devel/py-pycodestyle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tox>0:devel/py-tox@${PY_FLAVOR}
+
+USES= python:3.6+ shebangfix
+USE_PYTHON= distutils autoplist concurrent
+NO_ARCH= yes
+
+SHEBANG_FILES= *.py
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}stem-*
+
+do-test:
+ @cd ${WRKSRC} \
+ && ${PYTHON_CMD} run_tests.py -a
+
+.include <bsd.port.mk>
diff --git a/net/py-cepa/distinfo b/net/py-cepa/distinfo
new file mode 100644
index 000000000000..4790cb496f68
--- /dev/null
+++ b/net/py-cepa/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646239491
+SHA256 (cepa-1.8.3.tar.gz) = 1dc6f0b324d37a2ed2ca274648ece8fd2c96a1d2f440f58c0ca17afd4b5ede7a
+SIZE (cepa-1.8.3.tar.gz) = 2858826
diff --git a/net/py-cepa/pkg-descr b/net/py-cepa/pkg-descr
new file mode 100644
index 000000000000..4df02f739228
--- /dev/null
+++ b/net/py-cepa/pkg-descr
@@ -0,0 +1,7 @@
+Cepa (short for allium cepa) is a fork of stem that adds support for v3 onion
+client authentication. Stem is a Python controller library for Tor.
+
+With it you can use Tor's control protocol to script against the Tor process,
+or build things such as Nyx.
+
+WWW: https://github.com/onionshare/cepa