aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-04-27 07:20:11 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-04-28 05:58:56 +0000
commit930715f767ccfb6375ee7c56f7ba3134541593de (patch)
tree274368a4cb98aaf226aec68f33b8efc51c5a76f3
parent4903f7826afa04dcbd2c5a96d0050a8389f2fa09 (diff)
downloadports-930715f767ccfb6375ee7c56f7ba3134541593de.tar.gz
ports-930715f767ccfb6375ee7c56f7ba3134541593de.zip
editors/rehex: update to 0.5.0
ChangeLog: https://github.com/solemnwarning/rehex/releases/tag/0.5.0 Submitter requests maintainership. Already maintainer of several ports. PR: 263562 Reported by: fuz@fuz.su (maintainer)
-rw-r--r--editors/rehex/Makefile18
-rw-r--r--editors/rehex/distinfo6
-rw-r--r--editors/rehex/files/patch-Makefile32
-rw-r--r--editors/rehex/files/patch-plugins_binary-template_Makefile11
-rw-r--r--editors/rehex/pkg-plist13
5 files changed, 58 insertions, 22 deletions
diff --git a/editors/rehex/Makefile b/editors/rehex/Makefile
index 6726ae7b1dd4..3ecdb18f8f95 100644
--- a/editors/rehex/Makefile
+++ b/editors/rehex/Makefile
@@ -1,23 +1,31 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= rehex
-PORTVERSION= 0.4.1
+DISTVERSION= 0.5.0
CATEGORIES= editors
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= fuz@fuz.su
COMMENT= Hex editor for reverse engineering
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= p5-Template-Toolkit>0:www/p5-Template-Toolkit \
+ zip:archivers/zip
LIB_DEPENDS= libcapstone.so:devel/capstone4 \
+ libharfbuzz.so:print/harfbuzz \
+ libiconv.so:converters/libiconv \
libjansson.so:devel/jansson \
libunistring.so:devel/libunistring
-USES= compiler:c++11-lang gmake gnome lua:53 pkgconfig
-USE_WX= 3.0+
-MAKE_ENV= LUA_PKG="lua-${LUA_VER}" LUA="${LUA_CMD}"
+USES= compiler:c++11-lang gmake gnome lua:53 perl5 pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= solemnwarning
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
+USE_PERL5= build
+USE_WX= 3.0+
+MAKE_ENV= LUA_PKG="lua-${LUA_VER}" LUA="${LUA_CMD}" STRIP="${STRIP}"
+TEST_TARGET= check
PORTDOCS= CHANGES.txt
diff --git a/editors/rehex/distinfo b/editors/rehex/distinfo
index 3d75ac9b9231..54dfa451bed0 100644
--- a/editors/rehex/distinfo
+++ b/editors/rehex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1642090465
-SHA256 (solemnwarning-rehex-0.4.1_GH0.tar.gz) = 88a8ec41147a5ed5c542d40496b7231fb42ebfd1783c4498202fca5a1ddaae8f
-SIZE (solemnwarning-rehex-0.4.1_GH0.tar.gz) = 3347164
+TIMESTAMP = 1650880974
+SHA256 (solemnwarning-rehex-0.5.0_GH0.tar.gz) = f6737e44d98da9a81ba0217da56fc0b4d36338204ab5f076b77af536a4b35981
+SIZE (solemnwarning-rehex-0.5.0_GH0.tar.gz) = 3905886
diff --git a/editors/rehex/files/patch-Makefile b/editors/rehex/files/patch-Makefile
index 91c4fea5fd06..2f8727d454e7 100644
--- a/editors/rehex/files/patch-Makefile
+++ b/editors/rehex/files/patch-Makefile
@@ -1,27 +1,31 @@
---- Makefile.orig 2021-05-03 12:57:27 UTC
+--- Makefile.orig 2022-04-23 13:09:38 UTC
+++ Makefile
-@@ -388,18 +388,20 @@ PLUGINS_INSTALL := \
+@@ -503,17 +503,21 @@ PLUGINS := \
.PHONY: install
- install: $(EXE)
+ install: $(EXE) help/rehex.htb
- install -D -m 0755 $(EXE) $(DESTDIR)$(bindir)/$(EXE)
-+ $(BSD_INSTALL_PROGRAM) $(EXE) $(DESTDIR)$(bindir)/$(EXE)
++ install -m 0755 $(STRIP) $(EXE) $(DESTDIR)$(bindir)/$(EXE)
for s in 16 32 48 64 128 256 512; \
do \
- install -D -m 0644 res/icon$${s}.png $(DESTDIR)$(datarootdir)/icons/hicolor/$${s}x$${s}/apps/rehex.png; \
+ mkdir -p $(DESTDIR)$(datarootdir)/icons/hicolor/$${s}x$${s}/apps; \
-+ $(BSD_INSTALL_DATA) res/icon$${s}.png $(DESTDIR)$(datarootdir)/icons/hicolor/$${s}x$${s}/apps/rehex.png; \
++ install -m 0644 res/icon$${s}.png $(DESTDIR)$(datarootdir)/icons/hicolor/$${s}x$${s}/apps/rehex.png; \
done
-
+-
- install -D -m 0644 res/rehex.desktop $(DESTDIR)$(datarootdir)/applications/rehex.desktop
-+ $(BSD_INSTALL_DATA) res/rehex.desktop $(DESTDIR)$(datarootdir)/applications/rehex.desktop
-
+-
+- install -D -m 0644 help/rehex.htb $(DESTDIR)$(datadir)/rehex/rehex.htb
+-
++
++ mkdir -p $(DESTDIR)$(datarootdir)/applications
++ install -m 0644 res/rehex.desktop $(DESTDIR)$(datarootdir)/applications/rehex.desktop
++
++ mkdir -p $(DESTDIR)$(datadir)/rehex
++ install -m 0644 help/rehex.htb $(DESTDIR)$(datadir)/rehex/rehex.htb
++
+ mkdir -p $(DESTDIR)$(libdir)/rehex/exe
- for f in $(PLUGINS_INSTALL); \
+ for p in $(PLUGINS); \
do \
-- install -D -m 0644 plugins/$${f} $(DESTDIR)$(libdir)/rehex/$${f}; \
-+ $(BSD_INSTALL_DATA) plugins/$${f} $(DESTDIR)$(libdir)/rehex/$${f}; \
- done
-
- .PHONY: uninstall
+ $(MAKE) -C plugins/$${p} install || exit $$?; \
diff --git a/editors/rehex/files/patch-plugins_binary-template_Makefile b/editors/rehex/files/patch-plugins_binary-template_Makefile
new file mode 100644
index 000000000000..8ab71562080e
--- /dev/null
+++ b/editors/rehex/files/patch-plugins_binary-template_Makefile
@@ -0,0 +1,11 @@
+--- plugins/binary-template/Makefile.orig 2022-04-25 10:32:52 UTC
++++ plugins/binary-template/Makefile
+@@ -49,7 +49,7 @@ ifeq ($(BUSTED),)
+ endif
+
+ ifeq ($(BUSTED),)
+- X := $(error Neither busted or busted.bat found in PATH)
++ BUSTED := @echo busted not found in PATH, skipping checks ; true
+ endif
+ endif
+
diff --git a/editors/rehex/pkg-plist b/editors/rehex/pkg-plist
index 86e612384b8d..6d03734ca597 100644
--- a/editors/rehex/pkg-plist
+++ b/editors/rehex/pkg-plist
@@ -1,4 +1,16 @@
bin/rehex
+lib/rehex/binary-template/executor.lua
+lib/rehex/binary-template/executor/arrayvalue.lua
+lib/rehex/binary-template/executor/filearrayvalue.lua
+lib/rehex/binary-template/executor/filevalue.lua
+lib/rehex/binary-template/executor/immediatevalue.lua
+lib/rehex/binary-template/executor/plainvalue.lua
+lib/rehex/binary-template/executor/structvalue.lua
+lib/rehex/binary-template/lulpeg/lulpeg.lua
+lib/rehex/binary-template/parser.lua
+lib/rehex/binary-template/plugin.lua
+lib/rehex/binary-template/preprocessor.lua
+lib/rehex/binary-template/templates/riff.bt
lib/rehex/exe/bitops52.lua
lib/rehex/exe/class.lua
lib/rehex/exe/document_stream.lua
@@ -17,3 +29,4 @@ share/icons/hicolor/32x32/apps/rehex.png
share/icons/hicolor/48x48/apps/rehex.png
share/icons/hicolor/512x512/apps/rehex.png
share/icons/hicolor/64x64/apps/rehex.png
+%%DATADIR%%/rehex.htb