aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2021-12-10 05:19:44 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-12-10 05:19:44 +0000
commit937188af9d1a4dd7622b8aef33814345a6a9b73a (patch)
tree0da05302710222c2e69bd96979360dae6654558a
parentac510869a92cda3bd6a2f25492deb5d52a281b43 (diff)
downloadports-937188af9d1a4dd7622b8aef33814345a6a9b73a.tar.gz
ports-937188af9d1a4dd7622b8aef33814345a6a9b73a.zip
devel/R-cran-lintr: New port: A 'Linter' for R Code
-rw-r--r--devel/Makefile1
-rw-r--r--devel/R-cran-lintr/Makefile31
-rw-r--r--devel/R-cran-lintr/distinfo3
-rw-r--r--devel/R-cran-lintr/pkg-descr5
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 219accf957cc..c8f9a34475df 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -66,6 +66,7 @@
SUBDIR += R-cran-itertools
SUBDIR += R-cran-later
SUBDIR += R-cran-lifecycle
+ SUBDIR += R-cran-lintr
SUBDIR += R-cran-listenv
SUBDIR += R-cran-lubridate
SUBDIR += R-cran-magrittr
diff --git a/devel/R-cran-lintr/Makefile b/devel/R-cran-lintr/Makefile
new file mode 100644
index 000000000000..4c9c265f00ce
--- /dev/null
+++ b/devel/R-cran-lintr/Makefile
@@ -0,0 +1,31 @@
+# Created by: Guangyuan Yang <ygy@FreeBSD.org>
+
+PORTNAME= lintr
+DISTVERSION= 2.0.1
+CATEGORIES= devel
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= ygy@FreeBSD.org
+COMMENT= A 'Linter' for R Code
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= R-cran-knitr>0:print/R-cran-knitr
+RUN_DEPENDS= R-cran-jsonlite>0:converters/R-cran-jsonlite \
+ R-cran-crayon>0:devel/R-cran-crayon \
+ R-cran-cyclocomp>0:devel/R-cran-cyclocomp \
+ R-cran-rstudioapi>=0.2:devel/R-cran-rstudioapi \
+ R-cran-testthat>=2.2.1:devel/R-cran-testthat \
+ R-cran-knitr>0:print/R-cran-knitr \
+ R-cran-digest>0:security/R-cran-digest \
+ R-cran-rex>0:textproc/R-cran-rex \
+ R-cran-xml2>=1.0.0:textproc/R-cran-xml2 \
+ R-cran-xmlparsedata>=1.0.3:textproc/R-cran-xmlparsedata \
+ R-cran-httr>=1.2.1:www/R-cran-httr
+TEST_DEPENDS= R-cran-mockery>0:devel/R-cran-mockery \
+ R-cran-rmarkdown>0:textproc/R-cran-rmarkdown
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/devel/R-cran-lintr/distinfo b/devel/R-cran-lintr/distinfo
new file mode 100644
index 000000000000..e6dc41aedf02
--- /dev/null
+++ b/devel/R-cran-lintr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1639112705
+SHA256 (lintr_2.0.1.tar.gz) = fe0723757b653ef83ec7a5005d0a7524cd917d646d35a5627ee639158881ce93
+SIZE (lintr_2.0.1.tar.gz) = 219142
diff --git a/devel/R-cran-lintr/pkg-descr b/devel/R-cran-lintr/pkg-descr
new file mode 100644
index 000000000000..f870f03f6705
--- /dev/null
+++ b/devel/R-cran-lintr/pkg-descr
@@ -0,0 +1,5 @@
+Checks adherence to a given style, syntax errors and possible semantic issues.
+Supports on the fly checking of R code edited with 'RStudio IDE', 'Emacs',
+'Vim', 'Sublime Text' and 'Atom'.
+
+WWW: https://github.com/jimhester/lintr