aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-12-17 08:11:42 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-12-17 19:04:30 +0000
commit939a3a8b0788e5a9e79855e5cf8ca100fd5c59fa (patch)
tree99e9fa109503bf1b1d0abf70fea6006bb3647fc1
parentb9a34290c5ce02678b4cd0868cb53799e72e7458 (diff)
downloadports-939a3a8b0788e5a9e79855e5cf8ca100fd5c59fa.tar.gz
ports-939a3a8b0788e5a9e79855e5cf8ca100fd5c59fa.zip
textproc/libebml: Update to 1.4.5
-rw-r--r--textproc/libebml/Makefile10
-rw-r--r--textproc/libebml/distinfo6
-rw-r--r--textproc/libebml/files/patch-src_EbmlUnicodeString.cpp11
3 files changed, 21 insertions, 6 deletions
diff --git a/textproc/libebml/Makefile b/textproc/libebml/Makefile
index d0969f4d8d48..b6d3aa45688c 100644
--- a/textproc/libebml/Makefile
+++ b/textproc/libebml/Makefile
@@ -1,7 +1,7 @@
PORTNAME= libebml
-DISTVERSION= 1.4.4
+DISTVERSION= 1.4.5
CATEGORIES= textproc
-MASTER_SITES= https://dl.matroska.org/downloads/libebml/
+MASTER_SITES= https://dl.matroska.org/downloads/${PORTNAME}/
MAINTAINER= multimedia@FreeBSD.org
COMMENT= EBML (Extensible Binary Meta Language), sort of binary version of XML
@@ -10,10 +10,14 @@ WWW= https://www.matroska.org/
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE.LGPL
-USES= cmake compiler:c++11-lang cpe tar:xz
+BUILD_DEPENDS= ${LOCALBASE}/include/utf8cpp/utf8/checked.h:devel/utf8cpp
+
+USES= cmake compiler:c++14-lang cpe localbase pathfix tar:xz
USE_LDCONFIG= yes
CPE_VENDOR= matroska
+EXTRACT_AFTER_ARGS= --exclude src/lib
+
CMAKE_ARGS= -DBUILD_SHARED_LIBS=YES
.include <bsd.port.mk>
diff --git a/textproc/libebml/distinfo b/textproc/libebml/distinfo
index dd9eb416a0c9..0e9cc82ff8de 100644
--- a/textproc/libebml/distinfo
+++ b/textproc/libebml/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1665308816
-SHA256 (libebml-1.4.4.tar.xz) = 82dc5f83356cc9340aee76ed7512210b3a4edf5f346bc9c2c7044f55052687a7
-SIZE (libebml-1.4.4.tar.xz) = 64116
+TIMESTAMP = 1702779355
+SHA256 (libebml-1.4.5.tar.xz) = 4971640b0592da29c2d426f303e137a9b0b3d07e1b81d069c1e56a2f49ab221b
+SIZE (libebml-1.4.5.tar.xz) = 64408
diff --git a/textproc/libebml/files/patch-src_EbmlUnicodeString.cpp b/textproc/libebml/files/patch-src_EbmlUnicodeString.cpp
new file mode 100644
index 000000000000..bcb70d7410a9
--- /dev/null
+++ b/textproc/libebml/files/patch-src_EbmlUnicodeString.cpp
@@ -0,0 +1,11 @@
+--- src/EbmlUnicodeString.cpp.orig 2023-12-17 02:35:17 UTC
++++ src/EbmlUnicodeString.cpp
+@@ -40,7 +40,7 @@
+
+ #include "ebml/EbmlUnicodeString.h"
+
+-#include "lib/utf8-cpp/source/utf8/checked.h"
++#include "utf8cpp/utf8/checked.h"
+
+ namespace libebml {
+