aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-20 18:21:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-23 17:00:39 +0000
commit939c10e291f4e8294675459d58789369d0c9fe62 (patch)
tree4b465d104292f59aff85fd46d54c670a1652f77b
parent295652858bbb0a061ec6a12cb0df3e098cec8cd4 (diff)
downloadports-939c10e291f4e8294675459d58789369d0c9fe62.tar.gz
ports-939c10e291f4e8294675459d58789369d0c9fe62.zip
games/dustrac: update to 2.1.1
-rw-r--r--games/dustrac/Makefile12
-rw-r--r--games/dustrac/distinfo6
-rw-r--r--games/dustrac/files/patch-CMakeLists.txt16
-rw-r--r--games/dustrac/files/patch-src_game_MiniCore_CMakeLists.txt11
-rw-r--r--games/dustrac/pkg-plist2
5 files changed, 12 insertions, 35 deletions
diff --git a/games/dustrac/Makefile b/games/dustrac/Makefile
index 7f316cd227fb..76e4f924e23b 100644
--- a/games/dustrac/Makefile
+++ b/games/dustrac/Makefile
@@ -1,5 +1,5 @@
PORTNAME= dustrac
-PORTVERSION= 2.0.3
+PORTVERSION= 2.1.1
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -9,16 +9,19 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu
USE_GITHUB= yes
GH_ACCOUNT= juzzlin
GH_PROJECT= DustRacing2D
+GH_TAGNAME= ae380b8 # includes crash fix
USES= compiler:c++11-lib cmake gl openal pkgconfig qt:5
USE_GL= gl glu
-USE_QT= core gui opengl xml widgets testlib \
+USE_QT= core gui opengl xml widgets testlib sql \
buildtools_build linguisttools_build qmake_build
CMAKE_ARGS= -DReleaseBuild=on \
+ -DSystemFonts=on \
-DDATA_PATH=${DATADIR} \
-DDOC_PATH=${DOCSDIR}
LDFLAGS+= -L${LOCALBASE}/lib
@@ -28,10 +31,7 @@ PORTDOCS= *
OPTIONS_DEFINE= DOCS
-STRIP_FILES= bin/dustrac-game \
- bin/dustrac-editor
-
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dustrac-*
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/dustrac-editor
.include <bsd.port.mk>
diff --git a/games/dustrac/distinfo b/games/dustrac/distinfo
index e1d1cf565458..f63562c8ce3c 100644
--- a/games/dustrac/distinfo
+++ b/games/dustrac/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1563219146
-SHA256 (juzzlin-DustRacing2D-2.0.3_GH0.tar.gz) = cbf73fc1c446d4068222c51d7fd67bd90dcce2651ba2aa2ae8aecb2dc8ee0873
-SIZE (juzzlin-DustRacing2D-2.0.3_GH0.tar.gz) = 17338605
+TIMESTAMP = 1619196464
+SHA256 (juzzlin-DustRacing2D-2.1.1-ae380b8_GH0.tar.gz) = a955ab1027fda2ca5dce55ed2c08e5a8dd8760e87a00210e810ff131bbbe2b77
+SIZE (juzzlin-DustRacing2D-2.1.1-ae380b8_GH0.tar.gz) = 17393096
diff --git a/games/dustrac/files/patch-CMakeLists.txt b/games/dustrac/files/patch-CMakeLists.txt
index dab32a028963..0a2aeb772dea 100644
--- a/games/dustrac/files/patch-CMakeLists.txt
+++ b/games/dustrac/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2019-07-09 21:02:22 UTC
+--- CMakeLists.txt.orig 2021-02-21 12:07:18 UTC
+++ CMakeLists.txt
-@@ -90,16 +90,6 @@ elseif(WIN32)
+@@ -108,15 +108,6 @@ elseif(WIN32)
endif()
if(CMAKE_COMPILER_IS_GNUCXX OR MINGW OR ${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
@@ -13,16 +13,6 @@
- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
- endif(CCACHE_FOUND)
--
+
elseif(MSVC)
add_definitions(-DNOMINMAX)
- endif()
-@@ -124,7 +114,7 @@ find_package(OpenGL REQUIRED)
- if(${CMAKE_VERSION} VERSION_LESS "3.11.0")
- set(DUSTRAC_OPENGL_LIBS ${OPENGL_gl_LIBRARY})
- else()
-- set(DUSTRAC_OPENGL_LIBS OpenGL::OpenGL)
-+ set(DUSTRAC_OPENGL_LIBS OpenGL::GL)
- endif()
-
- # OpenAL for sounds. OpenAL directory can be given by -DOPENALDIR=...
diff --git a/games/dustrac/files/patch-src_game_MiniCore_CMakeLists.txt b/games/dustrac/files/patch-src_game_MiniCore_CMakeLists.txt
deleted file mode 100644
index ef1b1fd27f2b..000000000000
--- a/games/dustrac/files/patch-src_game_MiniCore_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/game/MiniCore/CMakeLists.txt.orig 2019-07-09 21:02:22 UTC
-+++ ./src/game/MiniCore/CMakeLists.txt
-@@ -60,7 +60,7 @@ find_package(OpenGL REQUIRED)
- if(${CMAKE_VERSION} VERSION_LESS "3.11.0")
- set(MINICORE_OPENGL_LIBS ${OPENGL_gl_LIBRARY})
- else()
-- set(MINICORE_OPENGL_LIBS OpenGL::OpenGL)
-+ set(MINICORE_OPENGL_LIBS OpenGL::GL)
- endif()
-
- # Enable CMake's unit test framework
diff --git a/games/dustrac/pkg-plist b/games/dustrac/pkg-plist
index 7c045ff5619e..a3fedf3bec4e 100644
--- a/games/dustrac/pkg-plist
+++ b/games/dustrac/pkg-plist
@@ -5,5 +5,3 @@ share/applications/dustrac-game.desktop
share/icons/hicolor/64x64/apps/dustrac-editor.png
share/icons/hicolor/64x64/apps/dustrac-game.png
share/metainfo/dustrac.appdata.xml
-share/pixmaps/dustrac-editor.png
-share/pixmaps/dustrac-game.png