aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-05-06 18:49:50 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-05-06 18:49:50 +0000
commit9445cd9e3ca7a09150fc55eac5b850aa81d53e34 (patch)
tree160023c7dfa135dc68d75147d21756d562b5d96a
parent852a8ad094684bf1a77f9c6a5d8284bc1160a90c (diff)
downloadports-9445cd9e3ca7a09150fc55eac5b850aa81d53e34.tar.gz
ports-9445cd9e3ca7a09150fc55eac5b850aa81d53e34.zip
New port: graphics/photoqt -- a simple image viewer.
* Based on a version submitted by Andrew Romanenko. PR: 221482 Submitted by: Andrew Romanenko <melanhit@gmail.com> (initial version)
Notes
Notes: svn path=/head/; revision=469244
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/photoqt/Makefile37
-rw-r--r--graphics/photoqt/distinfo3
-rw-r--r--graphics/photoqt/pkg-descr4
-rw-r--r--graphics/photoqt/pkg-plist8
5 files changed, 53 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 278c8bc32a32..644b739056fd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -808,6 +808,7 @@
SUBDIR += pho
SUBDIR += photivo
SUBDIR += photopc
+ SUBDIR += photoqt
SUBDIR += phototonic
SUBDIR += php-facedetect
SUBDIR += php-gdal
diff --git a/graphics/photoqt/Makefile b/graphics/photoqt/Makefile
new file mode 100644
index 000000000000..b34a06f58a41
--- /dev/null
+++ b/graphics/photoqt/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= photoqt
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.6
+CATEGORIES= graphics
+
+MAINTAINER= melanhit@gmail.com
+COMMENT= Simple, powerful and good looking QT5 image viewer
+
+LICENSE= GPLv2
+
+USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
+ localbase:ldflags
+USE_QT5= core graphicaleffects gui multimedia network qml quick \
+ quickcontrols sql svg widgets xml \
+ buildtools_build linguisttools_build qmake_build
+
+USE_GITHUB= yes
+GH_ACCOUNT= luspi
+
+OPTIONS_DEFINE= EXIV2 RAW GM
+OPTIONS_DEFAULT=EXIV2
+
+EXIV2_CMAKE_BOOL= EXIV2
+EXIV2_DESC= Metadata editing
+EXIV2_LIB_DEPENDS= libexiv2.so:graphics/exiv2
+
+RAW_CMAKE_BOOL= RAW
+RAW_DESC= Raw image support
+RAW_LIB_DEPENDS= libraw.so:graphics/libraw
+
+GM_CMAKE_BOOL= GM
+GM_DESC= GraphicsMagick image processing
+GM_LIB_DEPENDS= libGraphicsMagick.so:graphics/GraphicsMagick
+
+.include <bsd.port.mk>
diff --git a/graphics/photoqt/distinfo b/graphics/photoqt/distinfo
new file mode 100644
index 000000000000..0fef876f655f
--- /dev/null
+++ b/graphics/photoqt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1525630998
+SHA256 (luspi-photoqt-v1.6_GH0.tar.gz) = 34f30ee07d535a227db325219a59f81e9f21a6918510e225a3e7310f6fde569d
+SIZE (luspi-photoqt-v1.6_GH0.tar.gz) = 1119296
diff --git a/graphics/photoqt/pkg-descr b/graphics/photoqt/pkg-descr
new file mode 100644
index 000000000000..5319aeb5a9ed
--- /dev/null
+++ b/graphics/photoqt/pkg-descr
@@ -0,0 +1,4 @@
+PhotoQt is a simple, yet powerful and good looking image viewer,
+written in C++/Qt
+
+WWW: http://photoqt.org/
diff --git a/graphics/photoqt/pkg-plist b/graphics/photoqt/pkg-plist
new file mode 100644
index 000000000000..aa1b7df6197c
--- /dev/null
+++ b/graphics/photoqt/pkg-plist
@@ -0,0 +1,8 @@
+bin/photoqt
+share/appdata/photoqt.appdata.xml
+share/applications/photoqt.desktop
+share/icons/hicolor/128x128/apps/photoqt.png
+share/icons/hicolor/16x16/apps/photoqt.png
+share/icons/hicolor/32x32/apps/photoqt.png
+share/icons/hicolor/48x48/apps/photoqt.png
+share/icons/hicolor/64x64/apps/photoqt.png