aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2023-10-16 08:23:03 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2023-10-16 08:23:03 +0000
commit944eff5cfa5f0fe00d44a04f891b19928a34c335 (patch)
tree9d2f26017b91d90b8a537ddf8eb81e4fbe1a2097
parentec382620f61c2798bf44c02f945f5a9d1983ad61 (diff)
downloadports-944eff5cfa5f0fe00d44a04f891b19928a34c335.tar.gz
ports-944eff5cfa5f0fe00d44a04f891b19928a34c335.zip
emulators/wine-devel: Improve configuration for ALSA and OSS
Use ALSA_CONFIGURE_WITH and OSS_CONFIGURE_WITH instead of the ALSA_CONFIGURE_ON and OSS_CONFIGURE_ON forms. This properly handles the case where neither the ALSA nor OSS option are set. It's more resilient to future changes. And shorter. PR: 273987
-rw-r--r--emulators/wine-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index ee4be09e5a89..ac8a54161728 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -80,7 +80,7 @@ WINEMAKER_DESC= Fully support winemaker (requires Perl)
GECKO_DESC= Bundle Gecko MSI package for Wine
MONO_DESC= Bundle Mono MSI package for Wine
-ALSA_CONFIGURE_ON= --with-alsa --without-oss
+ALSA_CONFIGURE_WITH= alsa
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_RUN_DEPENDS= alsa-plugins>0:audio/alsa-plugins
@@ -96,7 +96,7 @@ GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
MONO_RUN_DEPENDS= wine-mono-devel>0:emulators/wine-mono-devel
-OSS_CONFIGURE_ON= --without-alsa --with-oss
+OSS_CONFIGURE_WITH= oss
V4L_CONFIGURE_WITH= v4l2
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat