aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-07-14 10:08:24 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-07-14 10:08:24 +0000
commit946a5aef9357709b16b55e284b8088469ce46922 (patch)
treef7dabad5ab1613f31a0e0638234d217241a1f315
parent973a707c70478448af77004a07eab1f85c2f6757 (diff)
downloadports-946a5aef9357709b16b55e284b8088469ce46922.tar.gz
ports-946a5aef9357709b16b55e284b8088469ce46922.zip
ports-mgmt/fastest_pkg: Update example line
Display mirror_type: "NONE" in example line as recent versions of pkg(8) are more capable of warning. PR: 272468 Reported by: grahamperrin
-rw-r--r--ports-mgmt/fastest_pkg/Makefile1
-rw-r--r--ports-mgmt/fastest_pkg/files/patch-fastest__pkg_fastest__pkg.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/ports-mgmt/fastest_pkg/Makefile b/ports-mgmt/fastest_pkg/Makefile
index 171362ce2f65..f78add869982 100644
--- a/ports-mgmt/fastest_pkg/Makefile
+++ b/ports-mgmt/fastest_pkg/Makefile
@@ -1,6 +1,7 @@
PORTNAME= fastest_pkg
PORTVERSION= 0.2.1
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= ports-mgmt python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/ports-mgmt/fastest_pkg/files/patch-fastest__pkg_fastest__pkg.py b/ports-mgmt/fastest_pkg/files/patch-fastest__pkg_fastest__pkg.py
new file mode 100644
index 000000000000..e6d6fc705910
--- /dev/null
+++ b/ports-mgmt/fastest_pkg/files/patch-fastest__pkg_fastest__pkg.py
@@ -0,0 +1,11 @@
+--- fastest_pkg/fastest_pkg.py.orig 2022-11-11 12:59:37 UTC
++++ fastest_pkg/fastest_pkg.py
+@@ -146,7 +146,7 @@ def main():
+ print(json.dumps(stats_sorted))
+ else:
+ pkg = PkgMirror(stats_sorted[0]["mirror_name"])
+- pkg_cfg = 'FreeBSD: { url: "http://%s/${ABI}/%s" }' % (
++ pkg_cfg = 'FreeBSD: { url: "http://%s/${ABI}/%s", mirror_type: "NONE" }' % (
+ stats_sorted[0]["mirror_name"],
+ pkg.release,
+ )