aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-04 01:26:08 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-04 01:26:47 +0000
commit947dc6231b42dc4787393dcb1efd9887141f7885 (patch)
treeba8564426a0f576ee4dbe9eeba2b8915fc34cd22
parent4c064f921f345d5e28eab4d1a5828c40acf43760 (diff)
downloadports-947dc6231b42dc4787393dcb1efd9887141f7885.tar.gz
ports-947dc6231b42dc4787393dcb1efd9887141f7885.zip
audio/lsp-plugins-lv2: Update 1.2.0 -> 1.2.1
-rw-r--r--audio/lsp-plugins-lv2/Makefile6
-rw-r--r--audio/lsp-plugins-lv2/distinfo6
-rw-r--r--audio/lsp-plugins-lv2/files/patch-b2d31f757611b6fb8fc16c8a78465b11bc392526143
-rw-r--r--audio/lsp-plugins-lv2/pkg-plist8
4 files changed, 10 insertions, 153 deletions
diff --git a/audio/lsp-plugins-lv2/Makefile b/audio/lsp-plugins-lv2/Makefile
index 226f46e91fa2..9cc54955ee2c 100644
--- a/audio/lsp-plugins-lv2/Makefile
+++ b/audio/lsp-plugins-lv2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= lsp-plugins
-DISTVERSION= 1.2.0
+DISTVERSION= 1.2.1
CATEGORIES= audio
-MASTER_SITES= https://github.com/sadko4u/lsp-plugins/releases/download/1.2.0/
+MASTER_SITES= https://github.com/sadko4u/lsp-plugins/releases/download/${DISTVERSION}/
PKGNAMESUFFIX= -lv2
DISTFILES= ${PORTNAME}-src-${DISTVERSION}.tar.gz
@@ -60,7 +60,7 @@ post-install:
post-install-JACK-on:
@${STRIP_CMD} \
${STAGEDIR}${PREFIX}/bin/lsp-* \
- ${STAGEDIR}${PREFIX}/lib/lsp-plugins/liblsp-plugins-jack-1.2.0.so
+ ${STAGEDIR}${PREFIX}/lib/lsp-plugins/liblsp-plugins-jack-${PORTVERSION}.so
post-install-VST2-on:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/vst/lsp-plugins/*.so
diff --git a/audio/lsp-plugins-lv2/distinfo b/audio/lsp-plugins-lv2/distinfo
index 85968f2433b4..5052481728e8 100644
--- a/audio/lsp-plugins-lv2/distinfo
+++ b/audio/lsp-plugins-lv2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1650483074
-SHA256 (lsp-plugins-src-1.2.0.tar.gz) = af75332bf996dd572ae1a8e6ea3537d02cc95c5a05b7ee04597afd068800e977
-SIZE (lsp-plugins-src-1.2.0.tar.gz) = 25971969
+TIMESTAMP = 1651625840
+SHA256 (lsp-plugins-src-1.2.1.tar.gz) = c0789b6496eb832eedd33dab4437b5154006dfc056fdd474260a0a5566029fad
+SIZE (lsp-plugins-src-1.2.1.tar.gz) = 36424374
diff --git a/audio/lsp-plugins-lv2/files/patch-b2d31f757611b6fb8fc16c8a78465b11bc392526 b/audio/lsp-plugins-lv2/files/patch-b2d31f757611b6fb8fc16c8a78465b11bc392526
deleted file mode 100644
index 3524ca186d4d..000000000000
--- a/audio/lsp-plugins-lv2/files/patch-b2d31f757611b6fb8fc16c8a78465b11bc392526
+++ /dev/null
@@ -1,143 +0,0 @@
-- fix of the compilation problem: https://github.com/lsp-plugins/lsp-plugin-fw/commit/b2d31f757611b6fb8fc16c8a78465b11bc392526
-
-From b2d31f757611b6fb8fc16c8a78465b11bc392526 Mon Sep 17 00:00:00 2001
-From: sadko4u <sadko4u@gmail.com>
-Date: Thu, 21 Apr 2022 00:00:52 +0300
-Subject: [PATCH] Fixed compilation for clang.
-
---- modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ports.h.orig 2022-03-25 17:27:50 UTC
-+++ modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ports.h
-@@ -470,7 +470,7 @@ namespace lsp
- class MeshPort: public Port
- {
- private:
-- jack::mesh_t *pMesh;
-+ plug::mesh_t *pMesh;
-
- public:
- explicit MeshPort(const meta::port_t *meta, Wrapper *w) : Port(meta, w)
-@@ -485,7 +485,7 @@ namespace lsp
-
- virtual int init()
- {
-- pMesh = jack::mesh_t::create(pMetadata);
-+ pMesh = jack::create_mesh(pMetadata);
- return (pMesh == NULL) ? STATUS_NO_MEM : STATUS_OK;
- }
-
-@@ -494,7 +494,7 @@ namespace lsp
- if (pMesh == NULL)
- return;
-
-- jack::mesh_t::destroy(pMesh);
-+ jack::destroy_mesh(pMesh);
- pMesh = NULL;
- }
-
---- modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/types.h.orig 2022-03-25 17:27:50 UTC
-+++ modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/types.h
-@@ -147,45 +147,41 @@ namespace lsp
-
- } path_t;
-
-- typedef struct mesh_t: public plug::mesh_t
-+ inline plug::mesh_t *create_mesh(const meta::port_t *meta)
- {
-- static mesh_t *create(const meta::port_t *meta)
-- {
-- size_t buffers = meta->step;
-- size_t buf_size = meta->start * sizeof(float);
-- size_t mesh_size = sizeof(mesh_t) + sizeof(float *) * buffers;
-+ size_t buffers = meta->step;
-+ size_t buf_size = meta->start * sizeof(float);
-+ size_t mesh_size = sizeof(plug::mesh_t) + sizeof(float *) * buffers;
-
-- // Align values to 64-byte boundaries
-- buf_size = align_size(buf_size, OPTIMAL_ALIGN);
-- mesh_size = align_size(mesh_size, OPTIMAL_ALIGN);
-+ // Align values to 64-byte boundaries
-+ buf_size = align_size(buf_size, OPTIMAL_ALIGN);
-+ mesh_size = align_size(mesh_size, OPTIMAL_ALIGN);
-
-- // Allocate pointer
-- uint8_t *ptr = static_cast<uint8_t *>(malloc(mesh_size + buf_size * buffers));
-- if (ptr == NULL)
-- return NULL;
-+ // Allocate pointer
-+ uint8_t *ptr = static_cast<uint8_t *>(malloc(mesh_size + buf_size * buffers));
-+ if (ptr == NULL)
-+ return NULL;
-
-- // Initialize references
-- mesh_t *mesh = reinterpret_cast<mesh_t *>(ptr);
-- mesh->nState = plug::M_EMPTY;
-- mesh->nBuffers = 0;
-- mesh->nItems = 0;
-- ptr += mesh_size;
-- for (size_t i=0; i<buffers; ++i)
-- {
-- mesh->pvData[i] = reinterpret_cast<float *>(ptr);
-- ptr += buf_size;
-- }
--
-- return mesh;
-- }
--
-- static void destroy(mesh_t *mesh)
-+ // Initialize references
-+ plug::mesh_t *mesh = reinterpret_cast<plug::mesh_t *>(ptr);
-+ mesh->nState = plug::M_EMPTY;
-+ mesh->nBuffers = 0;
-+ mesh->nItems = 0;
-+ ptr += mesh_size;
-+ for (size_t i=0; i<buffers; ++i)
- {
-- if (mesh != NULL)
-- free(mesh);
-+ mesh->pvData[i] = reinterpret_cast<float *>(ptr);
-+ ptr += buf_size;
- }
-- } mesh_t;
-
-+ return mesh;
-+ }
-+
-+ inline void destroy_mesh(plug::mesh_t *mesh)
-+ {
-+ if (mesh != NULL)
-+ free(mesh);
-+ }
- }
- }
-
---- modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ui_ports.h.orig 2022-03-25 17:27:50 UTC
-+++ modules/lsp-plugin-fw/include/lsp-plug.in/plug-fw/wrap/jack/ui_ports.h
-@@ -167,24 +167,24 @@ namespace lsp
- class UIMeshPort: public UIPort
- {
- private:
-- jack::mesh_t *pMesh;
-+ plug::mesh_t *pMesh;
-
- public:
- explicit UIMeshPort(jack::Port *port): UIPort(port)
- {
-- pMesh = jack::mesh_t::create(port->metadata());
-+ pMesh = jack::create_mesh(port->metadata());
- }
-
- virtual ~UIMeshPort()
- {
-- jack::mesh_t::destroy(pMesh);
-+ jack::destroy_mesh(pMesh);
- pMesh = NULL;
- }
-
- public:
- virtual bool sync()
- {
-- mesh_t *mesh = pPort->buffer<mesh_t>();
-+ plug::mesh_t *mesh = pPort->buffer<plug::mesh_t>();
- if ((mesh == NULL) || (!mesh->containsData()))
- return false;
-
diff --git a/audio/lsp-plugins-lv2/pkg-plist b/audio/lsp-plugins-lv2/pkg-plist
index 9a3dadef26bf..1adbde2419b9 100644
--- a/audio/lsp-plugins-lv2/pkg-plist
+++ b/audio/lsp-plugins-lv2/pkg-plist
@@ -125,7 +125,7 @@
%%JACK%%lib/liblsp-r3d-glx-lib-1.0.1.so
%%JACK%%lib/liblsp-r3d-glx-lib.a
%%JACK%%lib/liblsp-r3d-glx-lib.so
-%%JACK%%lib/lsp-plugins/liblsp-plugins-jack-1.2.0.so
+%%JACK%%lib/lsp-plugins/liblsp-plugins-jack-1.2.1.so
lib/lv2/lsp-plugins.lv2/art_delay_mono.ttl
lib/lv2/lsp-plugins.lv2/art_delay_stereo.ttl
lib/lv2/lsp-plugins.lv2/comp_delay_mono.ttl
@@ -168,8 +168,8 @@ lib/lv2/lsp-plugins.lv2/limiter_mono.ttl
lib/lv2/lsp-plugins.lv2/limiter_stereo.ttl
lib/lv2/lsp-plugins.lv2/loud_comp_mono.ttl
lib/lv2/lsp-plugins.lv2/loud_comp_stereo.ttl
-lib/lv2/lsp-plugins.lv2/lsp-plugins-lv2-1.2.0.so
-lib/lv2/lsp-plugins.lv2/lsp-plugins-lv2ui-1.2.0.so
+lib/lv2/lsp-plugins.lv2/lsp-plugins-lv2-1.2.1.so
+lib/lv2/lsp-plugins.lv2/lsp-plugins-lv2ui-1.2.1.so
lib/lv2/lsp-plugins.lv2/manifest.ttl
lib/lv2/lsp-plugins.lv2/mb_compressor_lr.ttl
lib/lv2/lsp-plugins.lv2/mb_compressor_mono.ttl
@@ -294,7 +294,7 @@ lib/lv2/lsp-plugins.lv2/trigger_stereo.ttl
%%VST2%%lib/vst/lsp-plugins/limiter-stereo.so
%%VST2%%lib/vst/lsp-plugins/loud-comp-mono.so
%%VST2%%lib/vst/lsp-plugins/loud-comp-stereo.so
-%%VST2%%lib/vst/lsp-plugins/lsp-plugins-vst2-1.2.0.so
+%%VST2%%lib/vst/lsp-plugins/lsp-plugins-vst2-1.2.1.so
%%VST2%%lib/vst/lsp-plugins/mb-compressor-lr.so
%%VST2%%lib/vst/lsp-plugins/mb-compressor-mono.so
%%VST2%%lib/vst/lsp-plugins/mb-compressor-ms.so