aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-09-04 16:35:24 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-09-04 16:35:24 +0000
commit951bb0c949fcdb80d3f193dd5ca99904f4af23a9 (patch)
tree147d7248d0032bdc8f94a03407a3134b1d904b64
parent0083e93666f3fa9efd7f11546e5fccfb180a18d7 (diff)
downloadports-951bb0c949fcdb80d3f193dd5ca99904f4af23a9.tar.gz
ports-951bb0c949fcdb80d3f193dd5ca99904f4af23a9.zip
finance/expense: replace previous naive build "fix" with a real one
Comparator functions must return NSComparisonResult, not an integer. Fixes: 944d53ea8c43
-rw-r--r--finance/expense/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/finance/expense/Makefile b/finance/expense/Makefile
index eabe22510461..db38c5504c3c 100644
--- a/finance/expense/Makefile
+++ b/finance/expense/Makefile
@@ -18,13 +18,11 @@ WRKSRC= ${WRKDIR}/Expense
PORTSCOUT= ignore:1
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
-ADDITIONAL_CPPFLAGS+= -Wno-error=incompatible-function-pointer-types
-.endif
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Expense.app/Expense
+post-patch:
+ @${REINPLACE_CMD} -e '/_recordSort/s,^int,NSComparisonResult,' \
+ ${WRKSRC}/LedgerModel.[hm]
+
.include <bsd.port.mk>