aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-05 22:58:04 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2024-01-10 09:46:56 +0000
commit951dfc6f76dba7e53ebd8d4497918b4fc8c953b6 (patch)
tree8591588e774cbdc023b65a9b7131698302a95eff
parent1b819e486953bae191a4b8f0da175b55cb6c3070 (diff)
downloadports-951dfc6f76dba7e53ebd8d4497918b4fc8c953b6.tar.gz
ports-951dfc6f76dba7e53ebd8d4497918b4fc8c953b6.zip
multimedia/libx264: fix build on powerpc64le on 15
cc: error: unsupported option '-mabi=' for target 'powerpc64le-unknown-freebsd15.0'
-rw-r--r--multimedia/libx264/Makefile3
-rw-r--r--multimedia/x264/files/patch-configure27
2 files changed, 18 insertions, 12 deletions
diff --git a/multimedia/libx264/Makefile b/multimedia/libx264/Makefile
index 819813278a9d..487cb9514621 100644
--- a/multimedia/libx264/Makefile
+++ b/multimedia/libx264/Makefile
@@ -7,9 +7,6 @@ COMMENT= H.264/MPEG-4 AVC Video Encoding (Library)
MASTERDIR= ${.CURDIR}/../x264
PLIST= ${.CURDIR}/pkg-plist
-NOT_FOR_ARCHS= powerpc64le
-NOT_FOR_ARCHS_REASON= endian test failed
-
# Clear dependency on libx264 (itself), see x264/Makefile
LIB_DEPENDS= #
diff --git a/multimedia/x264/files/patch-configure b/multimedia/x264/files/patch-configure
index c2dfba0cefa9..07d1103cdc7a 100644
--- a/multimedia/x264/files/patch-configure
+++ b/multimedia/x264/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2020-09-12 17:23:57 UTC
+--- configure.orig 2024-01-05 22:26:57 UTC
+++ configure
-@@ -743,12 +743,6 @@ case $host_cpu in
+@@ -744,12 +744,6 @@ case $host_cpu in
AS_EXT=".asm"
ASFLAGS="$ASFLAGS -DARCH_X86_64=0 -I\$(SRCPATH)/common/x86/"
if [ $compiler = GNU ]; then
@@ -13,7 +13,7 @@
CFLAGS="-m32 $CFLAGS"
LDFLAGS="-m32 $LDFLAGS"
fi
-@@ -763,7 +757,7 @@ case $host_cpu in
+@@ -764,7 +758,7 @@ case $host_cpu in
ASFLAGS="$ASFLAGS -f elf32"
fi
;;
@@ -22,7 +22,16 @@
ARCH="X86_64"
AS="${AS-nasm}"
AS_EXT=".asm"
-@@ -952,7 +946,7 @@ if cc_check '' '' '' '__attribute__((force_align_arg_p
+@@ -801,7 +795,7 @@ case $host_cpu in
+ if [ $SYS = MACOSX ] ; then
+ CFLAGS="$CFLAGS -faltivec -fastf -mcpu=G4"
+ else
+- CFLAGS="$CFLAGS -maltivec -mabi=altivec"
++ CFLAGS="$CFLAGS -maltivec"
+ define HAVE_ALTIVEC_H
+ fi
+ if [ "$vsx" != "no" ] ; then
+@@ -958,7 +952,7 @@ fi
fi
fi
@@ -31,7 +40,7 @@
if ! as_check "vmovdqa32 [eax]{k1}{z}, zmm0" ; then
VER="$( ($AS --version || echo no assembler) 2>/dev/null | head -n 1 )"
echo "Found $VER"
-@@ -965,9 +959,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \
+@@ -971,9 +965,6 @@ if [ $asm = auto -a $ARCH = ARM ] ; then
fi
if [ $asm = auto -a $ARCH = ARM ] ; then
@@ -41,7 +50,7 @@
cc_check '' '' '__asm__("add r0, r1, r2");' && define HAVE_ARM_INLINE_ASM
if [ $compiler = CL ] && cpp_check '' '' 'defined(_M_ARM) && _M_ARM >= 7' ; then
define HAVE_ARMV6
-@@ -978,9 +969,8 @@ if [ $asm = auto -a $ARCH = ARM ] ; then
+@@ -984,9 +975,8 @@ if [ $asm = auto -a $ARCH = ARM ] ; then
cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON
ASFLAGS="$ASFLAGS -c"
else
@@ -53,7 +62,7 @@
fi
fi
-@@ -1012,9 +1002,8 @@ if [ $asm = auto -a $ARCH = MIPS ] ; then
+@@ -1018,9 +1008,8 @@ if [ $asm = auto -a $ARCH = MIPS ] ; then
if cc_check '' '' '__asm__("addvi.b $w0, $w1, 1");' ; then
define HAVE_MSA
else
@@ -65,7 +74,7 @@
fi
fi
-@@ -1343,10 +1332,6 @@ if cc_check '' -Wshadow ; then
+@@ -1368,10 +1357,6 @@ fi
CFLAGS="-Wshadow $CFLAGS"
fi
@@ -76,7 +85,7 @@
if [ $compiler = GNU ] && cc_check '' -fvisibility=hidden ; then
CFLAGS="$CFLAGS -fvisibility=hidden"
fi
-@@ -1386,6 +1371,9 @@ if [ "$opencl" = "yes" ]; then
+@@ -1411,6 +1396,9 @@ if [ "$opencl" = "yes" ]; then
opencl="yes"
define HAVE_OPENCL "(BIT_DEPTH==8)"
libdl="-ldl"