aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-09-08 22:52:36 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-09-08 22:52:36 +0000
commit955e1cb1fe00d80b0cb724ba4954d18b53a0a910 (patch)
tree376ecbbfa4b2c78fbb675c3f593a63e77f04e81a
parent45a231d71e11c21c1bdf84c4e007ac27d9b6b368 (diff)
downloadports-955e1cb1fe00d80b0cb724ba4954d18b53a0a910.tar.gz
ports-955e1cb1fe00d80b0cb724ba4954d18b53a0a910.zip
- Update to version 5.2.
- Take maintainership. - Install manual page. - Mark as IGNORE for 4.x (does not build).
Notes
Notes: svn path=/head/; revision=172596
-rw-r--r--games/bsp/Makefile23
-rw-r--r--games/bsp/distinfo6
-rw-r--r--games/bsp/files/patch-endian.c11
3 files changed, 19 insertions, 21 deletions
diff --git a/games/bsp/Makefile b/games/bsp/Makefile
index 2c49068eead6..d372a01e0349 100644
--- a/games/bsp/Makefile
+++ b/games/bsp/Makefile
@@ -6,25 +6,34 @@
#
PORTNAME= bsp
-PORTVERSION= 5.1
+PORTVERSION= 5.2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= doombsp
+MASTER_SITES= http://games.moria.org.uk/doom/bsp/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= alepulver@FreeBSD.org
COMMENT= Node builder for Doom
+USE_BZIP2= yes
GNU_CONFIGURE= yes
+MAN6= bsp.6
+
post-patch:
- ${REINPLACE_CMD} -e "s,-O2 -fomit-frame-pointer -ffast-math,${CFLAGS}," \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2 -fomit-frame-pointer|${CFLAGS} &|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bsp ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/bsp.6 ${MANPREFIX}/man/man6
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= does not build
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/bsp/distinfo b/games/bsp/distinfo
index 426619f9de1d..0a551b16a126 100644
--- a/games/bsp/distinfo
+++ b/games/bsp/distinfo
@@ -1,3 +1,3 @@
-MD5 (bsp-5.1.tar.gz) = a8d7cf42baf7ecb291869899e2aefae8
-SHA256 (bsp-5.1.tar.gz) = 15db23b6c55b0b672d1b284c862141bf9c1b54e68ce8bde7e6c00e01306d9e4e
-SIZE (bsp-5.1.tar.gz) = 143323
+MD5 (bsp-5.2.tar.bz2) = 6f29fc0d5ca0512c34482843b0a1fcb3
+SHA256 (bsp-5.2.tar.bz2) = 641c4350fd620d485e874dc9e504e6feeb6f44272be50f8622c97cbe396bc00e
+SIZE (bsp-5.2.tar.bz2) = 162768
diff --git a/games/bsp/files/patch-endian.c b/games/bsp/files/patch-endian.c
deleted file mode 100644
index 1740538e20d9..000000000000
--- a/games/bsp/files/patch-endian.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- endian.c Mon Jan 24 21:25:33 2005
-+++ endian.c Mon Jan 24 21:25:09 2005
-@@ -195,7 +195,7 @@
- {
- Verbose("Doing endianness correction... ");
- ConvertVertex();
-- ConvertLineDef();
-+ ConvertLinedef();
- ConvertSidedef();
- ConvertSector();
- ConvertPseg();