aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-01-13 11:38:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-01-13 11:38:02 +0000
commit959b8ae97402be80d337b7cca88eb3a3bcff2d5d (patch)
treed95163f9b064a6098d26fcf890199f69fa4a058c
parentb31f2fdb7c3160909555a13d39c47154e31efb98 (diff)
downloadports-959b8ae97402be80d337b7cca88eb3a3bcff2d5d.tar.gz
ports-959b8ae97402be80d337b7cca88eb3a3bcff2d5d.zip
databases/symphytum: new port had been added (+)
Symphytum is a personal database software for everyone who desires to manage and organize data in an easy and intuitive way, without having to study complex database languages and software user interfaces. WWW: https://github.com/giowck/symphytum
-rw-r--r--databases/Makefile1
-rw-r--r--databases/symphytum/Makefile32
-rw-r--r--databases/symphytum/distinfo3
-rw-r--r--databases/symphytum/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 371cf14a59cb..1bb2b084cc2e 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -1035,6 +1035,7 @@
SUBDIR += sqlrelay
SUBDIR += sqsh
SUBDIR += squirrel-sql
+ SUBDIR += symphytum
SUBDIR += tarantool
SUBDIR += tarantool-c
SUBDIR += tcl-Mysql
diff --git a/databases/symphytum/Makefile b/databases/symphytum/Makefile
new file mode 100644
index 000000000000..c1b3d262b92c
--- /dev/null
+++ b/databases/symphytum/Makefile
@@ -0,0 +1,32 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= symphytum
+PORTVERSION= 2.6
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Personal, user-friendly database software
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= qmake qt:5
+USE_QT= buildtools_build \
+ core gui network printsupport sql svg widgets
+USE_GITHUB= yes
+GH_ACCOUNT= giowck
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= AUTHORS CHANGELOG.md
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/databases/symphytum/distinfo b/databases/symphytum/distinfo
new file mode 100644
index 000000000000..265ce97836ff
--- /dev/null
+++ b/databases/symphytum/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1580856379
+SHA256 (giowck-symphytum-v2.6_GH0.tar.gz) = 64f2c10fc7de005473cc49c7109fc19fb5e0765f94ca3ffc23fbd9627d728610
+SIZE (giowck-symphytum-v2.6_GH0.tar.gz) = 15443973
diff --git a/databases/symphytum/pkg-descr b/databases/symphytum/pkg-descr
new file mode 100644
index 000000000000..91310dc5baad
--- /dev/null
+++ b/databases/symphytum/pkg-descr
@@ -0,0 +1,5 @@
+Symphytum is a personal database software for everyone who desires to
+manage and organize data in an easy and intuitive way, without having
+to study complex database languages and software user interfaces.
+
+WWW: https://github.com/giowck/symphytum