aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-16 15:13:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-16 15:23:48 +0000
commit95b7a5b34a963490503cd26159895b192358a9e8 (patch)
treee1c40186cf4216807d83a5ff81f09bd41b7bd732
parentc7864c5a12e00502b72ecbe8275dafe3d4e7de30 (diff)
downloadports-95b7a5b34a963490503cd26159895b192358a9e8.tar.gz
ports-95b7a5b34a963490503cd26159895b192358a9e8.zip
print/py-vharfbuzz: Add py-vharfbuzz 0.1.1
uharfbuzz is an awesome tool for shaping text in Python. But it wraps the Harfbuzz C interface quite closely, so still requires you to perform a bunch of boilerplate operations before you can get on with the shaping. vharfbuzz allows you a slightly more high-level interface to the text shaping process. WWW: https://github.com/simoncozens/vharfbuzz
-rw-r--r--print/Makefile1
-rw-r--r--print/py-vharfbuzz/Makefile22
-rw-r--r--print/py-vharfbuzz/distinfo3
-rw-r--r--print/py-vharfbuzz/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 550ec7fa3165..a9b740e9c0b7 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -196,6 +196,7 @@
SUBDIR += py-ttfautohint-py
SUBDIR += py-ufolib2
SUBDIR += py-uharfbuzz
+ SUBDIR += py-vharfbuzz
SUBDIR += py-weasyprint
SUBDIR += qpdf
SUBDIR += qpdfview
diff --git a/print/py-vharfbuzz/Makefile b/print/py-vharfbuzz/Makefile
new file mode 100644
index 000000000000..a9a45dab9f7a
--- /dev/null
+++ b/print/py-vharfbuzz/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= vharfbuzz
+PORTVERSION= 0.1.1
+CATEGORIES= print python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= User-friendlier way to use Harfbuzz in Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fonttools>=0:print/py-fonttools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}uharfbuzz>=0:print/py-uharfbuzz@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/print/py-vharfbuzz/distinfo b/print/py-vharfbuzz/distinfo
new file mode 100644
index 000000000000..2ae14768577f
--- /dev/null
+++ b/print/py-vharfbuzz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620928547
+SHA256 (vharfbuzz-0.1.1.tar.gz) = 49eb93735f22d46ba2cf5e6a7ea074bd279f00ad9b625f4d4ffb450ecfe68153
+SIZE (vharfbuzz-0.1.1.tar.gz) = 5078
diff --git a/print/py-vharfbuzz/pkg-descr b/print/py-vharfbuzz/pkg-descr
new file mode 100644
index 000000000000..e7e12a8032c1
--- /dev/null
+++ b/print/py-vharfbuzz/pkg-descr
@@ -0,0 +1,6 @@
+uharfbuzz is an awesome tool for shaping text in Python. But it wraps the
+Harfbuzz C interface quite closely, so still requires you to perform a bunch of
+boilerplate operations before you can get on with the shaping. vharfbuzz allows
+you a slightly more high-level interface to the text shaping process.
+
+WWW: https://github.com/simoncozens/vharfbuzz