aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@disroot.org>2023-08-19 19:12:09 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-09-10 16:13:03 +0000
commit95fe9b7490bf280b086ad650243b6f8a4f385286 (patch)
tree3348fc7fc39d6e90d11d6b8a22c1d5ae3de2e044
parent7219a47f1ab385e6977fb04aba301549d976965d (diff)
downloadports-95fe9b7490bf280b086ad650243b6f8a4f385286.tar.gz
ports-95fe9b7490bf280b086ad650243b6f8a4f385286.zip
sysutils/py-director: New port: Define and run multi-jail environments with AppJail
AppJail Director is a tool for running multi-jail environments on AppJail using a simple YAML specification. A Director file is used to define how one or more jails that make up your application are configured. Once you have a Director file, you can create and start your application with a single command: appjail-director up WWW: https://github.com/DtxdF/director PR: 273234
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-director/Makefile41
-rw-r--r--sysutils/py-director/distinfo3
-rw-r--r--sysutils/py-director/pkg-descr5
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index aaebcd65e3d8..58aac2410160 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1083,6 +1083,7 @@
SUBDIR += py-croniter
SUBDIR += py-dict-toolbox
SUBDIR += py-diffoscope
+ SUBDIR += py-director
SUBDIR += py-dirsync
SUBDIR += py-distro
SUBDIR += py-dlipower
diff --git a/sysutils/py-director/Makefile b/sysutils/py-director/Makefile
new file mode 100644
index 000000000000..deef404c4f52
--- /dev/null
+++ b/sysutils/py-director/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= director
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.1
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= DtxdF@disroot.org
+COMMENT= Define and run multi-jail environments with AppJail
+WWW= https://github.com/DtxdF/${PORTNAME}
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}strictyaml>=0:devel/py-strictyaml@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= DtxdF
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= APPJAIL_STABLE
+OPTIONS_SINGLE= APPJAIL
+OPTIONS_SINGLE_APPJAIL= APPJAIL_DEVEL APPJAIL_STABLE
+
+APPJAIL_DEVEL_DESC= Use the development version of AppJail
+APPJAIL_STABLE_DESC= Use the stable version of AppJail
+
+APPJAIL_DEVEL_RUN_DEPENDS= appjail:sysutils/appjail-devel
+APPJAIL_STABLE_RUN_DEPENDS= appjail:sysutils/appjail
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}/${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-director/distinfo b/sysutils/py-director/distinfo
new file mode 100644
index 000000000000..ced7eb9c7ab4
--- /dev/null
+++ b/sysutils/py-director/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692471352
+SHA256 (DtxdF-director-v0.2.1_GH0.tar.gz) = 83d38b8ac63a24157270f4b47a80b45f05febe399a7e3809e097ab944889db42
+SIZE (DtxdF-director-v0.2.1_GH0.tar.gz) = 10938
diff --git a/sysutils/py-director/pkg-descr b/sysutils/py-director/pkg-descr
new file mode 100644
index 000000000000..423a7927c7f3
--- /dev/null
+++ b/sysutils/py-director/pkg-descr
@@ -0,0 +1,5 @@
+AppJail Director is a tool for running multi-jail environments on
+AppJail using a simple YAML specification. A Director file is used
+to define how one or more jails that make up your application are
+configured. Once you have a Director file, you can create and start
+your application with a single command: appjail-director up