aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-12-29 18:53:49 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2023-12-29 18:57:14 +0000
commit96286fc8fdabb430731185b20409aba4e9f473fd (patch)
tree58db604620e0081ee2feeca13e6e8905d9680f5c
parent23a47f28de20c42fb2c3a7286c815797013df6ea (diff)
downloadports-96286fc8fdabb430731185b20409aba4e9f473fd.tar.gz
ports-96286fc8fdabb430731185b20409aba4e9f473fd.zip
biology/diamond: Fix build on main after import of clang 17
-rw-r--r--biology/diamond/Makefile1
-rw-r--r--biology/diamond/files/patch-src_util_data__structures_deque.h14
2 files changed, 15 insertions, 0 deletions
diff --git a/biology/diamond/Makefile b/biology/diamond/Makefile
index 7716c930c43a..d45e49fd8006 100644
--- a/biology/diamond/Makefile
+++ b/biology/diamond/Makefile
@@ -1,6 +1,7 @@
PORTNAME= diamond
DISTVERSIONPREFIX= v
DISTVERSION= 2.1.8
+PORTREVISION= 1
CATEGORIES= biology
MAINTAINER= jrm@FreeBSD.org
diff --git a/biology/diamond/files/patch-src_util_data__structures_deque.h b/biology/diamond/files/patch-src_util_data__structures_deque.h
new file mode 100644
index 000000000000..efaa13f79a8a
--- /dev/null
+++ b/biology/diamond/files/patch-src_util_data__structures_deque.h
@@ -0,0 +1,14 @@
+--- src/util/data_structures/deque.h.orig 2023-12-29 18:15:28 UTC
++++ src/util/data_structures/deque.h
+@@ -186,6 +186,11 @@ struct Deque {
+ return *this;
+ }
+
++ Iterator& operator-=(ptrdiff_t i) {
++ i_ -= i;
++ return *this;
++ }
++
+ private:
+
+ ptrdiff_t i_;