aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-29 21:54:13 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-31 00:06:18 +0000
commit9662523850423d0f53668dcb364b100ed5d0159d (patch)
tree8e656de234168d5180fd272d98a196ece6860dab
parent6f78b7e075dfe7c56659d0b869a6887b16fbc18f (diff)
downloadports-9662523850423d0f53668dcb364b100ed5d0159d.tar.gz
ports-9662523850423d0f53668dcb364b100ed5d0159d.zip
graphics/libgfx: Remove expired port
2023-12-31 graphics/libgfx: unmaintained upstream since sep 2005
-rw-r--r--MOVED1
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libgfx/Makefile51
-rw-r--r--graphics/libgfx/distinfo2
-rw-r--r--graphics/libgfx/files/patch-png.cxx28
-rw-r--r--graphics/libgfx/files/patch-warnings52
-rw-r--r--graphics/libgfx/pkg-descr7
-rw-r--r--graphics/libgfx/pkg-plist34
8 files changed, 1 insertions, 175 deletions
diff --git a/MOVED b/MOVED
index 51bb6fb71755..5a30bab58281 100644
--- a/MOVED
+++ b/MOVED
@@ -8212,3 +8212,4 @@ comms/ncid||2023-12-31|Has expired: Umaintained for over a year, outdated and un
multimedia/gmerlin||2023-12-31|Has expired: Upstream last activity was in 2012
mail/trojita||2023-12-31|Has expired: Depends on deprecated www/qt5-webkit
games/springlobby||2023-12-31|Has expired: Depends on expired games/spring
+graphics/libgfx||2023-12-31|Has expired: unmaintained upstream since sep 2005
diff --git a/graphics/Makefile b/graphics/Makefile
index 2eda6b37dba7..ac2a07992227 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -461,7 +461,6 @@
SUBDIR += libfpx
SUBDIR += libfreehand
SUBDIR += libgeotiff
- SUBDIR += libgfx
SUBDIR += libgltext
SUBDIR += libgltf
SUBDIR += libglvnd
diff --git a/graphics/libgfx/Makefile b/graphics/libgfx/Makefile
deleted file mode 100644
index 4649229dd3d1..000000000000
--- a/graphics/libgfx/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-PORTNAME= libgfx
-DISTVERSION= 1.1.0
-PORTREVISION= 14
-CATEGORIES= graphics
-MASTER_SITES= http://mgarland.org/files/dist/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= OpenGL/FLTK development
-WWW= https://mgarland.org/software/libgfx.html
-
-LICENSE= MIT
-
-DEPRECATED= unmaintained upstream since sep 2005
-EXPIRATION_DATE= 2023-12-31
-
-LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
- libtiff.so:graphics/tiff \
- libpng.so:graphics/png \
- libgzstream.so:devel/gzstream
-
-BUILD_WRKSRC= ${WRKSRC}/src
-
-USES= gl gmake jpeg xorg
-USE_GL= glu
-USE_XORG= x11 xext xft xinerama
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-gzstream --with-libtiff-lzw --with-x
-ALL_TARGET= ${PORTNAME}.so
-USE_LDCONFIG= yes
-
-CFLAGS+= -fPIC
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-post-patch:
- @${REINPLACE_CMD} -e \
- '/^CC /d ; \
- /^CXX /d' ${WRKSRC}/gfx-config.in
- @${REINPLACE_CMD} -e \
- 's|\.a|.so|g ; \
- /RANLIB/d ; \
- s|[(]AR[)] cru|{CC} ${CFLAGS} ${LDFLAGS} -shared $${GUI_LIBS} -lgzstream -o|' ${WRKSRC}/src/${MAKEFILE}
- @${REINPLACE_CMD} -e \
- '/^FLTK_LIBS/s|"-lfltk"|"`fltk-config --ldflags`"|' ${WRKSRC}/configure
-
-do-install:
- @(cd ${WRKSRC}/include/gfx && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include/gfx)
- ${INSTALL_LIB} ${WRKSRC}/src/${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib
- @${LN} -sf ${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}.so.0
-
-.include <bsd.port.mk>
diff --git a/graphics/libgfx/distinfo b/graphics/libgfx/distinfo
deleted file mode 100644
index df8a66370119..000000000000
--- a/graphics/libgfx/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (libgfx-1.1.0.tar.gz) = 2bd53940c068c40125a8cfebcbd519c10c8630f8bdf4ebe9f57d328c74ad0284
-SIZE (libgfx-1.1.0.tar.gz) = 145470
diff --git a/graphics/libgfx/files/patch-png.cxx b/graphics/libgfx/files/patch-png.cxx
deleted file mode 100644
index ed39be100fa1..000000000000
--- a/graphics/libgfx/files/patch-png.cxx
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/raster-png.cxx.orig 2004-09-27 04:45:31 UTC
-+++ src/raster-png.cxx
-@@ -9,6 +9,7 @@
-
- ************************************************************************/
-
-+#include <cstring>
- #include <vector>
- #include <gfx/gfx.h>
- #include <gfx/raster.h>
-@@ -42,7 +43,7 @@ ByteRaster *read_png_image(const char *f
- // Because we didn't set up any error handlers, we need to be
- // prepared to handle longjmps out of the library on error
- // conditions.
-- if( setjmp(png_ptr->jmpbuf) )
-+ if( setjmp(png_jmpbuf(png_ptr)) )
- {
- png_destroy_read_struct(&png_ptr, &info_ptr, NULL);
- fclose(fp);
-@@ -132,7 +133,7 @@ bool write_png_image(const char *file_na
- return false;
- }
-
-- if( setjmp(png_ptr->jmpbuf) )
-+ if( setjmp(png_jmpbuf(png_ptr)) )
- {
- fclose(fp);
- png_destroy_write_struct(&png_ptr, (png_infopp)NULL);
diff --git a/graphics/libgfx/files/patch-warnings b/graphics/libgfx/files/patch-warnings
deleted file mode 100644
index 39b803b461c1..000000000000
--- a/graphics/libgfx/files/patch-warnings
+++ /dev/null
@@ -1,52 +0,0 @@
---- src/raster.cxx 2004-09-27 00:45:31.000000000 -0400
-+++ src/raster.cxx 2013-05-13 13:53:50.000000000 -0400
-@@ -10,4 +10,6 @@
- #include <gfx/raster.h>
-
-+#include <string.h> /* For memcpy() */
-+
- #include <string>
- #include <cctype>
-@@ -49,6 +51,6 @@
-
-
--static char *img_names[] = {"PPM", "PNG", "TIFF", "JPEG"};
--static char *img_ext[] = {"ppm", "png", "tif", "jpg"};
-+static const char *img_names[] = {"PPM", "PNG", "TIFF", "JPEG"};
-+static const char *img_ext[] = {"ppm", "png", "tif", "jpg"};
-
- const char *image_type_name(int type)
---- src/gltools.cxx 2005-06-18 09:58:15.000000000 -0400
-+++ src/gltools.cxx 2013-05-13 13:56:31.000000000 -0400
-@@ -57,5 +57,5 @@
- GLuint nnames = *ptr++;
- GLuint cur_zmin = *ptr++;
-- /* GLuint cur_zmax = */ *ptr++;
-+ ptr++;
-
- if( cur_zmin < zmin )
---- src/arcball.cxx 2004-09-27 00:45:31.000000000 -0400
-+++ src/arcball.cxx 2013-05-13 13:58:11.000000000 -0400
-@@ -20,22 +20,4 @@
- {
-
--// Converts a unit quaternion to two points on the unit sphere
--static void quat_to_sphere(const Quat& q, Vec3& from, Vec3& to)
--{
-- const Vec3& v = q.vector();
--
-- double s = sqrt(v[0]*v[0] + v[1]*v[1]);
-- if( s==0.0 )
-- from = Vec3(0.0, 1.0, 0.0);
-- else
-- from = Vec3(-v[1]/s, v[0]/s, 0.0);
--
-- to[0] = q.scalar()*from[0] - v[2]*from[1];
-- to[1] = q.scalar()*from[1] + v[2]*from[2];
-- to[2] = v[0]*from[1] - v[1]*from[0];
--
-- if(q.scalar() < 0.0) from = -from;
--}
--
- // Converts to points on unit sphere into a unit quaternion
- static Quat quat_from_sphere(const Vec3& from, const Vec3& to)
diff --git a/graphics/libgfx/pkg-descr b/graphics/libgfx/pkg-descr
deleted file mode 100644
index 5573455cbcb0..000000000000
--- a/graphics/libgfx/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-The purpose of this library is to simplify the creation of computer graphics
-software. Specifically, it is targeted towards cross-platform development
-using the OpenGL rendering API and the FLTK interface toolkit. It attempts
-to provide facilities which are useful in the majority of graphics programs.
-
-This release introduces some (relatively small) incompatible changes with
-1.0.x versions of the library. Details on changes can be found below.
diff --git a/graphics/libgfx/pkg-plist b/graphics/libgfx/pkg-plist
deleted file mode 100644
index 5eb234c7ee7c..000000000000
--- a/graphics/libgfx/pkg-plist
+++ /dev/null
@@ -1,34 +0,0 @@
-include/gfx/arcball.h
-include/gfx/array.h
-include/gfx/baseball.h
-include/gfx/color.h
-include/gfx/config-osx.h
-include/gfx/config-vc.h
-include/gfx/config.h
-include/gfx/config.h.in
-include/gfx/geom3d.h
-include/gfx/geom4d.h
-include/gfx/gfx.h
-include/gfx/gl.h
-include/gfx/glext.h
-include/gfx/gltools.h
-include/gfx/gui.h
-include/gfx/intvec.h
-include/gfx/mat2.h
-include/gfx/mat3.h
-include/gfx/mat4.h
-include/gfx/quat.h
-include/gfx/raster.h
-include/gfx/script.h
-include/gfx/symmat2.h
-include/gfx/symmat3.h
-include/gfx/symmat4.h
-include/gfx/trackball.h
-include/gfx/vec2.h
-include/gfx/vec3.h
-include/gfx/vec4.h
-include/gfx/win/gui-mfc.h
-include/gfx/win/mfc.h
-include/gfx/win/wintools.h
-lib/libgfx.so
-lib/libgfx.so.0