aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-16 11:17:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-04-16 11:17:14 +0000
commit96780b7f9917b4ec3429efb0ad1e0126e08f8794 (patch)
treeb44da03d52f6644fd481c7ad7c66349d44293b51
parentf027affded0cbc3a80717a7c104cecf1947ef697 (diff)
downloadports-96780b7f9917b4ec3429efb0ad1e0126e08f8794.tar.gz
ports-96780b7f9917b4ec3429efb0ad1e0126e08f8794.zip
- Update to 2.9.7
Notes
Notes: svn path=/head/; revision=252761
-rw-r--r--graphics/osg-devel/Makefile11
-rw-r--r--graphics/osg-devel/distinfo6
-rw-r--r--graphics/osg-devel/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp20
-rw-r--r--graphics/osg-devel/pkg-plist46
4 files changed, 41 insertions, 42 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 8e2961a4ea34..4484731563be 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= osg
-PORTVERSION= 2.9.6
-PORTREVISION= 3
+PORTVERSION= 2.9.7
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/distfiles/
@@ -32,9 +31,9 @@ USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=62 \
- OPENTHREADS_VERSION=2.4.0 \
- OPENTHREADS_SHLIBVER=11
+ OSG_SHLIBVER=63 \
+ OPENTHREADS_VERSION=2.5.0 \
+ OPENTHREADS_SHLIBVER=12
PORTSCOUT= limitw:1,odd
@@ -229,6 +228,8 @@ USE_XORG+= xrandr
post-patch:
@${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
+ @${REINPLACE_CMD} -e '/FIND_LIBRARY.*DL_LIBRARY/ d' \
+ ${WRKSRC}/CMakeLists.txt
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt
diff --git a/graphics/osg-devel/distinfo b/graphics/osg-devel/distinfo
index 7e340f4b01dd..6d5a71ea8043 100644
--- a/graphics/osg-devel/distinfo
+++ b/graphics/osg-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (OpenSceneGraph-2.9.6.zip) = f27a69499f3eadf1d8ad2ee22f6d5e85
-SHA256 (OpenSceneGraph-2.9.6.zip) = 9aa8ce2a581d42f8c9bac14dff5069c66633ddf73370a1e7412873048d643e9a
-SIZE (OpenSceneGraph-2.9.6.zip) = 7401321
+MD5 (OpenSceneGraph-2.9.7.zip) = b5118ed07ec2945e23ad5e880f3f0f6d
+SHA256 (OpenSceneGraph-2.9.7.zip) = ae0436a854b97a9efb7fe2c8a38630dab5182b1ea23b984ea0ea17fc789a5dd2
+SIZE (OpenSceneGraph-2.9.7.zip) = 7656130
diff --git a/graphics/osg-devel/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp b/graphics/osg-devel/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp
deleted file mode 100644
index f4a8c17c7639..000000000000
--- a/graphics/osg-devel/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/osgPlugins/png/ReaderWriterPNG.cpp.orig 2009-11-17 13:55:52.000000000 +0100
-+++ src/osgPlugins/png/ReaderWriterPNG.cpp 2010-03-29 16:18:38.000000000 +0200
-@@ -178,7 +178,7 @@
- endinfo = png_create_info_struct(png);
-
- fin.read((char*)header,8);
-- if (fin.gcount() == 8 && png_check_sig(header, 8))
-+ if (fin.gcount() == 8 && !png_sig_cmp(header, 0, 8))
- png_set_read_fn(png,&fin,png_read_istream); //Use custom read function that will get data from istream
- else
- {
-@@ -229,7 +229,7 @@
- if (color == PNG_COLOR_TYPE_PALETTE)
- png_set_palette_to_rgb(png);
- if (color == PNG_COLOR_TYPE_GRAY && depth < 8)
-- png_set_gray_1_2_4_to_8(png);
-+ png_set_expand_gray_1_2_4_to_8(png);
- if (png_get_valid(png, info, PNG_INFO_tRNS))
- png_set_tRNS_to_alpha(png);
-
diff --git a/graphics/osg-devel/pkg-plist b/graphics/osg-devel/pkg-plist
index 5e233ff39611..9893e2f14a0d 100644
--- a/graphics/osg-devel/pkg-plist
+++ b/graphics/osg-devel/pkg-plist
@@ -104,6 +104,8 @@ include/osg/NodeTrackerCallback
include/osg/NodeVisitor
include/osg/Notify
include/osg/Object
+include/osg/Observer
+include/osg/ObserverNodePath
include/osg/OccluderNode
include/osg/OcclusionQueryNode
include/osg/OperationThread
@@ -192,16 +194,14 @@ include/osgAnimation/ActionStripAnimation
include/osgAnimation/ActionVisitor
include/osgAnimation/Animation
include/osgAnimation/AnimationManagerBase
-include/osgAnimation/Assert
+include/osgAnimation/AnimationUpdateCallback
include/osgAnimation/BasicAnimationManager
include/osgAnimation/Bone
include/osgAnimation/BoneMapVisitor
include/osgAnimation/Channel
-include/osgAnimation/ComputeBindMatrixVisitor
include/osgAnimation/CubicBezier
include/osgAnimation/EaseMotion
include/osgAnimation/Export
-include/osgAnimation/FindParentAnimationManagerVisitor
include/osgAnimation/FrameAction
include/osgAnimation/Interpolator
include/osgAnimation/Keyframe
@@ -213,34 +213,44 @@ include/osgAnimation/RigTransformHardware
include/osgAnimation/RigTransformSoftware
include/osgAnimation/Sampler
include/osgAnimation/Skeleton
+include/osgAnimation/StackedMatrixElement
+include/osgAnimation/StackedQuaternionElement
+include/osgAnimation/StackedRotateAxisElement
+include/osgAnimation/StackedScaleElement
+include/osgAnimation/StackedTransform
+include/osgAnimation/StackedTransformElement
+include/osgAnimation/StackedTranslateElement
include/osgAnimation/StatsHandler
include/osgAnimation/StatsVisitor
include/osgAnimation/Target
include/osgAnimation/Timeline
include/osgAnimation/TimelineAnimationManager
-include/osgAnimation/UpdateCallback
+include/osgAnimation/UpdateBone
+include/osgAnimation/UpdateMaterial
+include/osgAnimation/UpdateMatrixTransform
include/osgAnimation/Vec3Packed
include/osgAnimation/VertexInfluence
include/osgDB/Archive
include/osgDB/AuthenticationMap
include/osgDB/Callbacks
include/osgDB/ConvertUTF
+include/osgDB/DataTypes
include/osgDB/DatabasePager
include/osgDB/DatabaseRevisions
include/osgDB/DotOsgWrapper
include/osgDB/DynamicLibrary
include/osgDB/Export
-include/osgDB/Field
-include/osgDB/FieldReader
-include/osgDB/FieldReaderIterator
include/osgDB/FileCache
include/osgDB/FileNameUtils
include/osgDB/FileUtils
include/osgDB/ImageOptions
include/osgDB/ImagePager
include/osgDB/Input
+include/osgDB/InputStream
+include/osgDB/ObjectWrapper
include/osgDB/Options
include/osgDB/Output
+include/osgDB/OutputStream
include/osgDB/ParameterOutput
include/osgDB/PluginQuery
include/osgDB/ReadFile
@@ -248,6 +258,7 @@ include/osgDB/ReaderWriter
include/osgDB/Registry
include/osgDB/Serializer
include/osgDB/SharedStateManager
+include/osgDB/StreamOperator
include/osgDB/Version
include/osgDB/WriteFile
include/osgDB/XmlParser
@@ -564,6 +575,17 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_bvh.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_cfg.so
%%CURL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_curl.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dds.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osganimation.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgfx.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgparticle.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgshadow.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgsim.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgterrain.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgtext.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgviewer.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgvolume.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_deprecated_osgwidget.so
%%ITK%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_dicom.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dw.so
@@ -592,17 +614,10 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_obj.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_openflight.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osg.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osga.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osganimation.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgfx.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgparticle.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgshadow.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgsim.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgterrain.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtext.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtgz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgviewer.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgvolume.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgwidget.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_p3d.so
%%PDF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_pdf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pic.so
@@ -613,6 +628,9 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_revisions.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rgb.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_scale.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osg.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgparticle.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgtext.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_shp.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_stl.so
%%SVG%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_svg.so