aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2024-03-23 15:00:09 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2024-03-23 15:00:59 +0000
commit97218fe0b5ed428fa8abefadfef391f8a41b829c (patch)
tree9b312923b7b60c5c1875aa4659127da107c3bfdb
parent43db9768ad6eefb2a036dbb926a67ab29c9e1305 (diff)
downloadports-97218fe0b5ed428fa8abefadfef391f8a41b829c.tar.gz
ports-97218fe0b5ed428fa8abefadfef391f8a41b829c.zip
security/boringssl: update to the recent snapshot
-rw-r--r--security/boringssl/Makefile4
-rw-r--r--security/boringssl/distinfo6
-rw-r--r--security/boringssl/files/patch-CMakeLists.txt (renamed from security/boringssl/files/patch-ssl_CMakeLists.txt)10
-rw-r--r--security/boringssl/files/patch-crypto_CMakeLists.txt4
-rw-r--r--security/boringssl/pkg-plist2
5 files changed, 15 insertions, 11 deletions
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
index bbc5d8e66437..4944847d4629 100644
--- a/security/boringssl/Makefile
+++ b/security/boringssl/Makefile
@@ -1,5 +1,5 @@
PORTNAME= boringssl
-PORTVERSION= 0.0.0.0.2024.02.28.01
+PORTVERSION= 0.0.0.0.2024.03.22.01
CATEGORIES= security
MASTER_SITES+= https://proxy.golang.org/:gomods
DISTFILES+= golang.org/x/crypto/@v/v0.17.0.zip:gomods \
@@ -28,7 +28,7 @@ CPE_VENDOR= google
USE_GITHUB= yes
GH_ACCOUNT= google
-GH_TAGNAME= df3b58e
+GH_TAGNAME= 231510c
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=1
CFLAGS_i386= -msse2
diff --git a/security/boringssl/distinfo b/security/boringssl/distinfo
index 89c7c1e5c616..96af871e0052 100644
--- a/security/boringssl/distinfo
+++ b/security/boringssl/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1709406072
+TIMESTAMP = 1711202760
SHA256 (golang.org/x/crypto/@v/v0.17.0.zip) = 97ea91df712ac1ca39c122480489be532b437bf4aeb5d781465cb1cf39824083
SIZE (golang.org/x/crypto/@v/v0.17.0.zip) = 1798689
SHA256 (golang.org/x/crypto/@v/v0.17.0.mod) = dc40867bef3ca5179569cc2f8742bb618b8cc684b0d25a753250e81d6dc29442
@@ -15,5 +15,5 @@ SHA256 (golang.org/x/term/@v/v0.15.0.zip) = cb7fff77d2925dc0e4f5ac0ced38d1068382
SIZE (golang.org/x/term/@v/v0.15.0.zip) = 19883
SHA256 (golang.org/x/term/@v/v0.15.0.mod) = 4b86976f8c4efb87bbcbec283cbfb395a28177b4b8b83420b49d95728eb7a2f8
SIZE (golang.org/x/term/@v/v0.15.0.mod) = 68
-SHA256 (google-boringssl-0.0.0.0.2024.02.28.01-df3b58e_GH0.tar.gz) = 06611a466cf36fb9608f46a5dbcef9588789726ac4edc22dd27b8def0b3e740a
-SIZE (google-boringssl-0.0.0.0.2024.02.28.01-df3b58e_GH0.tar.gz) = 36141420
+SHA256 (google-boringssl-0.0.0.0.2024.03.22.01-231510c_GH0.tar.gz) = a8a75d7c75ff152cfec8eff70c88b431ea083c0778795800214293c4011d04a6
+SIZE (google-boringssl-0.0.0.0.2024.03.22.01-231510c_GH0.tar.gz) = 36788739
diff --git a/security/boringssl/files/patch-ssl_CMakeLists.txt b/security/boringssl/files/patch-CMakeLists.txt
index d8c91acbddb2..c54f8fa02fad 100644
--- a/security/boringssl/files/patch-ssl_CMakeLists.txt
+++ b/security/boringssl/files/patch-CMakeLists.txt
@@ -1,8 +1,10 @@
---- ssl/CMakeLists.txt.orig 2023-07-12 16:42:06 UTC
-+++ ssl/CMakeLists.txt
-@@ -45,3 +45,5 @@ add_library(
+--- CMakeLists.txt.orig 2024-03-23 14:15:05 UTC
++++ CMakeLists.txt
+@@ -522,6 +522,7 @@ add_library(ssl ${SSL_SOURCES})
install_if_enabled(TARGETS ssl EXPORT OpenSSLTargets ${INSTALL_DESTINATION_DEFAULT})
set_property(TARGET ssl PROPERTY EXPORT_NAME SSL)
target_link_libraries(ssl crypto)
-+
+SET_TARGET_PROPERTIES(ssl PROPERTIES SOVERSION 1)
+
+ add_library(decrepit ${DECREPIT_SOURCES})
+ target_link_libraries(decrepit crypto ssl)
diff --git a/security/boringssl/files/patch-crypto_CMakeLists.txt b/security/boringssl/files/patch-crypto_CMakeLists.txt
index 6222ac5d5416..d123e69b80a9 100644
--- a/security/boringssl/files/patch-crypto_CMakeLists.txt
+++ b/security/boringssl/files/patch-crypto_CMakeLists.txt
@@ -1,6 +1,6 @@
---- crypto/CMakeLists.txt.orig 2024-02-28 18:04:35 UTC
+--- crypto/CMakeLists.txt.orig 2024-03-23 00:06:50 UTC
+++ crypto/CMakeLists.txt
-@@ -358,3 +358,5 @@ endif()
+@@ -375,3 +375,5 @@ endif()
if(USE_CUSTOM_LIBCXX)
target_link_libraries(crypto libcxx)
endif()
diff --git a/security/boringssl/pkg-plist b/security/boringssl/pkg-plist
index d98a5680514e..3bc465aa8145 100644
--- a/security/boringssl/pkg-plist
+++ b/security/boringssl/pkg-plist
@@ -40,6 +40,7 @@ include/openssl/evp.h
include/openssl/evp_errors.h
include/openssl/ex_data.h
include/openssl/experimental/kyber.h
+include/openssl/experimental/spx.h
include/openssl/hkdf.h
include/openssl/hmac.h
include/openssl/hpke.h
@@ -63,6 +64,7 @@ include/openssl/pkcs7.h
include/openssl/pkcs8.h
include/openssl/pki/certificate.h
include/openssl/pki/signature_verify_cache.h
+include/openssl/pki/verify_error.h
include/openssl/poly1305.h
include/openssl/pool.h
include/openssl/posix_time.h