aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:26:52 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:26:52 +0000
commit9782c3c17d1c690fea769ba7814bc635ffab8468 (patch)
treeb6cd75cd2a09f3fb49dfb6faf1f65fa15e48aa25
parent4466b95d595dddc26a2d5ccf9001a06488a4f9fd (diff)
downloadports-9782c3c17d1c690fea769ba7814bc635ffab8468.tar.gz
ports-9782c3c17d1c690fea769ba7814bc635ffab8468.zip
devel/py-pygit2: Fix RUN_DEPENDS
- cached-property is only required for Python 3.7 and below - six is not required - Update version requirement of *_DEPENDS - Bump PORTREVISION for dependency change from setup.py: install_requires = ['cffi>=1.4.0'] if sys.version_info < (3, 8): install_requires.append('cached-property') ... setup_requires=['cffi>=1.4.0'], from CHANGELOG.rst: - Don't require cached-property with Python 3.8 or later ... - Drop Python 2.7 and 3.4 support, six no longer required Approved by: portmgr (blanket) With hat: python
-rw-r--r--devel/py-pygit2/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/py-pygit2/Makefile b/devel/py-pygit2/Makefile
index 88788a8e5f5c..6a2b99b05a63 100644
--- a/devel/py-pygit2/Makefile
+++ b/devel/py-pygit2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pygit2
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,12 +13,9 @@ COMMENT= Python bindings for libgit2
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-MY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>1.0:devel/py-cffi@${PY_FLAVOR}
-BUILD_DEPENDS= ${MY_DEPENDS}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.4.0:devel/py-cffi@${PY_FLAVOR}
LIB_DEPENDS= libgit2.so:devel/libgit2
-RUN_DEPENDS= ${MY_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}cached-property>=0:devel/py-cached-property@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.4.0:devel/py-cffi@${PY_FLAVOR}
USES= python:3.8+
USE_PYTHON= autoplist distutils