aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2023-10-12 17:39:18 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2023-10-12 17:41:39 +0000
commit97d52f6d473533d6d53e5771c0839c160a2b92dd (patch)
tree75ae919f8ace5f8eb98954ce54f5b137e83b6ace
parent50dc8fda1928f029cad6d42584ec6a51e0b79c9e (diff)
downloadports-97d52f6d473533d6d53e5771c0839c160a2b92dd.tar.gz
ports-97d52f6d473533d6d53e5771c0839c160a2b92dd.zip
*/*: Set an expiration date for several Worldforge libraries and schedule for removal - There has been no release for most of the libraries in the past 10 years.
-rw-r--r--devel/atlas-devel/Makefile3
-rw-r--r--devel/atlas/Makefile3
-rw-r--r--devel/eris/Makefile3
-rw-r--r--devel/libwfut/Makefile3
-rw-r--r--devel/mercator/Makefile3
-rw-r--r--devel/mercator/pkg-descr6
-rw-r--r--devel/varconf/Makefile3
-rw-r--r--graphics/sage/Makefile3
-rw-r--r--math/wfmath/Makefile3
-rw-r--r--net/skstream/Makefile3
10 files changed, 30 insertions, 3 deletions
diff --git a/devel/atlas-devel/Makefile b/devel/atlas-devel/Makefile
index 58f4e3a26d57..a49107a4b0cb 100644
--- a/devel/atlas-devel/Makefile
+++ b/devel/atlas-devel/Makefile
@@ -13,6 +13,9 @@ WWW= https://www.worldforge.org/index.php/components/atlas-cpp/
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
USES= libtool pathfix compiler:c++11-lib tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/atlas/Makefile b/devel/atlas/Makefile
index 159a428c763d..a52fc7b339ed 100644
--- a/devel/atlas/Makefile
+++ b/devel/atlas/Makefile
@@ -12,6 +12,9 @@ WWW= https://www.worldforge.org/index.php/components/atlas-cpp/
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years
+EXPIRATION_DATE=2023-12-31
+
USES= libtool pathfix tar:bzip2
USE_CXXSTD= c++14
USE_LDCONFIG= yes
diff --git a/devel/eris/Makefile b/devel/eris/Makefile
index bb3f4d5dd985..cd89e33fb6c6 100644
--- a/devel/eris/Makefile
+++ b/devel/eris/Makefile
@@ -11,6 +11,9 @@ WWW= https://www.worldforge.org/index.php/components/eris/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
LIB_DEPENDS= libAtlas-0.6.so:devel/atlas-devel \
libskstream-0.3.so:net/skstream \
libwfmath-1.0.so:math/wfmath \
diff --git a/devel/libwfut/Makefile b/devel/libwfut/Makefile
index 3130a57c702d..f7f97471cfd3 100644
--- a/devel/libwfut/Makefile
+++ b/devel/libwfut/Makefile
@@ -11,6 +11,9 @@ WWW= https://www.worldforge.org/
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libcurl.so:ftp/curl
diff --git a/devel/mercator/Makefile b/devel/mercator/Makefile
index 2d02d847c9a8..1b275d4d5144 100644
--- a/devel/mercator/Makefile
+++ b/devel/mercator/Makefile
@@ -11,6 +11,9 @@ WWW= https://www.worldforge.org/index.php/components/mercator/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
LIB_DEPENDS= libwfmath-1.0.so:math/wfmath
USES= libtool pathfix pkgconfig compiler:c++11-lib
diff --git a/devel/mercator/pkg-descr b/devel/mercator/pkg-descr
index d9fb7c6d26d5..4d3c7112d52e 100644
--- a/devel/mercator/pkg-descr
+++ b/devel/mercator/pkg-descr
@@ -1,4 +1,4 @@
Mercator is a procedural terrain library. It is primarily aimed at terrain for
-multiplayer online games and forms one of the WorldForge
-(http://www.worldforge.org) core libraries. It is intended to be used as a
-terrain library on both the client, and the server.
+multiplayer online games and forms one of the WorldForge core libraries.
+It is intended to be used as a terrain library on both the client, and the
+server.
diff --git a/devel/varconf/Makefile b/devel/varconf/Makefile
index 48e068db8eb2..98364bfb9f1d 100644
--- a/devel/varconf/Makefile
+++ b/devel/varconf/Makefile
@@ -7,6 +7,9 @@ MASTER_SITES= SF/worldforge/${PORTNAME}%20%28config%20lib%29/${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
COMMENT= Configuration System for the STAGE Server
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20
USES= compiler:c++11-lib libtool pathfix pkgconfig tar:bzip2
diff --git a/graphics/sage/Makefile b/graphics/sage/Makefile
index ab993fe22fd2..7c8db1a0caed 100644
--- a/graphics/sage/Makefile
+++ b/graphics/sage/Makefile
@@ -8,6 +8,9 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= OpenGL extension library
WWW= http://www.worldforge.org/dev/eng/libraries/sage
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
CONFIGURE_ARGS= --program-transform-name=
GNU_CONFIGURE= yes
USES= gl libtool pathfix sdl
diff --git a/math/wfmath/Makefile b/math/wfmath/Makefile
index 31ec520aaa6e..eb3b90230f65 100644
--- a/math/wfmath/Makefile
+++ b/math/wfmath/Makefile
@@ -8,6 +8,9 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= Worldforge math library
WWW= https://www.worldforge.org/
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
USES= libtool pathfix pkgconfig compiler:c++11-lib
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/net/skstream/Makefile b/net/skstream/Makefile
index e957c4a4c1e2..d21f5ff19ced 100644
--- a/net/skstream/Makefile
+++ b/net/skstream/Makefile
@@ -11,6 +11,9 @@ WWW= http://www.worldforge.org/dev/eng/libraries/skstream/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= There has been no release for most of the Worldforge libraries in the past 10 years.
+EXPIRATION_DATE=2023-12-31
+
USES= libtool pathfix pkgconfig compiler:c++11-lib gmake
USE_CXXSTD= c++14
GNU_CONFIGURE= yes