aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schulz <ats@FreeBSD.org>1995-02-13 13:02:31 +0000
committerAndreas Schulz <ats@FreeBSD.org>1995-02-13 13:02:31 +0000
commit97dbcb4fff0788e2f700556bfda5e9165b265932 (patch)
treeea47889d6c49bf0398a719ebcc932734c544c632
parentd3ded881a1bc9ba64dddffe6ccc3403af13f09ee (diff)
downloadports-97dbcb4fff0788e2f700556bfda5e9165b265932.tar.gz
ports-97dbcb4fff0788e2f700556bfda5e9165b265932.zip
Add a "STRIP= " to the Makefile to prevent a problem that install will be
called with a "-s" flag for shell-scripts, fells flat on the nose and doesn't install them. We have a serious problem with name overloading here. The bsd.port.mk file uses INSTALL and INSTALL_PROGRAM that is also used from GNU's autoconfigure script. If configure detects them it uses it happily with sometimes surprising results. Normally configure know that shell scripts doesn't need the "-s" flag but our INSTALL in bsd.port.mk always uses the "-s" flag and overides configure's autodetection of the correct install and the installflags.
Notes
Notes: svn path=/head/; revision=963
-rw-r--r--editors/emacs/Makefile3
-rw-r--r--editors/emacs19/Makefile3
-rw-r--r--editors/emacs20/Makefile3
-rw-r--r--editors/emacs22/Makefile3
-rw-r--r--editors/emacs23/Makefile3
5 files changed, 10 insertions, 5 deletions
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 64a468da937a..674fcd3c6e02 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -3,12 +3,13 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.10 1995/01/05 09:00:18 jkh Exp $
+# $Id: Makefile,v 1.11 1995/01/09 12:06:29 jkh Exp $
#
DISTNAME= emacs-19.28
USE_GMAKE= yes
HAS_CONFIGURE= yes
+STRIP=
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX}
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
diff --git a/editors/emacs19/Makefile b/editors/emacs19/Makefile
index 64a468da937a..674fcd3c6e02 100644
--- a/editors/emacs19/Makefile
+++ b/editors/emacs19/Makefile
@@ -3,12 +3,13 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.10 1995/01/05 09:00:18 jkh Exp $
+# $Id: Makefile,v 1.11 1995/01/09 12:06:29 jkh Exp $
#
DISTNAME= emacs-19.28
USE_GMAKE= yes
HAS_CONFIGURE= yes
+STRIP=
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX}
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
diff --git a/editors/emacs20/Makefile b/editors/emacs20/Makefile
index 64a468da937a..674fcd3c6e02 100644
--- a/editors/emacs20/Makefile
+++ b/editors/emacs20/Makefile
@@ -3,12 +3,13 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.10 1995/01/05 09:00:18 jkh Exp $
+# $Id: Makefile,v 1.11 1995/01/09 12:06:29 jkh Exp $
#
DISTNAME= emacs-19.28
USE_GMAKE= yes
HAS_CONFIGURE= yes
+STRIP=
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX}
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
diff --git a/editors/emacs22/Makefile b/editors/emacs22/Makefile
index 64a468da937a..674fcd3c6e02 100644
--- a/editors/emacs22/Makefile
+++ b/editors/emacs22/Makefile
@@ -3,12 +3,13 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.10 1995/01/05 09:00:18 jkh Exp $
+# $Id: Makefile,v 1.11 1995/01/09 12:06:29 jkh Exp $
#
DISTNAME= emacs-19.28
USE_GMAKE= yes
HAS_CONFIGURE= yes
+STRIP=
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX}
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 64a468da937a..674fcd3c6e02 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -3,12 +3,13 @@
# Date created: 29 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.10 1995/01/05 09:00:18 jkh Exp $
+# $Id: Makefile,v 1.11 1995/01/09 12:06:29 jkh Exp $
#
DISTNAME= emacs-19.28
USE_GMAKE= yes
HAS_CONFIGURE= yes
+STRIP=
CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX}
MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/