aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 13:57:59 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-03 13:59:16 +0000
commit980748c75bf1722fc6dabb95b3caae389098bd08 (patch)
tree76e70b7e9293c619c9e188429d26ce9405ff89f7
parente51a2d1c8c5052a793244043470aba1e9655de06 (diff)
downloadports-980748c75bf1722fc6dabb95b3caae389098bd08.tar.gz
ports-980748c75bf1722fc6dabb95b3caae389098bd08.zip
math/py-cryptominisat: Fix build with setuptools 61.0.0+
With hat: python
-rw-r--r--math/py-cryptominisat/files/patch-setup.py.in26
1 files changed, 23 insertions, 3 deletions
diff --git a/math/py-cryptominisat/files/patch-setup.py.in b/math/py-cryptominisat/files/patch-setup.py.in
index ad6f9c3d61bb..a78c83ac1740 100644
--- a/math/py-cryptominisat/files/patch-setup.py.in
+++ b/math/py-cryptominisat/files/patch-setup.py.in
@@ -1,6 +1,26 @@
---- setup.py.in.orig 2019-02-19 20:49:20 UTC
+--- setup.py.in.orig 2020-07-06 21:45:41 UTC
+++ setup.py.in
-@@ -118,12 +118,12 @@ else:
+@@ -27,7 +27,7 @@ import sys
+ import os
+ import platform
+ from distutils.core import setup, Extension
+-from distutils import sysconfig
++import sysconfig
+ from distutils.cmd import Command
+
+ __PACKAGE_VERSION__ = "0.2.0"
+@@ -59,8 +59,8 @@ def _init_posix(init):
+ Forces g++ instead of gcc on most systems
+ credits to eric jones (eric@enthought.com) (found at Google Groups)
+ """
+- def wrapper():
+- init()
++ def wrapper(vars):
++ init(vars)
+
+ config_vars = sysconfig.get_config_vars() # by reference
+ if config_vars["MACHDEP"].startswith("sun"):
+@@ -119,12 +119,12 @@ else:
modules = dict(
name = "pycryptosat",
@@ -16,7 +36,7 @@
runtime_library_dirs=['${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}'],
libraries = [libname]
)
-@@ -152,7 +152,7 @@ setup(
+@@ -153,7 +153,7 @@ setup(
description = "Bindings to CryptoMiniSat {} (a SAT solver)".\
format(__LIBRARY_VERSION__),
# py_modules = ['pycryptosat'],