aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-04-29 09:17:17 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-04-29 09:17:17 +0000
commit98085c9b306f4a051952b63548bd92d4c68ef4aa (patch)
treeb93f2585f1a4437591dcb8507d8974e0c13e7aac
parent2084337456eac3fb2814aec32d989e02c12adb3a (diff)
downloadports-98085c9b306f4a051952b63548bd92d4c68ef4aa.tar.gz
ports-98085c9b306f4a051952b63548bd92d4c68ef4aa.zip
audio/mous: Unbreak and update to 2.0.1
Changes: https://github.com/bsdelf/mous/releases PR: 227500 Submitted by: Yanhui Shen <shen.elf@gmail.com> (maintainer, based on)
Notes
Notes: svn path=/head/; revision=468613
-rw-r--r--audio/mous/Makefile161
-rw-r--r--audio/mous/distinfo5
-rw-r--r--audio/mous/files/patch-CMakeLists.txt20
-rw-r--r--audio/mous/files/patch-contrib_ffmpeg-strip-wma_common.h14
-rw-r--r--audio/mous/files/patch-plugins_CuePack_CuePack.cpp11
-rw-r--r--audio/mous/files/patch-plugins_CuePack_CuePack.h11
-rw-r--r--audio/mous/pkg-descr2
-rw-r--r--audio/mous/pkg-message7
-rw-r--r--audio/mous/pkg-plist74
9 files changed, 85 insertions, 220 deletions
diff --git a/audio/mous/Makefile b/audio/mous/Makefile
index e2f9a57461d0..788fede74cc2 100644
--- a/audio/mous/Makefile
+++ b/audio/mous/Makefile
@@ -2,126 +2,103 @@
# $FreeBSD$
PORTNAME= mous
-PORTVERSION= 1.1a
-PORTREVISION= 6
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.1
CATEGORIES= audio
-MASTER_SITES= GHC
MAINTAINER= shen.elf@gmail.com
COMMENT= Simple yet powerful audio player
LICENSE= BSD2CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN= fails to build: sdk/scx/Socket.hpp:188:5: invalid operands to binary expression
-
-USES= cmake
+USES= cmake:outsource compiler:c++14-lang
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= bsdelf
-OPTIONS_DEFINE= ALSA ASSEMBLY FAAC FAAD FLAC LAME AO CUE MAC4DECODER \
- MACDECODER MPG123 NCURSES OSS QT4 SDK TAGLIB VORBIS \
- WAVDECODER WAVENCODER WMA
-OPTIONS_DEFAULT= FAAC FAAD FLAC LAME CUE MAC4DECODER \
- MPG123 NCURSES OSS QT4 TAGLIB VORBIS WAVDECODER \
- WAVENCODER
-OPTIONS_DEFAULT_amd64= ASSEMBLY WMA
-OPTIONS_DEFAULT_i386= ASSEMBLY WMA
-
-OPTIONS_SUB= yes
-
-ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
-ALSA_CMAKE_ON= -DWithPluginAlsaRenderer=1
-ALSA_CMAKE_OFF= -DWithPluginAlsaRenderer=0
-
-AO_LIB_DEPENDS= libao.so:audio/libao
-AO_CMAKE_ON= -DWithPluginAoRenderer=1
-AO_CMAKE_OFF= -DWithPluginAoRenderer=0
-
-ASSEMBLY_DESC= Enable assembly optimizations
-ASSEMBLY_BUILD_DEPENDS= ${LOCALBASE}/bin/yasm:devel/yasm
-ASSEMBLY_CMAKE_ON= -DWithAssembly=1
-ASSEMBLY_CMAKE_OFF= -DWithAssembly=0
-
-CUE_LIB_DEPENDS= libcue.so:textproc/libcue
-CUE_CMAKE_ON= -DWithPluginCuePack=1
-CUE_CMAKE_OFF= -DWithPluginCuePack=0
-
-FAAC_LIB_DEPENDS= libfaac.so:audio/faac
-FAAC_CMAKE_ON= -DWithPluginFaacEncoder=1
-FAAC_CMAKE_OFF= -DWithPluginFaacEncoder=0
-
-FAAD_LIB_DEPENDS= libfaad.so:audio/faad
-FAAD_CMAKE_ON= -DWithPluginFaadDecoder=1
-FAAD_CMAKE_OFF= -DWithPluginFaadEncoder=0
-
+CMAKE_OFF= WITH_PLUGIN_ALSA \
+ WITH_PLUGIN_COREAUDIO \
+ WITH_PLUGIN_FAAC \
+ WITH_PLUGIN_FAAD \
+ WITH_PLUGIN_LIBAO \
+ WITH_PLUGIN_WMA
+
+OPTIONS_DEFAULT= CLI NCURSES LIBCUE TAGLIB FDK_AAC FLAC LAME LIBCUE MAC \
+ MPG123 VORBIS WAV WAVPACK OSS
+OPTIONS_GROUP= APPLICATION GENERIC_PLUGIN CODEC_PLUGIN
+OPTIONS_GROUP_APPLICATION= CLI NCURSES QT5
+OPTIONS_GROUP_GENERIC_PLUGIN= LIBCUE TAGLIB
+OPTIONS_GROUP_CODEC_PLUGIN= FDK_AAC FLAC LAME MAC MPG123 VORBIS WAV WAVPACK
+OPTIONS_RADIO= OUTPUT_PLUGIN
+OPTIONS_RADIO_OUTPUT_PLUGIN= OSS SNDIO
+OPTIONS_SUB= yes
+
+APPLICATION_DESC= Interface support
+CLI_DESC= Command line interface support
+CODEC_PLUGIN_DESC= Codec plugins
+FDK_AAC_DESC= FDK AAC codec support
+GENERIC_PLUGIN_DESC= Generic plugins
+LIBCUE_DESC= CUE sheet support
+MAC_DESC= Monkey's Audio codec support
+OUTPUT_PLUGIN_DESC= Output plugins
+TAGLIB_DESC= TagLib support
+
+CLI_CMAKE_BOOL= WITH_APP_CLI
+
+FDK_AAC_CMAKE_BOOL= WITH_PLUGIN_FDK_AAC
+FDK_AAC_LIB_DEPENDS= libfdk-aac.so:audio/fdk-aac \
+ libmp4v2.so:multimedia/mp4v2
+
+FLAC_CMAKE_BOOL= WITH_PLUGIN_FLAC
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
-FLAC_CMAKE_ON= -DWithPluginFlacDecoder=1
-FLAC_CMAKE_OFF= -DWithPluginFlacDecoder=0
+LAME_CMAKE_BOOL= WITH_PLUGIN_LAME
LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
-LAME_CMAKE_ON= -DWithPluginLameEncoder=1
-LAME_CMAKE_OFF= -DWithPluginLameEncoder=0
-MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
-MPG123_CMAKE_ON= -DWithPluginMpg123Decoder=1
-MPG123_CMAKE_OFF= -DWithPluginMpg123Decoder=0
+LIBCUE_CMAKE_BOOL= WITH_PLUGIN_LIBCUE
+LIBCUE_LIB_DEPENDS= libcue.so:textproc/libcue
-MAC4DECODER_DESC= Newest mac4.11 decoder (*.ape)
-MAC4DECODER_CMAKE_ON= -DWithPluginMac4Decoder=1
-MAC4DECODER_CMAKE_OFF= -DWithPluginMac4Decoder=0
+MAC_CMAKE_BOOL= WITH_PLUGIN_MAC
-MACDECODER_DESC= Old mac3.99 ape decoder (*.ape)
-MACDECODER_LIB_DEPENDS= libmac.so:audio/mac
-MACDECODER_CMAKE_ON= -DWithPluginMacDecoder=1
-MACDECODER_CMAKE_OFF= -DWithPluginMacDecoder=0
+MPG123_CMAKE_BOOL= WITH_PLUGIN_MPG123
+MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
-NCURSES_DESC= Ncurses frontend
-NCURSES_USES= ncurses
-NCURSES_CMAKE_ON= -DWithFrontendNcurses=1
-NCURSES_CMAKE_OFF= -DWithFrontendNcurses=0
+NCURSES_CMAKE_BOOL= WITH_APP_NCURSES
+NCURSES_USE= ncurses
-OSS_CMAKE_ON= -DWithPluginOssRenderer=1
-OSS_CMAKE_OFF= -DWithPluginOssRenderer=0
+OSS_CMAKE_BOOL= WITH_PLUGIN_OSS
-QT4_DESC= QT4 frontend
-QT4_USE= QT4=corelib,gui,linguisttools_build
-QT4_USE+= QT4=qmake_build,moc_build,rcc_build,uic_build
-QT4_CMAKE_ON= -DWithFrontendQt=1
-QT4_CMAKE_OFF= -DWithFrontendQt=0
+QT5_CMAKE_BOOL= WITH_APP_QT5
+QT5_USE= qt5=buildtools,core,gui,widgets,qmake_build
-SDK_DESC= Install SDK
-SDK_CMAKE_ON= -DWithHeadFiles=1
-SDK_CMAKE_OFF= -DWithHeadFiles=0
+SNDIO_CMAKE_BOOL= WITH_PLUGIN_SNDIO
+SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
-TAGLIB_DESC= TagLib plugin (recommended)
+TAGLIB_CMAKE_BOOL= WITH_PLUGIN_TAGLIB
TAGLIB_LIB_DEPENDS= libtag.so:audio/taglib
-TAGLIB_CMAKE_ON= -DWithPluginTagLibParser=1
-TAGLIB_CMAKE_OFF= -DWithPluginTagLibParser=0
-VORBIS_LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
-VORBIS_CMAKE_ON= -DWithPluginOggDecoder=1
-VORBIS_CMAKE_OFF= -DWithPluginOggDecoder=0
+VORBIS_CMAKE_BOOL= WITH_PLUGIN_OGG_VORBIS
+VORBIS_LIB_DEPENDS= libogg.so:audio/libogg \
+ libvorbis.so:audio/libvorbis\
+ libvorbisenc.so:audio/libvorbis\
+ libvorbisfile.so:audio/libvorbis
-WAVDECODER_DESC= Decode Wav
-WAVDECODER_CMAKE_ON= -DWithPluginWavDecoder=1
-WAVDECODER_CMAKE_OFF= -DWithPluginWavEncoder=0
+WAV_CMAKE_BOOL= WITH_PLUGIN_WAV
-WAVENCODER_DESC= Encode Wav
-WAVENCODER_CMAKE_ON= -DWithPluginWavEncoder=1
-WAVENCODER_CMAKE_OFF= -DWithPluginWavEncoder=0
+WAVPACK_CMAKE_BOOL= WITH_PLUGIN_WAVPACK
+WAVPACK_LIB_DEPENDS= libwavpack.so:audio/wavpack
-WMA_DESC= WMA decoder plugin
-WMA_CMAKE_ON= -DWithPluginWmaDecoder=1
-WMA_CMAKE_OFF= -DWithPluginWmaDecoder=0
+.include <bsd.port.options.mk>
+.if ${ARCH} == i386
+# error: always_inline function '_mm_load_si128' requires target feature
+# 'mmx', but would be inlined into function 'AdaptSSE' that is compiled
+# without support for 'mmx'
post-patch:
- @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' \
- -e 's|/usr/local|${LOCALBASE}|g' \
- ${WRKSRC}/CMakeLists.txt
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mous/*
+ @${REINPLACE_CMD} '/#define ENABLE_SSE_ASSEMBLY/d' \
+ ${WRKSRC}/deps/MAC_SDK/Shared/All.h \
+ ${WRKSRC}/deps/MAC_SDK/Source/Shared/All.h
+.endif
.include <bsd.port.mk>
diff --git a/audio/mous/distinfo b/audio/mous/distinfo
index bc15d401b457..e967d1ee2fe8 100644
--- a/audio/mous/distinfo
+++ b/audio/mous/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mous-1.1a.tar.gz) = 55826f30567a11d1c54af335b4290329b680c9e64ef9f46c0b7e3a4427414b56
-SIZE (mous-1.1a.tar.gz) = 677884
+TIMESTAMP = 1524993359
+SHA256 (bsdelf-mous-v2.0.1_GH0.tar.gz) = b8866049c225fab2033617908d3c3b353533bc20c274b1fa0d7c034ea1c15cef
+SIZE (bsdelf-mous-v2.0.1_GH0.tar.gz) = 2735960
diff --git a/audio/mous/files/patch-CMakeLists.txt b/audio/mous/files/patch-CMakeLists.txt
deleted file mode 100644
index 16fac8bbd568..000000000000
--- a/audio/mous/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
---- CMakeLists.txt.orig 2012-06-28 14:58:11 UTC
-+++ CMakeLists.txt
-@@ -306,7 +306,7 @@ if(WithFrontendQt)
- RUNTIME DESTINATION bin)
- install(
- CODE "file(GLOB TRANSLATION_FILES \"${PROJECT_BINARY_DIR}/*.qm\")"
-- CODE "file(INSTALL \${TRANSLATION_FILES} DESTINATION ${CMAKE_INSTALL_PREFIX}/share/mous/qt)"
-+ CODE "file(INSTALL \${TRANSLATION_FILES} DESTINATION %%DATADIR%%/qt)"
- )
- endif()
-
-@@ -321,7 +321,7 @@ install(
- )
-
- file(GLOB RESOURCE_FILES "${MOUS_SOURCE_DIR}/resource/*")
--install(DIRECTORY ${RESOURCE_FILES} DESTINATION share/mous)
-+install(DIRECTORY ${RESOURCE_FILES} DESTINATION %%DATADIR%%)
-
- #==== Messages ====#
- message("CMake: " ${CMAKE_VERSION})
diff --git a/audio/mous/files/patch-contrib_ffmpeg-strip-wma_common.h b/audio/mous/files/patch-contrib_ffmpeg-strip-wma_common.h
deleted file mode 100644
index 74fc198e38e8..000000000000
--- a/audio/mous/files/patch-contrib_ffmpeg-strip-wma_common.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- contrib/ffmpeg-strip-wma/common.h.orig 2012-06-28 14:58:11 UTC
-+++ contrib/ffmpeg-strip-wma/common.h
-@@ -1150,11 +1150,6 @@ if(256*256*256*64%(tcount+tskip_count)==
-
- #define CLAMP_TO_8BIT(d) ((d > 0xff) ? 0xff : (d < 0) ? 0 : d)
-
--/* avoid usage of various functions */
--#define malloc please_use_av_malloc
--#define free please_use_av_free
--#define realloc please_use_av_realloc
--
- #define CHECKED_ALLOCZ(p, size)\
- {\
- p= av_mallocz(size);\
diff --git a/audio/mous/files/patch-plugins_CuePack_CuePack.cpp b/audio/mous/files/patch-plugins_CuePack_CuePack.cpp
deleted file mode 100644
index d2ce06fe4ae2..000000000000
--- a/audio/mous/files/patch-plugins_CuePack_CuePack.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/CuePack/CuePack.cpp.orig 2012-06-28 14:58:11 UTC
-+++ plugins/CuePack/CuePack.cpp
-@@ -55,7 +55,7 @@ void CuePack::DumpCue(const string& dir,
- string genre;
- int year = -1;
-
-- char* data = NULL;
-+ const char* data = NULL;
- Cdtext* cdt = cd_get_cdtext(cd);
- Rem* rem = cd_get_rem(cd);
-
diff --git a/audio/mous/files/patch-plugins_CuePack_CuePack.h b/audio/mous/files/patch-plugins_CuePack_CuePack.h
deleted file mode 100644
index b14cae07ca47..000000000000
--- a/audio/mous/files/patch-plugins_CuePack_CuePack.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/CuePack/CuePack.h.orig 2012-06-28 14:58:11 UTC
-+++ plugins/CuePack/CuePack.h
-@@ -1,7 +1,6 @@
- #include <plugin/IMediaPack.h>
- extern "C" {
--#include <libcue-1.4/libcue/libcue.h>
--#include <libcue-1.4/libcue/cd.h>
-+#include <libcue.h>
- }
- using namespace std;
- using namespace mous;
diff --git a/audio/mous/pkg-descr b/audio/mous/pkg-descr
index 1c6e49202112..e2c574078ec9 100644
--- a/audio/mous/pkg-descr
+++ b/audio/mous/pkg-descr
@@ -1,3 +1,3 @@
Mous is a simpe yet powerful audio player.
-WWW: https://github.com/0x02/mous
+WWW: https://github.com/bsdelf/mous
diff --git a/audio/mous/pkg-message b/audio/mous/pkg-message
index 13366928494d..26b904b4a0e8 100644
--- a/audio/mous/pkg-message
+++ b/audio/mous/pkg-message
@@ -1,6 +1 @@
-========================================================================
-
-For mous-ncurses frontend, you can check its usage
-with 'H' after starting.
-
-========================================================================
+You can check mous-ncurses usage with 'H' after starting.
diff --git a/audio/mous/pkg-plist b/audio/mous/pkg-plist
index ac2867a469ec..5cd3d70326d3 100644
--- a/audio/mous/pkg-plist
+++ b/audio/mous/pkg-plist
@@ -1,70 +1,18 @@
+%%CLI%%bin/mous-cli
%%NCURSES%%bin/mous-ncurses
-%%QT4%%bin/mous-qt
-%%SDK%%include/mous/charset/CharsetConvInf.h
-%%SDK%%include/mous/charset/ICharsetConv.h
-%%SDK%%include/mous/core/IConvTask.h
-%%SDK%%include/mous/core/IConvTaskFactory.h
-%%SDK%%include/mous/core/IMediaLoader.h
-%%SDK%%include/mous/core/IPlayer.h
-%%SDK%%include/mous/core/IPluginAgent.h
-%%SDK%%include/mous/core/IPluginManager.h
-%%SDK%%include/mous/core/ITagParserFactory.h
-%%SDK%%include/mous/plugin/IDecoder.h
-%%SDK%%include/mous/plugin/IEncoder.h
-%%SDK%%include/mous/plugin/IEventWatcher.h
-%%SDK%%include/mous/plugin/IFilter.h
-%%SDK%%include/mous/plugin/IMediaPack.h
-%%SDK%%include/mous/plugin/IRenderer.h
-%%SDK%%include/mous/plugin/ITagParser.h
-%%SDK%%include/mous/scx/BufObj.hpp
-%%SDK%%include/mous/scx/CharsetHelper.hpp
-%%SDK%%include/mous/scx/CondVar.hpp
-%%SDK%%include/mous/scx/ConfigFile.hpp
-%%SDK%%include/mous/scx/Conv.hpp
-%%SDK%%include/mous/scx/Dir.hpp
-%%SDK%%include/mous/scx/Env.hpp
-%%SDK%%include/mous/scx/FileHelper.hpp
-%%SDK%%include/mous/scx/FileInfo.hpp
-%%SDK%%include/mous/scx/Function.hpp
-%%SDK%%include/mous/scx/IconvHelper.hpp
-%%SDK%%include/mous/scx/LPVBuffer.hpp
-%%SDK%%include/mous/scx/Mutex.hpp
-%%SDK%%include/mous/scx/PVBuffer.hpp
-%%SDK%%include/mous/scx/RunTimer.hpp
-%%SDK%%include/mous/scx/SemVar.hpp
-%%SDK%%include/mous/scx/Signal.hpp
-%%SDK%%include/mous/scx/Singleton.hpp
-%%SDK%%include/mous/scx/Socket.hpp
-%%SDK%%include/mous/scx/SoftSemVar.hpp
-%%SDK%%include/mous/scx/TaskSchedule.hpp
-%%SDK%%include/mous/scx/Thread.hpp
-%%SDK%%include/mous/scx/UniPinYin.hpp
-%%SDK%%include/mous/util/AudioMode.h
-%%SDK%%include/mous/util/ErrorCode.h
-%%SDK%%include/mous/util/MediaItem.h
-%%SDK%%include/mous/util/MediaTag.h
-%%SDK%%include/mous/util/Option.h
-%%SDK%%include/mous/util/Playlist.h
-%%SDK%%include/mous/util/PlaylistSerializer.h
-%%SDK%%include/mous/util/PluginDef.h
-%%SDK%%include/mous/util/PluginHelper.h
-%%SDK%%include/mous/util/PluginOption.h
+%%QT5%%bin/mous-qt
lib/libMousCore.so
-%%ALSA%%lib/mous/libAlsaRenderer.so
-%%AO%%lib/mous/libAoRenderer.so
-%%CUE%%lib/mous/libCuePack.so
-%%FAAC%%lib/mous/libFaacEncoder.so
-%%FAAD%%lib/mous/libFaadDecoder.so
+%%LIBCUE%%lib/mous/libCueParser.so
+%%FDK_AAC%%lib/mous/libFdkDecoder.so
%%FLAC%%lib/mous/libFlacDecoder.so
%%LAME%%lib/mous/libLameEncoder.so
-%%MAC4DECODER%%lib/mous/libMac4Decoder.so
-%%MACDECODER%%lib/mous/libMacDecoder.so
-%%VORBIS%%lib/mous/libOggDecoder.so
+%%MAC%%lib/mous/libMacDecoder.so
+%%VORBIS%%lib/mous/libVorbisDecoder.so
+%%VORBIS%%lib/mous/libVorbisEncoder.so
%%MPG123%%lib/mous/libMpg123Decoder.so
%%OSS%%lib/mous/libOssRenderer.so
+%%SNDIO%%lib/mous/libSndioOutput.so
%%TAGLIB%%lib/mous/libTagLibParser.so
-%%WAVDECODER%%lib/mous/libWavDecoder.so
-%%WAVENCODER%%lib/mous/libWavEncoder.so
-%%WMA%%lib/mous/libWmaDecoder.so
-%%DATADIR%%/pinyin/unipy.map
-%%QT4%%share/mous/qt/mous-qt_zh_CN.qm
+%%WAV%%lib/mous/libWavDecoder.so
+%%WAV%%lib/mous/libWavEncoder.so
+%%WAVPACK%%lib/mous/libWvDecoder.so